×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

2.1 406 update failed...SYSTEM DOWN

2.1 406 update failed...SYSTEM DOWN

2.1 406 update failed...SYSTEM DOWN

(OP)
I ran the upgrade on my 2.0 system tonight and all 4 units failed.  Now the main IP406 module is continually rebooting and flashing red at the end of each reboot.  How do I proceed?  This is a production system.

702-400-4366 if anyone can help.

RE: 2.1 406 update failed...SYSTEM DOWN

Sounds like the config is corrupt the folowing will allow you to reset to default and reload the ddb.

The DTE port settins are at the end of this message and you will need a serial cable

Erasing the Flash Configuration
This process erases the configuration held in the IP Office Control Unit's Flash memory. Following this action, when rebooted all aspects of the configuration will be return to their factory defaults.

Ensure that you have a backup copy of the IP Office's configuration before performing this action.

Switch off power to the IP Office Control Unit.

Attach the serial cable between the PC and the DTE port on the IP Office Control Unit.

Start the terminal program on your PC. Ensure that it has been setup as listed in DTE Port Settings.

Within a HyperTerminal session, the current settings are summarized across the base of the screen.

Power on the Control Unit and press the escape key every second until you get a Loader message. Below is an example.

P2 Loader 0.7 (4MB-2xLV160 Flash-120nS SDRAM-10)
CPU Revision 0x0501

Enter AT (note upper case). The Control Unit should respond OK.

Enter AT-X2. The Control Unit should respond 0x0200C000H Erase.

Enter AT-X3. The Control Unit should respond 0x02001000H Erase.

Switch power to the Control Unit off and then back on. Within the terminal program you should see various messages as the Control Unit performs various start up tasks. See DTE Port Trace of Defaulted Unit Reboot for an example.

Close the terminal program session.

You can now use Manager to alter and then upload an old configuration file or receive and edit the Control Unit's now defaulted configuration.

You also require an asynchronous terminal program such as HyperTerminal. Configure this for operation via a PC serial port, as follows:

Bits per second: 38,400.

Data bits: 8.

Parity: None.

Stop Bits: 1.

Flow Control: None.

Settings | Emulation: TTY or VT100.

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
I have one of our guys trying what you listed right now.  As as note I was able to open Manager 4.1 and view the TFTP log.  Every 3 or 4 reboots it would list the mac address of the unit then 0.0.0.0 as the IP, then that the unit failed to process the request.  Also, was it okay to go from 2.0 (16) to 2.1.  I have upgraded 3 other units with no problem.  Now this.

Can I upload a 2.1 ip406.bin file from the beginning or will I have to upload a 1.x bin file first.  One of our IP400 30 Port digital stations is also rebooting on it's own.

RE: 2.1 406 update failed...SYSTEM DOWN

Yes OK to goto 2.1 from 2.0

Its a 406 so you can go from any version to any version you like.

If you have done the AT commands correctly and rebooted the sytem by power off on dont forget to change the PC to 192.168.42.10 say then look at the tftp log

Couple questions
1. Have you got the PC with manager set as static IP address. Must do this
2. Is your manager set to 255.255.255.255 in preferences.
Must have this.
3. Have you got you working director set as the location of the bin files.
4. Is the mac address listed on of the ones listed in the bootp on you manager

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
Got the system up.  It is at 2.1 (15).  However, it has the default address and it will not take a change.  When I click save, through any method, it doesn't take.  I also tried opening my "real" config and sending it to the unit.  That doesn't work.  Nor does, opening the default config now on the restored box and clicking restore, at which point I point to my old backed up files.

How do I now proceed to get it from a default installation back to my configuration?

RE: 2.1 406 update failed...SYSTEM DOWN

Can you ping the system on the default address?
Also restart manager some times it locks up.

First goal is get upload and download to with default settings once that is working.
Go off line in manager and get the backed up database and send it to the system.
Then change you PC back to the correct IP address range and you should be off.

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
When we were trying to get the system going earlier we had made a bootp record on our laptop and it was plugged in while we were initiating the at commands.  Would this bootp record be causing any problems?

RE: 2.1 406 update failed...SYSTEM DOWN

No don'tthink so.

Is it possble that the system when it started up agin with 2.1 was connect to your company network and recived an ip address from your dhcp server.


check its not back on you network by changing the pc with manager back to the local network.

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
I cannot even change anything in the default config after the restore.  When I click save, immediately, the manager screen clears, the unit doesn't reboot, and when I open its config back up it didn't take any of my changes.

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
I can ping the unit at 192.168.42.1.

RE: 2.1 406 update failed...SYSTEM DOWN

It sonds like the system is OK.

So when you click open the sytem responds askes for a password and gives you a default database yes or no

If no just restart the PC with manager on it and try again may be manager is down.

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
Tried that.  However, when I use hyperterm and clear everything off, what version of the firmware should come up?  The 1.4 that it came with?

RE: 2.1 406 update failed...SYSTEM DOWN

It will come up with what ever you have loaded it should say version 2.1 when you go open on the manager.

The AT-x2 and X3 clear the Config file and not the bin file.

Once you upgrade the old version is gone.

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
I just cleared the memory again using exc, at-x2.... and restarted the unit.  Now when it comes up it stops at branch2 cpuload, where before it would run through a bunch of things.

Again, manager isn't open and the device isn't on the network.

RE: 2.1 406 update failed...SYSTEM DOWN


One step at a time
So you have done AT-X2 and X3 these must be in uper case to work and then you must power off and on after that do you have a green light on the froni of the unit or not?

Manager will not work until the light is green also take the system off the network if you havent already

RE: 2.1 406 update failed...SYSTEM DOWN

Do you have access to Windows Instant messager it maybe easier to com on this.

My address is lyndon7000@hotmail.com

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
Light is red after doing AT-X2, and AT-X3 and rebooting it.

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
I don't have IM on the machine.  I can call you.

RE: 2.1 406 update failed...SYSTEM DOWN

what country are you in?

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
United States

RE: 2.1 406 update failed...SYSTEM DOWN

This will be expensive for you i'm in New Zealand if you a still keen let me know an email address and ill send you the my number

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
I don't see any other choice.  It responds to the at commands, but stops at the branch2 during a reboot.

ben@ascentsolutions.biz

RE: 2.1 406 update failed...SYSTEM DOWN

Number on its way well see what we can do

RE: 2.1 406 update failed...SYSTEM DOWN

My hero, let us know how it went

RE: 2.1 406 update failed...SYSTEM DOWN

Just a point:

If an upgrade of the main unit has failed, i would not just do the X2 and X3, but certianly also an AT-X to erase the current bin-file in the system!

After this the unit should make an TFTP-request for the bin-file. If it doesn't, i would consider the unit faulty!

Try it!

RE: 2.1 406 update failed...SYSTEM DOWN

Possible feedback on the original problem - once your unit is back up.

When you are trying to send the config from manager to your unit - you need to enter the password on the reboot prompt screen. Which on a defaulted system will be back to the default password of "password".

RE: 2.1 406 update failed...SYSTEM DOWN

(OP)
Thanks for all of the help.  CrashTest1000 got us up and running.  The default "password" was our major problem after getting the unit up the first time.  Right now we are testing all of our remote sites' 4620 phones.  So far all is well.  Again, thank you everyone.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close