×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed
8

IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

(OP)
Hi Guys, does anyone try the one x mobile one x mobile preferred VoIP mode?

I get the error:

VoIP registration failed

The application is operational with the exception of the VoIP feature which is experiencing problems registering with the server. (error 13:0)

I have HTC ONE android.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Do you have a Power User licence enabled on that user?
A mobile worker won't be enough for the SIP part.


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

(OP)
Yes, I did enable the power user.
Also I follow the Avaya Document.

Thanks.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Do you have a FQDN set and the sip remote worker enabled?

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

(OP)
SIP remote worker is enabled.
I turn off the VoIP mode and one x mobile preferred shows green and is fully working.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

That means no VoIP.
What phone do you use?
If android, is it running 4.0 or higher?
If iPhone is it running iOS 5.0 or higher?
Did you do the port forwarding for sip and rtp?

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

(OP)
I have HTC ONE android 4.3.
The Cellphone wireless is in the same internal subnet of IP Office and One x portal server.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

So you have a IP500 and a separate 1XP. You might need to setup Split DNS in your router to make it work.
You only have 1 FQDN but the 1XM app need to get its info from 2 IP's.


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

do you have TCP 5060/5061 forwarded through your firwall to the IPO box (not 1xPortal box)

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You might try it from external over 3G or from a external Wifi, internal is mostly a hassle.


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

(OP)
@Bas1234
Thanks.
I will try Split DNS.

@nnaarrnn
Cell phone wireless is in the same subnet with IPO and one x portal server

If the user use one x mobile voip mode, IP Office will auto generate a SIP extension like IP office softphone?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

No it won't create one in the IPO but it will be a sip phone.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

(OP)
Thanks peter

@Bas1234
I try the Split DNS and one x mobile use FQDN.
But I still get the same error.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

2
2 FQDNs are needed for this. one for the IPO and one for OXP. these can both resolve externally to the same public IP. Even better if the FQDN works on your internal WiFi. that is how we have it set.

You also need STUN or SIP ALG and possibly RTP ports forwarded.

Mine works like a dream in the office on WiFi (iOS) but outside is a litle more of an issue. Not put enough time into yet though TBH.

Jamie Green

Avaya Registered Specialist Engineer

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

(OP)
Thanks guys.
I figure it out
You guys means I need get a public IP so I will get it and try later.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You do indeed need two FQDN's and split DNS.
I have done one yesterday and works great.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

I'm confused on this one (as I am at first with all of this). Where in the app do I input my second FQDN?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

In the One-X Poetal admin - it's not in Manager.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

I only see the XMPP domain in there, not one for the VoIP mode on the onex mobile preferred?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

For the 1xp for ipo there is only 1 fqdn you can fill in so on the inside (outside can be done by all routers) of the router you need to have a split dns so that can do port based dns. For flare you can fill in two fqdn's but those still have to be the same.


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi

Just trying to set this and its causing me a little grief.

Ive got the call back action working but I can't seem to get the Voip setup correct. I'm a little confused and need seem help.

At the moment I have a Cisco firewall with ports 5222/5244/8444 forwarded to to the 1x Server.

If someone has set one up could they kindly push me in the right direction

Many Thanks

Nick

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

A little push is to read the installation manual smile
All you have done now is the one-x part.
The voip part needs more port like 5060 and 5061 and RTP ports configured in the IPO (sip remote worker)

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

@tlpeter

Where do you put specify the second FQDN

Thanks

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

2
@nicka29 The first FQDN is for One X Portal and you enter this on XMPP in one X Portal Admin under configuration / IM/Presence and XMPP Domain. The Second FQDN you put in the IP Office LAN1 or LAN2 / VoIP Tab Domain Name where you have setup your Auto Create Extn/User and SIP Registrar and RTP Port etc. If your testing you One x Mobile internally make sure that your DNS has the FQDN pointing the right place, i.e. 1 to the One X Portal server and one the Phone System LAN 1 or LAN 2 Internal IP . To work externally you can have both FQDN's Pointing the same address just make sure on your firewall you remember to point the One X Portal Ports to the One X Portal IP and the Voip Stuff the Phone System as One X Portal doesn't handle to VoIP side

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

@HPBSYS

Top man

Thanks for taking time out and writing the response. I will test in my office Monday

Thanks

Nick

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Did you guys manage to get this working?

We have a very similar situation where everything is working perfectly internally but no VOIP calls can be made when not on the local network.

I can however IM and access my voicemails but when I try to make a call I recieve "unable to make VOIP calls".

Split DNS and firewall rues have all been setup and checked.

So close yet so far it seems!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You have to have an FQND that is reachable over the public internet. Remember when testing if you are off site you will mostly get no ping or tracert replies as the network provider will not be supplying them like they would locally. If you get a successful Telnet then you know you have this routed correctly and reachable.

If It's Not Broken...Don't Fix It!

Stephen Webb
Norstar, BCM and IP Office Engineer

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi all, just a question... Are two FQDNs must be the same..??? One in 1XP and one in the IPO manager..???

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi folks,

We are having the same problem, I think I understand the messages but just want to be clear.

Right now 1xmobile and IPO have two separate and distinct IP addresses, both of of which regular public IP addresses (no NAT). Every port listed in the installation manual is open now to both (although we may lock them down afterwards and require VPN authentication).

IPO is on 1xx.xxx.xxx.12 with no DNS entry.

The "portal" is set as 1xmobile.ourdomain.com

It would seem that I need to register IPO as something like ipo.ourdomain.com and then enter that in the appropriate location in Manager. Since I have no NAT and right now we have all the ports opened to both IP addresses I should be good. One item that still confuses me is that you only enter the 1xmobile address in the iPhone preferences, there is no second spot for the IPO server info. Does that app take care of that?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Yes the app takes care of it. I have two "free" dyndns pointing to same public IP.

I think most have trouble forwarding and opening the right ports

ACSS-SME

http://interconnexionsld.ca/

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Everyone, thanks for the help, the second DNS entry worked. Things are working great for WiFi in the office and at my home (which is connected via a physical sonic wall), but we can't get it complete a call over LTE even though all the ports are open (and even with a VPN connection running on the iPhone). When we make a call, it rings on the other end, but as soon as that user picks up the iPhone user gets a quick busy and it shows "Call Failed." Any ideas?

Our other questions/issues are:

1) Once you have answered a call on VOIP we can't figure out how to get it "back" to the handset (like you can do on a twinned call).

2) If one has saved emails viewable in one-x portal, the Events icon constantly flickers.

3) We are trying to figure out a dialing rule that only applies to phone numbers from the phones internal address book (i.e., append 9).

Thanks for the help.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

I just tested this on WiFi and had the same problem, so I'm guessing it has something to do with the routing/firewall rules. Working that angle now.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

i understand the 2 fqdns

1 is put in the xmpp

2 is put in the lan1 domain name on the ip office

BUT, where do i put 2 fqdns on the iphone app?

it only asks for SERVER ID, which fqdn do i put in there???

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

the one that is forwarded to the one-x
that is what works for me and I only use 1 FQDN but I must have gotten lucky maybe

Joe W.

TeleTechs.ca
FHandw, ACSS (SME), ACIS (SME)


“This is the end of the world, make sure to buy your T-shirt before it is too late"
Original expression of my daughter

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You enter the One-x FQDN in the phone.
You need to point those FQDN's to an external IP address of the router/firewall and this is port forwarded to the IPO.
Both FQDN's also need to be entered in the DNS server for using it internally.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

I'm confused. The way i connect the one-x mobile is with ip and not fqdn.
In one-x portal xmpp domain i put the ip address of the server which one-x is running and in my phone i put that ip address.
Tested and working local wifi and with vpn client on the phone from external.
One question i have is, how to disable direct media path off if sip extensions are not created.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

What you are doing is wrong and can cause speech issues!
You need to use FQDN's and split DNS.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

@chrisag You HAVE to use a FQDN for internal and external access to both the IPO and the One-X

You need two FQDNs pointing to your single external IP, and the necessary ports forwarded through any firewalls to point to both the IPO and the One-X.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

@nnaarrnn,@tlpeter, iknow about the 2 fqdns but i'm working it with a different way. Really peter speech issues because i'm using ip and not fqdn.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

If the basics are not alright, how are you going to solve problems?

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

I will add that if you do not use FQDN's and configure split DNS then yes you can have speech issues so stop being a smart@ss!

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

peter you misunderstood me it was not my intension to be a smart@ss i'm just saying that i don't understand why not doing it with ip and i must use fqdn.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

OK, then i am sorry smile
You must use split DNS so that when you are internal that the FQDN is resolved and oyur speech stays in the internal network.
When you use the external IP address it will go outside and back in.
That is what you should avoid.
The FQDN is resolved internally and when you are outside then the FQDN is pointed to the external IP address and port forwarded to the IPO and One-X server.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Ok i can understand the need of fqdn when you are on a public network but my post was referring to private network.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You do need it on the internal network otherwise it wants to go to the external IP address.
Split DNS (configured on the internal DNS server) prevents this.
Now it wants to go outside and back in and that can cause speech issues.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Thats correct it's in the manuals, but on one-x the xmpp domain i put private ip and not domain name. This way i think it will work for private network.
For public net i have to agree with you.
Thanks for your time.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi there,

I'm having a shocker with this... i've now got it to the point where everything is working but no sound on making a call. When I look at the call details the "Remote" ip it's trying to get to is the internal IP of the phone system, but i'm working external & have put the external DNS name (onex.blahblah.co.uk) in the phone settings. Like I say it's green all the way except for the RTP part. So here's what i've done.

Juniper ssg 140 ( <-- not a fan at all....)
Created 1 VIP for the extra external IP address this is using, in the VIP is

5222 to One-X server
5269 to One-X Server
8444 to One-X Server

5060 to IPO
5061 to IPO
49152-53246 to IPO

On One-X server under the IM\Presence Configuration i've added onex.blahblah.co.uk then restarted One-X afterwards
On IPO under LAN2 (as that's what is being used) I've given it a STUN ip to go fetch its settings, of which it returns with the same IP as the onex.blahblah.co.uk resolves to & Partial Cone NAT <-- Summat like that anyway (I'm boring myself with this so sorry clown )
I've put onex.blahblah.co.uk into the Domain part under VOIP tab also on LAN2

Fire up the phone, it goes greeen & the little handset flashes 3 green bendy stripes & it all looks good, but when I make a call & press the Details button it's the internal IP of the remote side it's trying to get back to not the external IP or domain name?

Anybody seen this happen before?
Ta

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

49152-53246 to IPO, another one that will get hacked within 48hours


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Indeed, use a different port range.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

fair enough, didn't know that was a problem? Still need find out why it's trying to get back to internal IP when i've not set that anywhere, it must be coming from the remote end of either one-x portal or ipo.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi All Some help please and confirm if I have done this correctly...
I have two FQDN's one for IP office (ipo.xxx.com) resolving to the Lan1 address and one for the application server (ucserver.xxx.com) resolving to application server IP address. Both those IP's and NAT'ed to the 1 public IP 41.x.x.x

I have added the IP office FQDN (ipo.xxx.com) to the Lan 1 Voip tab domain name field and the UCserver FQDN to the application server
XMPP address field.

My one x on GSm (3g) works fine with call back but my VOIP fails to register.

What am I doing wrong?
Should the 2 FQDN's point to one Ip address internally?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

I'm pretty sure that your (and a lot of others too) problem is with port forwarding/opening. Make sure the right type of ports are either/or/both opened/forwarded (UDP).

ACSS-SME

http://interconnexionsld.ca/

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Thanks Yanblank, I will double check that with the network provider.
However in terms of the configuration on my side does what I mentioned sound about right?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You still need to setup the sip remote worker and make a user a power user.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Thnaks TLpeter,
I have added them as power user and selected remote worker. I also selected h323 Remote extension enable and SIP Remote extension Enable on my Lan 1 port nly. Not using the Wan.Is thios sufficient. ? Ive followed the manual to the T

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Did you enable the VOIP option too for this user?

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Yes the you mean the "enable mobile VOIP client" on the user tab and also on the One X app? if so yes.
It still doesnt register. Im using split DNS It may be the firewall?? Thanks TLPeter

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi All

im new on this, ive problem to test avaya one x mobile even using internal lan, phone says voip is not configure

this is my topology
192.168.18.11 is my ipo 500 box
192.168.18.7 is my one x portal server

ive already create fqdn on my dns server, lets say avaya.mydomain.com which ip should i put here ? ipo500 box (18.11) or onex portal server (18.7) ip ?
and plese let me know what should i do next ? im very new and next step by step instruction

thanks

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You need to have to FQDN's one for the IP office and one for the Onex Server.see above.
The IP office FQDN should go on the ip office "system "VOIP tab" under "domain name"
The One X server FQDN should go on the one portal server under the XMPP address.
both of those DNS entries should resolve to a public IP. The public IP should NAT to your internal One XPortal Server IP local IP
One your phone use the one x server Domain name.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi VikeshR

thanks for your reply

ive already create 2 record on my dns as your instruction, avaya.mydomain.com with ip 192.168.18.11(ipo500box) this i already configure on LAN 2>voip> domain, and onex.mydomain.com with ip 192.168.18.7(onex portal srv) that i configure on onexportal xmpp column, but when i try its still showing partially connected on my onex mobile android
what need to be done after this ?

i appreciate for help :)

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Check the firewall ports, Check if remote worker is setup on IP office correctly

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

actually i just want to tested on internal lan (wifi), our local firewall is open for everything on local network

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Okay so you entered the correct domain name on your device? you are pointing your phone to the one portal server xmpp address?
Check on system monitor if you can trace why the SIP client is not registering. Try the IP office video softphone. Use the same credentials and login and see if you can fully connect.
Check in system monitor under SIP Phone status.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

VikeshR, the video softphone does not work as a remote worker.
It is a problem in the port forwarding, split DNS or settings on a or the devices.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Yes I Know but he wants to test internally. I had this issue internally as well. The SIP phones could not register properly.
So even the Video soft phone did not register locally. Once that was fixed then I was able to troubleshoot the VOIP mode issues.
I merely want to see if any sip phone can register to the IP office....

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi Vikesh

Okay so you entered the correct domain name on your device? yes, i'm put domain instead of ip address
you are pointing your phone to the one portal server xmpp address? yes and im able to login,


Check on system monitor if you can trace why the SIP client is not registering.
so maybe this is stupid question, in what menu i can check this :)



Try the IP office video softphone. Use the same credentials and login and see if you can fully connect.
Check in system monitor under SIP Phone status.
YES i can login using softphone on PC , and see my avayaphone id login out

this is my configuration




RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You need to enable SIP remote worker.
The H.323 remote worker is for the 9600 phones and does not work for One-X Mobile.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

hi tlpeter

you mean i need to enable SIP Remote Ext Enable ? should i disable H323 ext enable, or i can just leave it like that ?, for remote worker i already activate it on the user menu

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

When you use 9600 phones as remote workers then you need to leave it on.
If not then you can turn it off as these are two different solutions.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

tlpeter

sorry i cant get you, my status is green (fully connected) when i disable voip, but when i try to call, to ekstenal or interneal. my avaya handset also initiate a call, from my mobile i just can see its connected, but i cant hear any sound from my mobile

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

TL is correct you need to activate SIP remote worker and leave the leave the h323. Disable the auto create SIP extension.
Tick the block for the TLS

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

VikeshR
how to activate SIP remote worker ? is this menu should i enable on user ?



still its not working, any other suggestion ?

this configuration on vaip tab on LAN 2

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

WOW SUPERRR !!! ITS WORKING
thanks amriddle01 :),
next step i will use vpn client on my mobile phone and connect to my office network, so i dont need to publish my ipo,

anybody try this method before ?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi You dont need to use your VPN client. You need to set up Split DNS and nat your public IP to your internal IP pointing to the one x server FQDn and set up the correct port fowarding rules on the router. Check the manual for the list of ports

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi VikesR

in this case i need to register new domain and pointing to my local ip of 1x portal ,is it work if supposed i just use public ip instead of fqdn, on xmpp configuration and on avaya mobile software ?

thanks

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

You will need the FQDN on the XMPP setting on the onex server. the FQDN on that one X server will need resolve to your internal DNS and External DNS so for e.g
public ip :
41.x.x.x = domain.avaya.com
internal IP:
172.x.x= domain.avaya.com
xmpp address: = domain.avaya.com

one the mobile app under server id you will use domain.avaya.com.
Public IP 41.x.x.x NAT to 172.x.x.x

Hope this helps

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hallo all,

im succesfully publish my onex portal to public, and also configure split dns, All feature its working fine when im on local network like VOip iM etc, but when im on outside network, im also be able to login, but still there is some issue with voip (cannot register), what ive done its I fwd TCP (only tcp) port http,icmp, voip, 5222,5244, 5269, 8444 and 8080 TO one-x portal, and also fwd TCP port 5060, 5061 to IPO500 server, but i still not be able to active voip, im i wrong, or should i put any other port

thanks

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi @amriddle01 & @digicx,

Please, you can re-publish the answer about what fields should be enabled to get a VOIP Call on ONEX MOBILE on iPhone.
Thanks in advance.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi @amriddle01 & @digicx,

Please, you can re-publish the answer about what fields should be enabled to get a VOIP Call on ONEX MOBILE on iPhone.
Thanks in advance.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi XIXOUNI

maybe this will be help

on user field
profile > power user ( you need to have a licensed for this)
Enable (thick) Softphone, onex portal service, remote worker, mobile voip client

on system field, Voip Tab
(tick) H323 Gatekeeper enable
(untick) Auto-create extn

SIP
(tick) SIP trunks enable, sip regiter enable, Sip remote ext enable
(untick) Auto create Extn/User

Domain : put you full fqdn address

(tick) UDP, TCP, TLS

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

hi all
this is my topology

192.168.18.11/ipo.mydomain.com (IPO 500 box)
192.168.18.7/onex.mydomain.com (one x portal server)

for ipo.mydomain.com i set up on IPO, under voip tab on domain names
for onex.mydomain.com i set up on xmpp record on one x portal server,

both of fqdn is resolve internal ip from inside network, voip call and everything is working fine inside

for publishing my ipo ive done this,
public ip exp 9.1.1.1 , registering in to two fqdn , ipo.mydomain.com & onex.mydomain.com

for nat and firewall ive done this
all req to port tcp 5060 and udp 5060 and tls 5061, i will fwd that req to internal ip 192.168.18.11 (IPO server)
all req to port tcp 5222, 5244.5269.8444.8080, i fwd in to internal ip 192.168.18.7 (onex portal server)

but still im having problem when connecting from outside network, i can be able to login only voip still having an issue, the rest feature is fine,
any other thing should i do to make voip call working ?

i appreciate your input all, im almost insane dealing with this guy ;)

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Are all opened on the router? Does the router support hair-pinning
5060 TCP UDP TLS
5061 TCP TLS
1719TCP
1720TCP
http 80 tcp


Ports 5222, 5269 and 8444 need to be opened on the customer's firewall or router, if the mobility client is to be used on a cellular network or if external XMPP access is required.
Ports 8086, 9094 and 9095 need not be opened on the customer's firewall or router.
Please see page 45 of the user manual

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

VikeshR, you forgot the RTP ports that needs to be opened too.
IF you do not then no speech at all.

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

@vikesR @tlpeter

sorry for asking again and again, i still cant see the clear picture here,
as you said we need to open like this, CMIIW
5060 TCP UDP TLS
5061 TCP TLS
1719TCP
1720TCP
http 80 tcp
49152-53246 RTP port
ALL OF THIS PORT IS FWD TO IPoffice IP addreess , is it correct ?

and then since i want to publish to outside network i also open this like below :
Ports 5222,5269,8444,8086,9094 and 9095
all of this port is forwarded to one x portal, is it correct ?

we are using sonicwall and yes its support hair-pining,

appreciate your help


RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Since the app uses port 5060 and the sip trunk uses port 5060, will there be a conflick? IPO is on lan1, which is the companys network and the sip trunk is on lan2, which is a vlan.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hello all, I have my IPO R9 and a UCM module with power users working perfect on local site with VOIP mode and I dont have a DNS server and I do not own a domain so I was wondering if it is possible just to make power users work via VPN clients based on android, Im right or not? or that is the only way to get users working remotely?

Thanks in advance

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

"49152-53246 to IPO, another one that will get hacked within 48hours"

What port range is safe to use instead please?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

A different range smile

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Wasn't sure if there is a particular range I should avoid so they don't clash. Maybe a range people use as not likely to..

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Check the documents and you will find a range.
Discussing it here is food for hackers smile

BAZINGA!

I'm not insane, my mother had me tested!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

So after spending some time trying to get OneX mobile to work externally. OneX was working internally so this is what i had to do to make it work externally.

Under our network firewall i opened up all the listed ports on the Avaya documentation.

Only the RTP, SIP, and H323 ports are forwarded to the IP Office IP address.
XMPP, UDP, TCP, TLS ports point to the the OneX IP address.
SIP ALG needs to be off

OneX Portal (http://[IPADDRESS]:8080/onexportal-admin.html)configuration:
>Configuration>IM/Presence/XMPP Domain Name: onex.domain.com

IP Office Manager Configuration:

>System>System> Enable Sofphone HTTP Provisioning: Enable
>System>LAN>VOIP>SIP Trunks Enabled: Enable
>System>LAN>VOIP>Auto Create Extension: Enable
>System>LAN>VOIP> SIP Remote Extension Enabled: Enable
>System>LAN>VOIP> Domain: Public IP/Domain (I used our routers public static IP since customer does not have domain)
>System>LAN>VOIP> UDP, TCP, and RTP (use these for the firewall and port forwarding)

>System>LAN>Network Topology>STUN Server Address: Usually provided by SIP Provider or search for "avaya free stun server" there is a bunch out there some on this forum as well

>System>LAN>Network Topology>Public IP: Router IP/Public IP

I used these to test the fuctionality of the client from the external network (instead of having to use the mobile client to test)
Login credentials= OneX Mobile user login and password(power user/telecommuter)
https://[IPADDRESS]:8444/rest/my/im-info
https://[IPADDRESS]:8444/rest/my/sip-info

This is what it would show on the browser (If you see the below information then you are done with the configuration)
<sip-info>
<identity>111@[EXTERNAL-IPADDRESS]</identity>
<userName>111</userName>
<password>123123</password>
<displayName>JohnD</displayName>
<privateAddress>[INTERNAL-IPADDRESS]</privateAddress>
<publicAddress>[EXTERNAL-IPADDRESS]</publicAddress>
<udpPrivatePort>XXXX</udpPrivatePort>
<udpPublicPort>XXXX</udpPublicPort>
<tcpPrivatePort>XXXX</tcpPrivatePort>
<tcpPublicPort>XXXX</tcpPublicPort>
<tlsPrivatePort>0</tlsPrivatePort>
<tlsPublicPort>0</tlsPublicPort>
<payloadType>101</payloadType>
<signalingQos>136</signalingQos>
<voiceQos>184</voiceQos>
<videoQos>184</videoQos>
</sip-info>


Hopefully this helps!

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi agsr4ever

I  have some issues in one-x portal.

 WE configured everything as per doc and the above threads.

One -x Mobile is working perfectly in voip mode in internal wifi.

We are able to call internal and external from one-x mobile(Android & IOS) in VOIP Mode.

But when we tried this in 3g voip is registering  we are able to call .

But there is no voice Path both side.

There is no firewall here in this setup.

I have 2 fqdns publicly resolving . One for one x and other for ipoffice.

i configured split dns with the public ip. Wan cable is directly connected to one-x server.

I forwarded the ports 5060(TCP & UDP),5061 and RTP(49152-53246) ports to ipoffice from One-x Server.

Please help me to sort out this issue

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Quote (I forwarded the ports 5060(TCP & UDP),5061 and RTP(49152-53246) ports to ipoffice from One-x Server):



2 Days and your system will be hacked!!!!

Change the Port Number range NAT in LAN1 or 2 from 49152-53246 into 53000-53246 in the Manager, and close down the public range also to 53000-53246

Make sure the router supports NAT Loopback, and that when you ping your FQDN from internal LAN your reply is from the public WAN IP.


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi Bas1234

Thanks for the reply

i changed the ports in LAN1 NAT to 53000-53246.

In the ip office firewall we have to do any comfiguration.

I selected open internet in the lan 1 firewall selection.

i only use the lan 1 for this setup/

through vpn its working.

but from external nw we are able to call but no sound each side.


please reply me.

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

In the Avaya Manager did you changed the NAT ports?
On LAN1 > Network Topology > fill in 198.27.81.168 on the STUN server.
Save config, reopen it, then hit RUN STUN and wait, it should fill in the public WAN IP addr and NAT type.
If it returns with blocking firewall you problem is in the firewall, it should return with "???? Cone NAT"


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

having same issue, but for my side VoIP ports are blocked by Government is there any solution for that too ?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Change ports is the best thing to do, so choose a port 5010-5090 or any other free port. Voip ports use 5060-5061 so changing these and they wouldn't know. It should work for you aswell


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed


I was thinking that mobile phone app is using same 5060 port. i will check it.
but i have few other sip tunnels do i need to change that everwhere ?

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

The app uses 5000 and up for rtp and the sip port provided by the ipo using stun.


___________________________________________
It works! Now if only I could remember what I did...

Dain Bramaged (Avaya Search tool http://tinyurl.com/bas1234 )
______________________________________

RE: IP Office 9.0 one x mobile preferred VoIP mode: VoIP registration failed

Hi I am new to IPO & to this forum, hope someone will help me. I was reading this thread and found my problem mentioned @jglongisland "When we make a call, it rings on the other end, but as soon as that user picks up the iPhone user gets a quick busy and it shows "Call Failed." Any body have come across this issue and resolved this?

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close