Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Echo problem on IP phones

Echo problem on IP phones

Echo problem on IP phones

I have a IP406  v1.4(22) and I have 15 4612 IP phones running on a isolated subnet (not mixing voice and data) all phones have there own switch port 100MB HD. And ping times are about 1ms from the IP406 to the phones. All are set to G.711 Ulaw 64K, with fast start, out of band DTMF and allow direct media path enabled.
    All the IP phones are experiencing intermittent echo with outside calls. Any thoughts or recommendations will be appreciated.


RE: Echo problem on IP phones

Yes we have the same issue with 6 IP phones.

However we are running over a WAN.

Our problem occurred when we moved from G729 to G711. my suggestion for you is to try G729 on a couple users and see how it goes.

I know this is not a solution but it could be interesting to see if it helps.

In our case we suspect it’s a combination of IP and PSTN. Will keep you updated on how it goes.

By the way have a number of IP phones on IP Office, which don't have any echo issues.

RE: Echo problem on IP phones

G711 is uncompressed & IIRC does not have any echo cancelation.

As per the earlier posts trey G729a

RE: Echo problem on IP phones

Make sure the phones are up to the latest firmware.

4606's, 12's and 24's do not have a switch port, they are a hub port.  The main difference being half duplex ethernet - not that it causes echo or anything.

Neither G711 or G729 have echo cancellation.  It's not a function of the compression codec.

I assume you are on analog trunks?  This is usually where echo occurs.  Try tweaking the DB levels on your trunks...

RE: Echo problem on IP phones

For what it is worth... I have 16 IP phones at remote construction sites.  We also use an IP Officed 406.  Our remote connections range from Cable modems to PTP Wireless using either the Motorola Canopy system or Proxim Quickbridges.  Twice I had a very bad echo in two of the phones with specific users.  As a test I deleted the phones and users from the system and allowed the autocreate function create the phones when they were reconnected while I recreated the users.  The echo went away on both of them.  I performed no other changes.  Why this worked I have no idea.  I have always found that degradation in our connections causes voice quality to go down, but never have we had echoing start other than the two instances I referenced above.  

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close