×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Excel Attachment in outlook will not open

Excel Attachment in outlook will not open

Excel Attachment in outlook will not open

(OP)
I have a user that everytime he gets an e-mail with an excel spreadsheet as an attachment, he cannot open it. It brings up Excel, all the tool bars and menu options, but no spreadsheet. Only a grey screen. If he clicks on save as before looking at it, it comes up fine. Happens with excel attachments from anyone. Any ideas??

RE: Excel Attachment in outlook will not open

I've seen this several times myself and it can happen with any of the office products. The easiest and surest way to fix this is to uninstall Excel and the reinstall Excel (and of course then reapply any SRs and patches). This appears to happen because the call from outlook to the program has become courpt.

RE: Excel Attachment in outlook will not open

The only problems I've had with opening attachments is when the 'Open' key for the associated app. is wrong (e.g. pointing to an old location of Excel, missing quotes so it gets confused by spaces in filenames, etc.)

I've got a regini file that I use to fix any problems that I find, but you can check yours by going to:

HKEY_CLASSES_ROOT\Excel.Sheet.8\Shell\Open\Command

(The "8" means Office 97, I assume that's what you're using)

This key should be set to the location of excel.exe.

e.g. "C:\Program Files\Microsoft Office\Office\EXCEL.EXE"

And the key:

HKEY_CLASSES_ROOT\Excel.Sheet.8\Shell\Open\ddeexec

Should be set to: [open("%1")]


No promises, but it works for me!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close