×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Gentran:Director xprocess fail to run in unattended mode

Gentran:Director xprocess fail to run in unattended mode

Gentran:Director xprocess fail to run in unattended mode

(OP)
We have a trading partner who sends/receives X12 messages without the ~ segment terminator via Geis. Gentran's xprocess is not functioning as it is supposed to. I.E manual execution by hand is handled successfully but when run from unattended mode , it failed. In the mean time , we are manually adding & removing the ~ by hand.

To recap the situation, in outbound, Geis expects the message to be terminated with CRLF. Running xprocess with -8 , -2 in unattended mode, did not result in removing of the ~, in fact no transformation of the file at all. Running xprocess from command mode, the utility ran successfully but with side effects.

-2 parameter resulted in line terminated with CR
-8 parameter resulted in line terminated with= LF

According to Gentran knowledgeBase, -2 is supposed to result in CRLF, but the manual and our experience shown that it resulted in CR only. When the message sent to Geis, Geis aborted the transmission due to line terminator was not CRLF. As a last resort, we used -1, but found out later that the -1 parameter replaced a character with another character, but not drop a character. e.g. before ~CRLF , after xprocess, CRCRLF, which do not solve the transmission to Geis problem.

In inbound, Gentran expects the message to be terminated in ~ for translation to begin. Our client receives both X12 & EDIFACT, Xprocess -1 or -3 automatically adds the ~ to both X12 & EDIFACT messages, not X12 messages only.

so, our questions are
1- why the xprocess failed in unattended mode? anyway to make it work or workaround it?
2- anyway for xprocess to add CRLF to text
3- anyway for xprocess to add ~ to x12 messages only

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close