×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Personal Web Server & MTS

Personal Web Server & MTS

Personal Web Server & MTS

(OP)
I tried installing MS Personal Web Server on my Windows 98, which requires that MTS is installed.  Upon installation, I receive the following two errors (one after the other):

=========================
An unknown error occurred while making MTS specific changes to the system registry
Error Code = 0x80004005


AND

Setup of "Transaction Server Core Components" failed.  The specific error code is 0xfee670.

Setup will continue but the component may not function properly.

=========================

What does this mean?  How can I fix it?  I have no programs running.  I have a Dell Dimension XPS T650r, whith a 650 Mhz Pentium 3, 128 MB RAM, and a large hard drive.  What can be the problem?

Ryan ;-]

RE: Personal Web Server & MTS

Hi

The problem lies not in your system requirements but it is a microsoft problem.
The fault lies in a specific dll named mtssetup.dll
The version you should get is 1997.11.532.0 (Right click on the dll in Windows Explorer & select the version tab)

If you currently do not have that version then you can download the correct version from Microsoft's web-site
& replace the dll.

You have to uninstall PWS & MTS if they're still installed.

Replace the dll with the correct file.

Run set-up again & it should work fine.

Hope this helps
caf

RE: Personal Web Server & MTS

(OP)
Will do!  Thanks a lot.

Ryan ;-]

RE: Personal Web Server & MTS

I have this soame problem. I discovered the 'cure' (as described by caf and in MS KB Q246081) but the symptoms are unchanged. Any other ideas pls?
MP

RE: Personal Web Server & MTS

Answering my own query (maybe it'll help someone).
The workaround was to run the ms-pws setup program twice. (You may have to remove all traces of previous installation attempts first, by running ms-pws setup and selecting 'remove all...'.) Choose 'Custom' installation and select only the MTS server first time. Then repeat, choosing PWS option second time.

RE: Personal Web Server & MTS

Same as above, i tried both solutions,#2 MTS and same error without mtssetup.dll not even loaded. the date on my cd is 1998.01,543.0, I'm trying to set up my win98 home pc to act like a server so that i can develope without being connected to a server and keeping that line/connection open during development. I'm using an Access DB, Coldfusion 4.5 and Dreamweaver. Is PWS the right answer for my need? or should i use Apache?

Help me...I have been struggleing with this for weeks!!

RE: Personal Web Server & MTS

(OP)
Here's the fix to your problem directly from the Microsoft KB (the link doesn't work right straight from Tek-Tips, so copy the entire URL and paste it in the address bar):

http://support.microsoft.com/support/kb/articles/Q214/6/44.ASP?LN=EN-US&;;SD=gn&FR=0&qry=mtssetup&rnk=3&src=DHCS_MSPSS_gn_SRCH&SPR=MSALL

By the way, I use PWS with ColdFusion Server 4.5 and develop on a number of platforms, including DreamWeaver, ColdFusion Studio, with several backends, like Microsoft Access.  The performance is great and the solution provides me with a solid environment to test and develop applications.

Ryan ;-]

RE: Personal Web Server & MTS

Thanks Ryan, you also answered my similar question on the Coldfusion forum (duncanmcl@aol.com). It worked, although my CD Dll had a leter version date (1998.01.543.0) and one would think a later version on a fix would work 1st time around.  Bottom line...thanks...when you are in limbo land its no fun as i'm sure your aware...since you also started this same forum question!

Is it possible to email you directly and build on your success of using PWS/MTS Coldfusion Dreamweaver and Access.  For me, it seems PWS and MTS are working with Coldfusion server single user (administrator), I registered my data source and identified myself with a password.  From CF Studio I'm trying to open it (DB)in the database tab...where is the tab? then at least I can start dev some Q's.  You see, I'm still fumbling with the environment, not even into my application yet!  

RE: Personal Web Server & MTS

(OP)
I frequently check the ColdFusion forum for posts.  Simply post any question you may have and I will try to answer it in a timely fashion.

Ryan ;-]

RE: Personal Web Server & MTS

Special thanks to Mike for the same issue here.  Installing in two steps was the trick.  Found this thread with google.com

A forever admirator! ;)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close