×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

VB 6 & MTS Performance Issues

VB 6 & MTS Performance Issues

VB 6 & MTS Performance Issues

(OP)
Hi..
We are having a serious peformance problems calling an MTS object from a base Client i.e. (it takes about 10-20 seconds to Created a reference to the MTS Dll.)
Configuration is.. MTS & SQL Server on same machine and part of a NT 4.0 cluster.
Client's are base clients located on a Terminal Server box connecting to the MTS Components via DCOM.
We have narrowed the problem down to the CreateObject call from the client. Declaring the object AS NEW is just as slow.
e.g. Dim obj as component.
     Set obj = CreatObject("Dll.Classname")..  This line of code hangs for at least 10 seconds.. However, once the MTS Object is created, calling this line of code again is Istantaneous..
We would greatly appreciate any help on the matter...!

RE: VB 6 & MTS Performance Issues

Hi,
Even i am facing exactly same problem with the same configureation. In our case, CreateObject is taking more time than New. Pl. Do let me know if u find any solution .

RE: VB 6 & MTS Performance Issues

(OP)
Result !!!

We have resolved this problem by looking at a number of areas..
Firstly we changed the way in which our MTS objects were instantiating other MTS objects. We now use 'CreateInstance" and NOT "Dim As New" or "CreateObject"
Secondly we looked at the binding order of the Network cards on both of the servers in the cluster. This yielded the most dramatic improvement in performance.
Have a look at <http://support.microsoft.com/default.aspx?scid=kb;en-us;Q246038>

We now have a usable system ! x-)

Good luck to all
Colin

RE: VB 6 & MTS Performance Issues

We had the same performance problem, taking 30 seconds or more.  We solved the problem by reordering the network cards.  The middle tier, where MTS is installed, has 2 network cards.  We tried everyting we could think of until we found the following solution.  The solution was found at http://support.microsoft.com/default.aspx?scid=kb;en-us;Q288886.  Following this simple solution worked wonders.

Hope this works for you.
sueo

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close