×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Mitel phone stuck on DHCP Discovery

Mitel phone stuck on DHCP Discovery

Mitel phone stuck on DHCP Discovery

(OP)
During the pandemic,we configured some telesales staff so that they could take MiTEL 5320e desk phones home...I believe they are using Teleworker licences and are connected to their routers over ethernet via a PoE injector.

All have been working absolutely fine for ages until suddenly one day last week, two of them, the phones don't boot beyond DHCP Discovery...and they just stay on that screen and get no further
All other users are unaffected

For these two users all other devices are getting IP addresses Ok from the router, including laptops, phones etc...just the Mitel 5320e phones cannot get past DHCP Discovery
It maybe conincidence but the two users affected have SKY routers. like I say has been working for months...until suddenly last week...these aren't the only users with SKY though..others with SKY continue to work OK
I was considering trying a different router for the purposes of testing but I know SKY are fussy about which 3rd party routers would work

Any ideas ?

Many thanks in advance!

RE: Mitel phone stuck on DHCP Discovery

Have you made any router changes at a higher level? Although i am guessing everyone would be impacted had you but worth looking

Many thanks Richard

RE: Mitel phone stuck on DHCP Discovery

(OP)
They are SKY routers so no, I wandered if a firmware update was the case but SKY deny that they have updated them

RE: Mitel phone stuck on DHCP Discovery

Odd - Hard to diagnose aswell with them being at home. Maybe try the obvious and replace phones. I also seem to remember reading that the 5320e phones sometimes have issues as these are the Gigabyte ones vs the 5320's (I think they pass through 100MB). Aside from that bit stuck if no firmware changes have been made

Many thanks Richard

RE: Mitel phone stuck on DHCP Discovery

(OP)
Agreed, very frustrating! I can confirm we have replaced the phones (5320e) and also the PoE injectors too...problem all points to the routers I think but SKY support say no

RE: Mitel phone stuck on DHCP Discovery

Sky are pretty useless tbh - but if all others are non sky and no issues, certainly points that way

Many thanks Richard

RE: Mitel phone stuck on DHCP Discovery

(OP)
Well we have other users on SKY without issues but of course not everyone has same router hardware depending on their broandband package, age of subscription etc etc

RE: Mitel phone stuck on DHCP Discovery

If you have hard-coded the Teleworker IPv4 address into the handsets then they only need limited DHCP options - address, mask & gateway should be enough. Every consumer broadband router will supply these plus DNS server IPv4 addresses (and usually a DNS suffix) unless they have been configured not to or some L2 security has been applied.
It's not just DHCP pool starvation is it? Do these users have open Wi-Fi and all the DHCP leases have been consumed?
I'm guessing you have tried the obvious of rebooting the Sky routers?
Can you try alternative IP phones at the users location?


RE: Mitel phone stuck on DHCP Discovery

(OP)
OK so the workaround to get these users working has been to assign a static IP address to the phones (5320e) - once this is done then they work fine

Someone also suggested changed ethernet mode on the router from Gigabit to Fast Ethernet but we haven't tried that

RE: Mitel phone stuck on DHCP Discovery

Question to be asked is why this doesn't give out DHCP properly and open a ticket with Mitel so that the reason can be determined. That way others may not run into this issue

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close