×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Contact US

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Cal Micros Workstation 6 issue

Cal Micros Workstation 6 issue

Cal Micros Workstation 6 issue

(OP)
I have a Micros Workstation 6 with Windows 10 on it and I'm trying to cal it to a Res 3700 5.7 server with no luck.

I've reset the terminal to defaults and when I run the Cal Client Installer I get the server inputed but when it starts the install it shows the below picture right away.

Any ideas?

Thanks

RE: Cal Micros Workstation 6 issue

(OP)
Got it to install by changing file permissions, however RES won't start, you get a message that says "error opening AppStarter.cfg"

RE: Cal Micros Workstation 6 issue

To properly reset the workstation you need to do it from the bios, not the windows reset

RE: Cal Micros Workstation 6 issue

(OP)
What is the best way to reset it from the BIOS? It's a workstation 610

Thank you

RE: Cal Micros Workstation 6 issue


Performing a Factory Reset from BIOS

To perform system recovery from the BIOS:

Enter the BIOS.
Connect a USB keyboard to the Workstation 6.
Power on or restart the workstation.
Press F2 immediately after pressing the power button and before the BIOS splash screen. You can press F2 repeatedly until the Configuration Utility starts. If the workstation boots into the operating system without starting the utility, restart the workstation and try again.
On the Advanced tab, use the arrow keys to select Special Configuration, and then press Enter.
Select Factory Recovery, and then press Enter.
Select Enabled, and then press Enter.
Press F10, select Yes, and then press Enter to save the configuration changes and exit the configuration utility. The Workstation 6 automatically restarts.
On the Choose an Option screen, click Troubleshoot.


For the 610:
On the Troubleshoot screen, click Reset your PC, and then click Next.
Click Fully clean the drive, and then click Reset to finish restoring factory settings.


For the 620 and 650:
On the Troubleshoot screen, click Factory Reset.
Select Y to reset the Windows partition to factory default.
When the restoration is complete and the workstation restarts, you can begin the operating system setup.

RE: Cal Micros Workstation 6 issue

After you do the clean install you need to setup windows for the client install before doing the install I have the staging guide if you need it

RE: Cal Micros Workstation 6 issue

(OP)
That did it!

thank you!

RE: Cal Micros Workstation 6 issue

Can we ghost image a ws 610/620/650 or even Tablet 721?

RE: Cal Micros Workstation 6 issue

I am having similar problems with a WS6 610. Would you mind posing the staging guide? Thank you!

RE: Cal Micros Workstation 6 issue

@POSINSAM If the machine has been used before you should do the BIOS reset. That usually clears up every Workstation 6 install problem. What is your email and i will shoot you a link to the staging guide.

RE: Cal Micros Workstation 6 issue

it has been used in the past and I reset it successfully. I am having problems with the ports not being available. (Specifically com 4 for idn

thanks

RE: Cal Micros Workstation 6 issue

I will send the guide over but I remember coming across this issue. Going to have to physically look how we overcame it as I cant remember. Are you trying to run 2 IDN printers from one workstation?

RE: Cal Micros Workstation 6 issue

Actually, wildbar, no, I’m not. I just happen to be out of the comport to RS 232 adapters for ws6 and I’m trying to use IDN which should be simple but for these particular terminals, all of which are 610’s, it’s not simple at all. In fact the whole thing is stressing me out because most of the stuff in the confidence test is not available. It all works, except for the idea import, but it’s not in the confidence to us. Very strange.

Maybe a helpful piece of information, the server I’m trying to attach them to is on 5.7 MR6. I’ve never put a 610 on a version that high. Shouldn’t have anything to do with comport installations or anything like that I would assume but…who knows

The Win32 Cal that I took off the server running 5.7 MR6 does not work Or at least seems to have something to do with the problem, because I could use an older version from another server and I can get some of the port to work (only some) I have to use an older version also interesting.

Any advice would be fantastic, but thank you so much for sending me that staging document.

RE: Cal Micros Workstation 6 issue

Well, No doubt I was doing a few things wrong according to the staging document you sent, (thanks again by the way) I have always used the win32cal version from the server and not the version that resides on the 610 itself. No luck however, as the confidence test still shows no active devices. Are you aware of any driver install files I may not be aware of? The staging document does not mention anything and I have never seen this. The devices seem to work for the most part (cash drawer, customer display, etc..) however the com ports seem to be busy with some other deice. (specifically com 4 (IDN))

Any thoughts? Thanks

RE: Cal Micros Workstation 6 issue

So it seems if I disable Cal, I can get the Micros diagnostic to test correctly. It looks like either CALor OPS is taking ownership of COM4 and not allowing anything to print to it (including OPS). So as soon as I enable CAL, which Enables OPS, I am locked out of the port

RE: Cal Micros Workstation 6 issue

Are you getting an error when you try to print?
i just went through the Oracle site and the only Workstation 6 IDN print issue seems to be a very rare occurrence of the firewall causing an IDN print issue. The suggested solution is disabling the workstation windows firewall and testing.
Ill just throw these in from the site as well...
Testing an IDN Printer
On the IDN Print tab, you can test connectivity and print line-by-line at an IDN Roll Printer with an ID of 1. You must have an RS422 (6 pin to 8 pin) cable.

Connect the 8-pin end to the workstation COM port 4.
Connect the 6-pin end to the printer IDN port 1.
Select COM4 from the Output Port drop-down list.
Press Test Ports.
Verify that the Tx Bytes field and the Rx Bytes field increments and that the printer continues printing line-by-line.
Press Quit Test.



RE: Cal Micros Workstation 6 issue

Thanks for your reply. Yep. I’m familiar with all that. Yes. I get print errors. Typical stuff. I can successfully test the idn ports with that utility I get all the lines printed until I start cal/ Ops. Then the utility comes back with comport 4 is denied.

RE: Cal Micros Workstation 6 issue

Check that NTIDN.sys resides in both system32/drivers and syswow64/drivers.

RE: Cal Micros Workstation 6 issue

Hello, I have a Micros 3700 Server running RES V5.7 MR6 w/10ea 5A workstations. Recently, I purchased a used 610 with Windows 10.

I am looking for the Staging Document which lead me to this post and any advice to successfully run CAL.
Would someone be kind enough to send it to me?

RE: Cal Micros Workstation 6 issue

What is your email?

RE: Cal Micros Workstation 6 issue

I could not find a way to send you an email directly or DM you.
cmotley[tt]2203
[pre]at[pre] 
gee mail

RE: Cal Micros Workstation 6 issue

@Wildbar - Hello, I am looking for the Staging Document to setup a workstation 6 win. Would u be kind enough to send it to me?
cmotley2203@gmail.com

RE: Cal Micros Workstation 6 issue

@Wildbar- Can i get the ws6 staging also, thanks in advanced.
ngogo109@gmail.com

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close