×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Reinstall Unixware on H4K V1

Reinstall Unixware on H4K V1

Reinstall Unixware on H4K V1

(OP)
Hello there,
We have a customer got problem on their H4K V1 system (yes, it is still running on V1) for UW7 failure to startup. We have tried to get back those MO disc but there was no one with UW7 installer (it should be in Area J, right?).
We finally get with old PC that running Windows XP with SCSI board, to install PCHI V2.1R3 and get copy of H4K V1 software to rebuild system hard disk (as well as MO disc). We then use this system disk to boot up but it is looping to reload in "Starting Unixware...".
We tried to break in menu for different installation selection but there is no improvement.
Please anyone may advice what I can do next, thanks for your support.

RE: Reinstall Unixware on H4K V1

I would use PCHI to create a MO disc containing the Unixware install files. Then I would copy the files from MO to :SCR: area on RMX HD.

I would connect to the V24 port with Procomm/Hyperterminal/Whatever using a crossed cable, either 115200 8N1 or 38400 8N1 depending on processor card, and (from LAN connection) give ADP a soft restart (or BP, if monoproc).

Some output should soon appear on the terminal program. You can press ESC to get the menu. From there you can start a reinstall from SCR area.

RE: Reinstall Unixware on H4K V1

(OP)
My testing is as follow;
- prepare system hard disk with customer MO disc;
- format and init. SCSI hard disk
- copy AREA E to AREA I data from MO to system hard disk
- create new MO disc with PCHI (H4K V1; P30252N4313B00004)
- copy AREA J data from MO to system hard disk (AREA K) that consist UW7 installer (right?)
- reboot H4K system with this system hard disk, connecting V24 port with cross cable for monitor
- terminal display shown bootup information, and looping on to "Starting Unixware..." with A1 reboot
I have tried to press "ESC" for menu to select different options (1 ~ 4) but no improvement. Is there any step get wrong or missing? or any hardware/software conflict/not supported?

RE: Reinstall Unixware on H4K V1

Focus on why you can't use ESC to get the menu. Sounds like a cable/comms problem.

RE: Reinstall Unixware on H4K V1

(OP)
No, the cross cable is working normal and I can use ESC to get the menu but there is no improvement no matter what I chose.

RE: Reinstall Unixware on H4K V1

Post the v24 log file.

RE: Reinstall Unixware on H4K V1

(OP)
It generally bootup until message shown as "Starting Unixware...", then A1 will be reboot and repeat again.

RE: Reinstall Unixware on H4K V1

Are there any log files on the system you have access to, such as HISTA? I am wondering if the system is throwing memory errors. I had an old Hicom 300 once that was rebooting like that, and I was on vacation 1000 miles away on a remote laptop seeing memory parity errors all over the place. I specifically put in a ticket to the vendor to replace the memory module because it was throwing errors. I was gone for over a week after that and during the course of the week they replaced the processor board, daughter board, hard disk, etc, but they never replaced the memory module. When I got back I asked them if they replaced the memory module and they said "no, we have never had a failure like that." After further argument, I called up the service manager, said "I am the g*d d*mn customer and I asked you to replace the memory module, nothing more, now send me the f*c*ing memory module!". I got the memory module, replaced it, and the problem went away immediately. I them proceeded to remove all the parts they changed out and put everything back to original (except the memory module) and told them I was shipping everything back and was not paying for any parts or labor other than the memory module and the time it would have taken to install it. Saved the company $10K in un-necessary repair costs because the regular tech was on vacation and they had sent the idiot backup who couldn't think for himself and just did whatever the voice on the phone told him to do.

So the moral of the story is, if you can see any log files from either UW or RMX look to see if there are memory errors showing up right before the system reboots. :)

Don Bruechert, Voice Comm Analyst II
CareTech Solutions @ Holy Family Memorial
Manitowoc, WI, USA

RE: Reinstall Unixware on H4K V1

(OP)
It is weird for me, let me check it next week

RE: Reinstall Unixware on H4K V1

(OP)
I checked that there is only one RAM module (S30807-Q6706-X-2) mounted on controller board, I did not find exactly the same RAM module but it got failure on boot up if I changed another similar RAM module (S30807-Q6706-X100). I have no manual to verify if it is compatible or not.
I refer to original hardware to capture V24 output as well as HISTA log that hang on UNIXWARE installation.

RE: Reinstall Unixware on H4K V1

Well there are a couple of things I see in the HISTA log that may or may not be relevant - one of them is some of the older system boards used to have an actual battery on them to keep the clock powered up when the system is shut down - it is possible if there is a battery on the board (it could be like 2/3 the size of a CR123 battery or it could be a coin cell. If you find one I would replace it just for peace of mind. I have had issues with those batteries going bad on the old Hicom 300 stuff, and V1 is probably not too far off of that. There is a battery failure warning in HISTA but it says datetime is valid after that.

The other thing is your codeword is invalid, but that would normally just block you from being able to do any administration and would not make the system spontaneously reboot. You probably have a SIM of some type on that board - I am not familiar with the old hardware. You could try cleaning the connections on that, and use DIS-CODEW from RMX if you can get to it to see what it says. You may have to re-enter it with ADD-CODEW (copy and paste is best, but not sure what media it's on). Again, the codeword usually doesn't mess with telephony - it just blocks you from changing anything.

Those are 2 more guesses to look into. If there is a battery it might be weird and you might have to go to Batteries Plus or something to get it if you're lucky.

Don Bruechert, Voice Comm Analyst II
CareTech Solutions @ Holy Family Memorial
Manitowoc, WI, USA

RE: Reinstall Unixware on H4K V1

(OP)
The battery is used to support controller board that installed on testing system, it is supposed to be dry-out so I have to change system clock every time on system power up.
As I only boot up A1 for testing, it could not enable dongle by CODEW. I have tried to bootup both ADP & SWU but SWU will be reboot whenever A1 restart, and Unixware may still not able to start installation.

RE: Reinstall Unixware on H4K V1


It's definitely not the codeword, or the date/time. UW install does not care about such things.

I wanted to see the V24 log to check which prompts you were answering for the UW install, but you only attached a jpg. I assume you are telling it to start a first installation from SCR partition. But then it doesn't get very far.

Strange problem.

1 - I suppose maybe there could be some corruption in the SCR files - could you rebuild the SCR area on a MO and copy again to SCR ? STA-INIT SCR area and copy from MO to HD.

2 - I don't remember which SCSI discs were supported on V1/DPC5/DSCXL but it used to be a 9GB disc I think. The original UW did not behave well with problems on the SCSI bus. Could you possibly be using an unsupported HD?

3 - Don's call with parity errors was a good one and I have seen that error more than once - but unfortunately not the problem in this case as HISTA is clear. Nevertheless, if you have DPC5s, I would swap the processors and try again - this could be a HW error - the interrupt is strange. Don't forget to swap the jumpers on the DPC5 to tell the old SWU it is now the ADP (jumper 6, but that's from memory). Just check jumpers on both cards.

If you build a new HD with PCHi, UW install should start and complete automatically after ADP has booted - there should be no reason to even enter the BIOS on a fresh install if everything is working properly.

Proper V24 log would still be interesting to see.

RE: Reinstall Unixware on H4K V1

(OP)
With helping by other person to get with another set of control card with memory module for further testing, it can reinstall Unixware on boot up with new system hard disk that created by PCHI finally.
It is amazing as I have never thought of H4K control card (with memory module) issue as it seems to be running normal (both ADS/SWU), thanks everyone and it is very good experience to me!!

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close