×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

MiVB 9.0 Upgrade Issue

MiVB 9.0 Upgrade Issue

MiVB 9.0 Upgrade Issue

(OP)
Hi All,

I have been away from working on Mitel's for a while and had to do an upgrade over the weekend from 7.0 SP1 PR1 to 9.0 SP2 but encountered an issue whereby the Migration tool never got past the Migrating Bootloader step, it simply says "In Progress"

The system audit & db backup passed with no issues. I did try twice but got the same result so aborted the upgrade to 9.0 SP2 and got them to 8.0 SP3 whilst I figure out what went wrong.

This morning I have got a 3300 out of our stores and have attempted to upgrade from 8.0 SP3 to 9.0 SP2 and I get the exact same issue so there is clearly something wrong on my laptop.

Extract from log file

Successfully copied backup file from /vmail/temp/db/archive/Ipera3k.dba to C:\Database Backups\lab3300

**************************************************************
Database Backup Complete - Elapsed Time: 00:02:02
**************************************************************

No resiliency detected, continuing Migration.

Migrating software version from ICP 14.0.3.22 to MIVB 9.0.2.16

**************************************************************
Bootloader Migration Starting - Elapsed Time: 00:02:02
**************************************************************


Have any of you guys had any similar issues? I haven't yet attempted to install manually as I would prefer to find out why the migration tool is not working as expected.

Thanks

RE: MiVB 9.0 Upgrade Issue

Assuming Physical

what hardware is it

If I never did anything I'd never done before , I'd never do anything.....

RE: MiVB 9.0 Upgrade Issue

(OP)

I should have included the hardware type!

MXeIII with 1Gb RAM and RAID with 2x HDD

RE: MiVB 9.0 Upgrade Issue

How long did you wait?

The upgrade to 9.0 takes hours and it sometimes seems like nothing is happening.

RE: MiVB 9.0 Upgrade Issue

(OP)
@sarond

The migration tool was at the 3rd step Migrating Bootloader for almost 2 hours before I cancelled it and gave up. The audit and DB backup steps completed fairly quickly.

The system was still up and operational and nothing was happening on the console.

RE: MiVB 9.0 Upgrade Issue

The transfer of the bootloader files takes only minutes. I would make sure you don't have any firewalls blocking FTP between you and the controller.

RE: MiVB 9.0 Upgrade Issue

Disable your Firewall completely on your connecting PC and connect straight to the front of the controller. That section literally takes less than 2 minutes. I upgraded a few from a Windows 10 and Windows 7 machine! On a physical controller its normally around 1.5Hours (depending on the size of the databases controller I have compelted are MxeIII and a CXiII) from start to finish on the Log View timer that is ticking upwards.
Have you got a RS232 serial plugged in to the front as well incase it provdes more info?

RE: MiVB 9.0 Upgrade Issue

FYI

This was taken from an upgrade to v9.0SP2 on a Cxi-II. There is a section where the licencing failed as it was disconencted from the network, therefore I licenced it offline for the time being as I had done that initially!

LOG VIEW BELOW continued after the backup section (I have altered the AMC Records for obvious reasons)

DATA SAVE Completed.

Successfully copied backup file from /vmail/temp/db/archive/Ipera3k.dba to C:\backup.tar

No resiliency detected, continuing Migration.

Transferring the software load to the system.

Deleting backup file

Creating directories for SW load transfer

Transferring SW load. Please be patient. This may take a while.

Transferring file bootrom.bin

Transferring file bootrom.bin.md5

Transferring file bootrom.s3

Transferring file bootrom.s3.md5

Transferring file config.cxii

Transferring file config.cxii.md5

Transferring file mivb-image-cxii.manifest

Transferring file mivb-image-cxii.tar.gz

Transferring file mivb-image-cxii.tar.gz.md5

Transferring file mlb-installer-image-cxii.cpio.gz.u-boot

Transferring file mlb-installer-image-cxii.cpio.gz.u-boot.md5

Transferring file mlb-installer-image-cxii.manifest

Transferring file modules-cxii.tgz

Transferring file modules-cxii.tgz.md5

Transferring file System.map-cxii

Transferring file System.map-cxii.md5

Transferring file u-boot-cxii.bin

Transferring file u-boot-cxii.bin.md5

Transferring file u-boot-cxii.srec

Transferring file u-boot-cxii.srec.md5

Transferring file uImage-cxii.bin

Transferring file uImage-cxii.bin.md5

Transferring file uImage-cxii.dtb

Transferring file uImage-cxii.dtb.md5

Transferring SW load completed.

Reboot to install the new MIVB load

Resetting the 3300

Trying to reconnect ...
Trying to reconnect ...
Connected to the system
Phase 1: Formatting VxWorks Extended Partition and creating EXT4 linux partition...


Phase 1: run partprobe...


Phase 1: Copying linux images from vxworks vmail partition to temporary ext4 partition...


Phase 2: Formatting and partitioning target drive...


Phase 2: run partprobe...


Phase 2: Creating ext4 filesystems on rootfs1, rootfs2 and recovery partitions...


Phase 2: Copying all linux images to rootfs1...


Phase 2: Validating MD5 checksum of all the linux images in rootfs1 partition...


Phase 2: set bootcmd to boot installer images from rootfs1 partition...


Phase 3: Creating last partition...


Phase 3: Creating ext4 filesytsem on vmail partition...


Phase 3: copying all linux images from rootfs1 to vmail partition...


Phase 3: Validating MD5 checksum of all the linux images in vmail partition...


*** Phase 4: Unpacking into rootfs1...


*** Phase 4: Unpacking into rootfs2...


WRL install complete!


Trying to reconnect ...
Trying to reconnect ...
Trying to reconnect ...
Trying to reconnect ...
Trying to reconnect ...
Trying to reconnect ...
Trying to reconnect ...
Trying to reconnect ...
Trying to reconnect ...
Connected to the system
Installation completed successfully.

Installation complete.


Starting up services...
Starting up services...
Starting up services...
Starting up services...
Starting up services...

MiVB is up.


FTP service started successfully.

All passwords changed successfully
Sync with AMC: ARID = xxxxxxxx, default AMC address
Licensing failed
Sync with AMC: ARID = xxxxxxxx, default AMC address
Licensing failed

Trying to reconnect ...
Connected to the systemSync with AMC: ARID = xxxxxxx, default AMC address
Licensing failed

Server manager Online Licensing failed. Offline licensing is now attempted.

Updating License and Options.
Transferring Restore File...

Transferring backup file C:\backup.tar
Transfer Complete...
Sending Restore Command...

Restoring DB In Progress ...
System reset to complete DB restore.

Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
Restoring DB In Progress ...
System performs final reset to complete DB restore.

Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Waiting to connect ...
Connected to the system.
DB Restore Successful.

Starting up MIVB Service ...
Starting up MIVB Service...

RE: MiVB 9.0 Upgrade Issue

(OP)
Thanks for the replys guys.

I have finally had time to look into this today and got the upgrade to work on my lab 3300.

The cause? I had created a repository in the following location on my machine, C:\Program Files (x86)\Mitel\MiVoice Business Repository and this location contained a folder called 9.0.2.16 this was simply the extracted files from the download site which is where I pointed the migration tool to.

For some reason the migration just would not happen so I pointed the migration tool to the extracted folder in my download directory and voila upgrade worked first time.

No idea why it did not like the repository location I created? But thought I would post my findings just in case anyone else has a similar issue. (Unlikely but you never know)

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close