×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

No RTP in both ways QSIG

No RTP in both ways QSIG

No RTP in both ways QSIG

(OP)
Hi everyone,

Some of you helped me in my previous post (long post-dial delay), and I am very grateful for that, but I'm afraid that I need your knowledge and wisdom once again.

The scenario is the same. My CS1K v5 is interconnected with an OpenScape Branch (Siemens) through a QSIG to allow internal calls between users in both systems. Now the issue is about RTP. When Nortel calls Siemens there's no RTP stream in both ways. Calls establish but without audio. When Siemens initiates the call this problem doesn't happen, only when Nortel begins the communication.

I've captured traces and I guess I identified the problem. Siemens end doesn't know how to proccess the SDP sent by Nortel. This is the media in the INVITE to Siemens:


--as2f5
Content-Type: application/sdp
Content-Length: 298

v=0
o=root 495347066 495347066 IN IP4 10.103.0.254
s=iGW OpenScapeBranch V9 R1.25.04-1
c=IN IP4 10.103.0.254
t=0 0
a=sbc:1
a=partnerfsm:3518609726_0_2340_0_0
m=audio 51754 RTP/AVP 0 8 18 101
a=rtpmap:0 PCMU/8000
a=rtpmap:8 PCMA/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -
a=ptime:20
a=sendrecv

--as2f5
Content-Type: application/QSIG;version="iso"
Content-Length: 80

\b\0026\002\005\004\003\200\220\243\030\003\251\203\232\034$\221\252\006\200\001\000\202\001\000\213\001\000\241\026\002\002\001\000\002\001\000\200
CXXXX MXXXX\036\002\201\203l\006I\2002633p\006\31114561\2251\001\2002\001\201
--as2f5--


Siemens answers with SIP/2.0 415 Unsupported Media Type and once established there's no RTP in both sides. My question is: Can I disable "application/QSIG" in Nortel CS1K? I want to send only G729, and both 711.

I've been searching in Element manager but can't find it, only the others codecs. MIME, Multipart Media Encapsulation, is sending "application/SDP" , which is fine, and ""application/QSIG":

MIME Multipart Media Encapsulation, Type: multipart/mixed, Boundary: "as2f5"
[Type: multipart/mixed]
First boundary: --as2f5\r\n
Encapsulated multipart part: (application/sdp)
Content-Type: application/sdp\r\n
Content-Length: 298\r\n\r\n
Session Description Protocol
Boundary: \r\n--as2f5\r\n
Encapsulated multipart part: (application/qsig)
Content-Type: application/QSIG;version="iso"\r\n
Content-Length: 80\r\n\r\n
Q.931
Last boundary: \r\n--as2f5--


How can I ged rid of this?

If you need the whole pcap just tell me and I will attach it.

Thank you everyone again.

RE: No RTP in both ways QSIG

So you're using QSIG trunks for a SIP endpoint/interface?

RE: No RTP in both ways QSIG

(OP)
Hi Rickypone,

Yes, there's a QSIG trunk between the CS1000 and Siemens SIP endpoint.

When Siemens calls Nortel there is RTP in both directions.

I'm sure it's application/qsig that originates the issue.Siemns endpoint only needs SDP to proccess media.

How could I disable application/qsig in Nortel side? I want Nortel only to send SDP.

Thanks.

RE: No RTP in both ways QSIG

There is something wrong with your connection
QSIG is a TDM Protokoll
RTP is only used by VOIP like SIP or H323
Let show us your Routing and Trunk script

RE: No RTP in both ways QSIG

capture the DCH messaging for a call going both ways & have a look to see if there is any diffenernce

Remember if it doesn't work hit it harder

Scott UK

RE: No RTP in both ways QSIG

All your traces will not help you
You must install a SIP Trunk on your CS1000 if the other end serve SIP

RE: No RTP in both ways QSIG

AvayaHE finished where I was going. You need to build a QSIG dchannel in the Seimens.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close