Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


re: can't see mssql.1 in dos window on 2008r2 - help : (

re: can't see mssql.1 in dos window on 2008r2 - help : (

re: can't see mssql.1 in dos window on 2008r2 - help : (

A little off topic, but I'm trying to use robocopy to copy a file located in mssql.1\mssql\data directory in 2008R2.
The problem is that robocopy uses dos convention, e.g., program files -> progra~1, etc. The problem, is that I can see 100, 90 and 80 directories, but I can't see mssql.1 when viewing from a dos window (cmd). I've checked all the security file attributes / permissions and there is nothing to indicate why it's hidden from view. I also tried allowing for protected system files to be viewed, but not dice. Any help would be appreciated. Thank you.

RE: re: can't see mssql.1 in dos window on 2008r2 - help : (

Maybe databases are placed in other folder.
If you have SSMS right click on DB Choose Properties and go to Files.
Then check where the physical files are placed.

Borislav Borissov
VFP9 SP2, SQL Server

RE: re: can't see mssql.1 in dos window on 2008r2 - help : (

attn: bborissov,

thanks for the reply, the database i'm trying to copy is in fact located in:
c:\progra~1\micros~1\mssql.1\data. the problem, is that I can't see the mssql.1 directory - it doesn't show up in the dos window, only the other directories do: 80, 90 and 100. of course, i can see and access mssql.1 from the gui and i have yet to understand or figure out how the mssql.1 dir is hidden as it doesn't appear to be a permission/ownership/acl issue.

attn: fredericofonseca,
thanks for the reply as well. robocopy is now an internal command on 2008r2, where as before, for example on 2000 server, it was an actual external app. i did try and use long file names, as i was curious if that worked, but it did not recognize, e.g., program files (x86) etc.

RE: re: can't see mssql.1 in dos window on 2008r2 - help : (

part of the mystery solved - it turns out you can use long file names with directories, however robocopy hiccups if there is a space in the directory name, e.g., program files (x86). apparently the work around is to use quotes around the file path name, making sure to add one space before the closing quote - this makes about as much sense as windows 8.


robocopy "C:\Program Files (x86)\adobe\acroba~1\ " d:

RE: re: can't see mssql.1 in dos window on 2008r2 - help : (

It's not a workaround; it's the way that DOS works, and always has. An unquoted space in a DOS command marks the end of the current value/parameter. You need the quotes to let DOS know that everything between quotes, including spaces, is the actual path.

Now, as for the space at the end, I haven't found any documentation.

With business clients like mine, you'd be better off herding cats.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close