Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here


2948 Help!

2948 Help!

2948 Help!

Just got a 2948 off the bay and would like to know if someone could help me out here.


It's running 4.4(1) , - How can i get the latest IOS?


does that version not have the http web interface? I went to setup the HTTP web management and that was not an option.


when i goto enable and run a dir bootflash i get this.

Console> (enable) dir bootflash

No such file

8653168 bytes available (2750096 bytes used)

4) This is what i have
Console> (enable) sh ver
WS-C2948 Software, Version NmpSW: 4.4(1)
Copyright (c) 1995-1999 by Cisco Systems, Inc.
NMP S/W compiled on Jan  6 1999, 18:02:54
GSP S/W compiled on Jan 06 1999, 12:50:40

System Bootstrap Version: 4.4(1)

Hardware Version: 1.0  Model: WS-C2948  Serial #: JAB0306009D

Mod Port Model      Serial #              Versions
--- ---- ---------- -------------------- ---------------------------------
1   0    WS-X2948   JAB0306009D          Hw : 1.0
                                         Gsp: 4.4(100)
                                         Nmp: 4.4(1)
2   50   WS-X2948G  JAB0306009D          Hw : 1.0

       DRAM                    FLASH                   NVRAM
Module Total   Used    Free    Total   Used    Free    Total Used  Free
------ ------- ------- ------- ------- ------- ------- ----- ----- -----
1       65536K  16029K  49507K  12288K   3838K   8450K  480K   90K  390K

Uptime is 0 day, 1 hour, 31 minutes

If anyone can assist me with the flash for this guy i would give many thanks :)


RE: 2948 Help!

Is it CAT OS or IOS? Post a complete sh ver...looks like the image name is cut out...


RE: 2948 Help!

4981_1> (enable) sh ver
WS-C2948 Software, Version NmpSW: 4.4(1)
Copyright (c) 1995-1999 by Cisco Systems, Inc.
NMP S/W compiled on Jan  6 1999, 18:02:54
GSP S/W compiled on Jan 06 1999, 12:50:40

System Bootstrap Version: 4.4(1)

Hardware Version: 1.0  Model: WS-C2948  Serial #: JAB0306009D

Mod Port Model      Serial #              Versions
--- ---- ---------- -------------------- ---------------------------------
1   0    WS-X2948   JAB0306009D          Hw : 1.0
                                         Gsp: 4.4(100)
                                         Nmp: 4.4(1)
2   50   WS-X2948G  JAB0306009D          Hw : 1.0

       DRAM                    FLASH                   NVRAM
Module Total   Used    Free    Total   Used    Free    Total Used  Free
------ ------- ------- ------- ------- ------- ------- ----- ----- -----
1       65536K  16042K  49494K  12288K   3838K   8450K  480K  112K  368K

Uptime is 0 day, 1 hour, 15 minutes
4981_1> (enable)

RE: 2948 Help!

I'm guessing CAT, this is my boot.

0:00.570748: No gateway has been specified
0:00.571447: Please set TftpServer variable to do tftp downloads
0:00.572918: ig0: 00:90:21:98:ff:fe is
0:00.573518: netmask:
0:00.573857: broadcast:
0:00.574208: gateway:
WS-X2948G bootrom version 4.4(1), built on 1998.12.28 10:22:22
H/W Revisions:    Fin: 2    Head: 6    Board: 1
Supervisor MAC addresses: 00:90:21:98:fc:00 through 00:90:21:98:ff:ff (1024 addr
Installed memory: 64 MB
Testing LEDs.... done!
The system will autoboot in 5 seconds.
Type control-C to prevent autobooting.
rommon 1 >
The system will now begin autobooting.
Autobooting image: "bootflash:cat4000.4-4-1.bin"
Starting Off-line Diagnostics
Mapping in TempFs
Board type is WS-X2948
DiagBootMode value is "post"
Loading diagnostics...

Power-on-self-test for Module 1:  WS-X2948
Status: (. = Pass, F = Fail)
processor: .           cpu sdram: .           temperature sensor: .
enet console port: .   nvram: .               switch sram: .
switch registers: .    switch port 6: .       switch port 7: .
switch bandwidth: .
Module 1 Passed

Power-on-self-test for Module 2:  WS-X2948
Port status: (. = Pass, F = Fail, ? = no GBIC)
 1: .   2: .   3: .   4: .   5: .   6: .   7: .   8: .
 9: .  10: .  11: .  12: .  13: .  14: .  15: .  16: .
17: .  18: .  19: .  20: .  21: .  22: .  23: .  24: .
25: .  26: .  27: .  28: .  29: .  30: .  31: .  32: .
33: .  34: .  35: .  36: .  37: .  38: .  39: .  40: .
41: .  42: .  43: .  44: .  45: .  46: .  47: .  48: .
49: ?  50: ?
Module 2 Passed

Exiting Off-line Diagnostics

Cisco Systems, Inc. Console

Enter password:

%SYS-5-MOD_OK:Module 1 is online
%SYS-5-MOD_OK:Module 2 is online
%PAGP-5-PORTTOSTP:Port 2/1 joined bridge port 2/1

RE: 2948 Help!

Easiet way to tell...
switch#conf t
switch(config)#set ?

If it gives you a bunch of options, then it's Cat OS, in which case someone like viperegg can help...


RE: 2948 Help!

Well the bootflash:cat4000.4-4-1.bin kinda lets me know it's a CatOS.

Set ? =

set alias                    Set alias for command
set arp                      Set ARP table entry
set authentication           Set TACACS authentication
set banner                   Set message of the day banner
set boot                     Set booting environment variable
set cam                      Set CAM table entry
set cdp                      Set cdp, use 'set cdp help' for more info
set cgmp                     Set CGMP (enable/disable)
set enablepass               Set privilege mode password
set help                     Show this message
set interface                Set network interface configuration
set ip                       Set IP, use 'set ip help' for more info
set length                   Set screen's number of lines (0 to disable 'more')
set logging                  Set system logging configuration information
set logout                   Set number of minutes before automatic logout
set module                   Set module, use 'set module help' for more info
set multicast                Set multicast router port
set ntp                      Set NTP, use 'set ntp help' for more info
set password                 Set console password
set port                     Set port, use 'set port help' for more info
set prompt                   Set prompt
set protocolfilter           Set protocol filtering
set snmp                     Set SNMP, use 'set snmp help' for more info
set span                     Set switch port analyzer
set spantree                 Set spanning tree information
set standbyports             Set standby ports feature (enable/disable).
set summertime               Set summertime
set system                   Set system, use 'set system help' for more info
set tacacs                   Set TACACS information
set time                     Set time
set timezone                 Set timezone
set trunk                    Set trunk ports
set vlan                     Set virtual LAN information
set vtp                      Set VLAN Trunk Information

RE: 2948 Help!

Its catos , and  really old  catos at that . It runs cat4000 code .   Only a image than has a  cv in the middle will support  the gui interface.

RE: 2948 Help!

So is there anyone out there who has a new image for me that i can use? This is my first cisco switch (Got tired of all of the cisco emulators) and i'm just happy that i finally got it in my hands but now I want to setup a vlan for everything in my house lol!

On the Road to CCNA!!!!

RE: 2948 Help!

It will do nothing for CCNA. It's too old...CatOs has not been covered in I don't know how long...


RE: 2948 Help!

Well i heard that the latest CatOS is more like the IOS.  I mean so far the PIX (i heard thats going out?) has it's own OS, the Routers have there own OS, and this switch has it's own OS.  So all in all I don't think that learning about the VTP/Vlan configuration would hurt me any on my journy.

RE: 2948 Help!

True, but you really need an IOS switch. No such thing as "set" in the current CCNA/CCNP...
The PIX/ASA indeed has its own "IOS", but they are covered in CCSP/CCIE Security. No drastic changes have been made. Catalyst switches with Cat OS and Catalyst switches with IOS are two TOTALLY different animals.


RE: 2948 Help!

   Learning to trunk and etherchannel can't hurt no matter what you use but the test will be useing IOS  like a 2950 switch. Catos were good switches and if you learned the commands was easier than a equivalent IOS based switch. I use to have a link that would give you updates but i just tried it and the site is no longer functional , sorry...

RE: 2948 Help!

It's ok, I just found cat4000-k8.8-4-10-glx.bin witch should work. but first i need to upgrade to cat4000-promupgrade.6-1-5.bin.  I am going to use a tftp but reading i need a promupgrade tool??  Am i reading this right or is the bin all i need?

RE: 2948 Help!

   More than likely if the code you have is that old yes you do need to do the prom upgrade otherwise if you try to boot the new code without it could leave you unable to do anything with it . 8.4.10 is like the last code they released for this series so you will have the latest and final code.  Make sure to follow the promupgrade instructions , this gets loaded up before the main .bin code .  

RE: 2948 Help!

Thanks for all of your help guys.  I don't know if people ever want to see this but i'm going to start writing about my goal of getting CCNA on the tek-tips forums.  I have a few simulators and a few cisco routers..one switch for now. and some training videos..Kinda like rambo but with cisco stuff :)

I'm going to do the flashes tonight ill let you know how it goes.  

Thanks Again!

RE: 2948 Help!

I was finally able to get my hands on a CV but i'm getting this issue.

Set boot system flash bootflash:cat4000-cv.8-4-1-glx.bin
Warning: file found but it is not a valid boot image.

I have a 8-4-10-GLX but i really wanted to check out the http of this item.  Has anyone seen this before?

RE: 2948 Help!

Looking it up i found this from Cisco

"If the file does exist, but is not a Supervisor Engine III, Catalyst 4000, or 2948G series switch supervisor engine module image, the file is not added to the bootstring, and a message displays, "Warning: file found but it is not a valid boot image."

I have heard of other people running this same image on there 2498G-L2 switch?!?

RE: 2948 Help!

   Should work ,  I would verify the imagename in bootflash. do a "dir bootflash:   and copy and paste the imagename right out of there .  Clear your original boot statement and enter a new one with the imagename cut and pasted out of the dir bootflash:   command , syntax must be exact when entering or it will complain about it .  To clear your boot statements , use "clear boot system all"  .

RE: 2948 Help!

2948_1> (enable) copy tftp flash
IP address or name of remote host []?
Name of file to copy from [cat4000-cv.8-4-1-GLX.bin]?
Flash device [bootflash]?
Name of file to copy to [cat4000-cv.8-4-1-GLX.bin]?
3833768 bytes available on device bootflash, proceed (y/n) [n]? y

File has been copied successfully.
2948_1> (enable) dir
-#- -length- -----date/time------ name
  1  2749968 --- -- ---- --:--:-- cat4000.4-4-1.bin
  2  4808072 Mar 12 2008 11:56:45 cat4000-k8.8-4-10-glx.bin
  3    10944 Mar 12 2008 12:07:26 cat4k-Start
  4  2466066 Mar 15 2008 15:20:17 cat4000-cv.8-4-1-GLX.bin

1367700 bytes available (10035564 bytes used)
2948_1> (enable) set boot system flash bootflash:cat4000-cv.8-4-1-GLX.bin prepen
Warning: file found but it is not a valid boot image.
2948_1> (enable) show boot
BOOT variable = bootflash:cat4000-k8.8-4-10-glx.bin,1;
CONFIG_FILE variable = bootflash:switch.cfg

Configuration register is 0x2
ignore-config: disabled
auto-config: non-recurring
console baud: 9600
boot: image specified by the boot system commands

2948_1> (enable)

I re-downloaded and re-uploaded the file but got the same results.  I'm guessing i just have a bad bin?

RE: 2948 Help!

   Boot the normal bin file and then just try enabling the http server function .  I don't think you boot that file but it has to be in bootflash in order for the gui function to work.

RE: 2948 Help!

Tried that, all i get is

%MGMT-5-HTTP_URINOTFOUND:Request for /favicon.ico from client not found

I don't see an HTTP folder,  Am i missing something here?

RE: 2948 Help!

  If you have both images in bootflash: .   Just add "set ip http server enable"   command.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close