×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

BCMS Data Module not working
2

BCMS Data Module not working

BCMS Data Module not working

(OP)
Our switch lost power after a nasty storm, and after it came back up, our BCMS server could not connect through it's data module to the switch.

Hyperterminal works, but not bcms. Avaya Tier-3 support is here along with techs, & thinks it's a bad data module..it's the second "new one" they've tried to no avail.

sta data-module XXXX returns in service/idle..short test passes..long test passes test 13,17,& 9 -  but aborts test 175 with error 1005. Tests are turned off, so this should be normal i believe.

HELP!! Any ideas? All other properties in switch appear normal to myself & Avaya..
thanks!

RE: BCMS Data Module not working

Hi
May be this is not working version, but did you try to change port of the data module?
Not to bad step to check the data module is try to connect PC Com port, start terminal programm and make a data call to NetCon data module extension of Definity to have a " Login:" prompt.
Wich type of data module?

RE: BCMS Data Module not working

(OP)
Thanks for the reply Dimas..

I forgot to add that we had 2 new 8400B data modules replaced, as well as our TN2224B 24-port digital line card replaced. It is a 8400B module, and we CAN sucessfully place a call to our netcon number through Hyperterminal.

But, on BCMS - it cannot connect to that same Netcon number, and returns an "error 7109 - Could not Communicate With Device".

This makes no sense to anybody at Avaya, and to me either.
We're losing hope..and it was all fine even after the power storm last thursday. The reason the parts were changed is because after the outage, the switch was alarming on that module..PDMODULE XXXX error type 1281 Aux Data 1...BUT it was still working until they unplugged it today. Now, it wont reconnect at all.

Im skeptical that these modules are bad because i can connect via hyperterminal..but they're getting yet another one to try ..should be anytime now.

Thanks again for the efforts..any/all suggestions are GREATLY appreciated!

RE: BCMS Data Module not working

Pbxman,
Just an Idea, Have you checked whether the BCMS data module goes off the hook ever or not. if not you can try re-installing the BCMS server again. hopefully if the physical link is correct it has to do something with your software. .

My gut feel is that it should work.

RE: BCMS Data Module not working

Hi,
I have one more an idea. Ligthing storm was able to drop flash memmory of data-module to a default profile.
Did you try to check out S-registers of your 8400B? You should try to select some parameters for communications with this unit as with ordinary modem. I know that new 8400B+ needs to select some config by AT command.

"
DEFINITY ECS Release 8.2
Installation for Adjuncts and Peripherals 555-233-116
Issue 1
April 2000

....Selecting 8400B options
On the 8400B data module, all configuration options are enabled by default. You
configure the 8400B by disabling options with a code that you enter in a memory
register (S24) in the data module. Consult the table below, and perform the steps
that follow.
Proceed as follows.

Table 12. Codes for disabling default settings of the 8400B data module
Default setting Disabling code
With Telephone 1
US Companding 2
Telephone Provides Dialing 4
Disable Data Metering Feature 16
Immediate Speakerphone Activation 32
Automatic Speakerphone Activation 64
Disable Busyout During Local Loopback Test 128

1. Calculate an option-selection value using Figure 12, ‘‘Codes for disabling
default settings of the 8400B data module’’. Add up the disabling codes
for all options that you wish to disable.
For example, if you turned off With Telephone, US Companding, Disable
Data Metering Feature, the selection code would be:
1 + 2 + 16 = 19
2. Check the current data-module setting by entering ATS24?.
3. If the current value does not match the selection value you calculated,
enter ATS24= nnn, where nnn is the selection value you calculated...."

RE: BCMS Data Module not working

(OP)
Dimas - thanks for all that research..you rock!

We figured out that the ATS24=1 setting was incorrect, and the previous engineer gave wrong register code settings.

AT&V showed us the settings for S21 and S24, and with both zeroed, worked immediately. From the previous engineer's settings, we had S21 set to 70H (instead of zero), and S24 was 1 (with telephone..which was inaccurate)

- with both settings zeroed, it connected immediately.
Thanks again, Dimas..

RE: BCMS Data Module not working

I believe a BCMS-VU pc originates the call to the netcon channel.  I would look at the software and check its settings.  A simple test would be to call the data module extension and see if you get a modem squeal, if you do it's the pc.

Chris

RE: BCMS Data Module not working

(OP)
Clausen,

My reply above solved the problem. This was completely weird..hyperterminal worked fine through the data module, but just not BCMS.

The problem was in the Data Module's default S-Register settings. After changing the initialization settings for the module, BCMS connected immediately.

The software was always set to dial the corect Netcon hunt to connect. Hyperterminal could dial it fine, and i could even login to the switch via the BCMS server..but the BCMS software would not dial the same number Hyperterminal would.

We thought for sure we'd need to reinstall BCMS server, but it was the data module's default S-Register settings...S21 and S24 needed to be Zero...and were not from the factory.

Problem is currently solved.
Thanks guys..

RE: BCMS Data Module not working

I realize that your problem is solved but wanted to offer my quick-fix solution to others as well.

When the bcms-vu shows 'error 7109 - Could not Communicate With Device' all you have to do is connect to the data module through Hyperterm and issue the following command

at&f

That's it!  It resets the data module and you are back up and running. It's that simple. (I've used it 6 times over the last 4 weeks!)

RE: BCMS Data Module not working

If you have fixed the problem great if not let me know.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close