Hi all,
I'm still a beginner with the Cisco routers. Here's my situation:
I have two offices which communicate over the internet using the VPN tunnel between two Cisco 1721 routers. One office is out in the middle of nowhere, and just recently we were able to get DSL service to replace the old ISDN line. I purchased a WIC-1ENET module to use with a DSL modem to get the service going on the remote site.
I've installed teh WIC-1ENET module in the router (with the ISDN module still in), and I know there will be some configuring to get the interface working with the DSL, but at present I can't even get an internal ping to work on the ethernet0 interface just to verify that the module is functional. If I telnet into the router, either onthe ISDN interface (BRI0) or the FastEthernet interface, log in as enable, then ping the IP address that I assigned to the ethernet0 interface, I get 0/5 response, even though the "show interface" says the module is OK and the status is "up".
Here is the "show ip int brief":
Interface IP-Address OK? Method Status Protocol
FastEthernet0 192.168.0.254 YES NVRAM up up
Virtual-Access1 unassigned YES unset up up
BRI0 x6.x1.x5.142 YES NVRAM up up
BRI0:1 unassigned YES unset up up
BRI0:2 unassigned YES unset up up
Ethernet0 192.168.2.253 YES manual up down
I'm using the non-routable address just for test purposes at the moment.
Here is the config:
Current configuration : 3587 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname MYROUTER
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 XXXXXXXX
!
username XXXXXX password 7 XXXXXXXXXX
clock timezone Pacific -8
clock summer-time PDT recurring
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
aaa new-model
!
!
aaa authentication login userauth local
aaa authorization network groupauth local
aaa session-id common
ip subnet-zero
!
!
ip domain name XXXXX.org
ip name-server XXX.XXX.174.17
!
ip cef
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
isdn switch-type basic-5ess
!
!
!
!
crypto isakmp policy 50
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key XXXXXXX address XX.XX.XXX.148 no-xauth
crypto isakmp keepalive 10 5
!
!
crypto ipsec transform-set mytransform esp-3des esp-md5-hmac
!
crypto map mytunnelrsa 10 ipsec-isakmp
set peer XX.XX.XXX.148
set transform-set mytransform
match address 116
!
!
!
!
interface BRI0
description ISDN Line # XXXXXXX
ip address XX.XX.XX.142 255.255.255.252
ip access-group 101 in
ip nat outside
encapsulation ppp
no ip route-cache cef
no ip mroute-cache
load-interval 60
dialer string XXXXXXXXX
dialer string XXXXX
dialer load-threshold 2 either
dialer-group 1
isdn switch-type basic-dms100
isdn spid1 XXXXXXXXX
isdn spid2 XXXXXXXXX
ppp authentication pap callin
ppp pap sent-username MYROUTER password 7 XXXXXX
ppp multilink
crypto map mytunnelrsa
!
interface Ethernet0
ip address 192.168.2.253 255.255.255.0
full-duplex
!
interface FastEthernet0
ip address 192.168.0.254 255.255.255.0
ip nat inside
no ip route-cache cef
no ip mroute-cache
speed auto
!
ip local pool ippool 10.1.1.1 10.1.1.254
ip nat pool my XX.XX.XX.142 XX.XX.XX.142 prefix-length 29
ip nat inside source route-map nonat interface BRI0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
no ip http secure-server
!
!
logging trap notifications
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 2 permit 192.168.0.0 0.0.0.255
access-list 10 permit 192.168.0.0 0.0.0.255
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 90 permit any log
access-list 101 deny tcp any eq 445 any
access-list 112 deny ip 192.168.0.0 0.0.0.255 10.1.1.0 0.0.0.255
access-list 112 deny ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 112 permit ip 192.168.0.0 0.0.0.255 any
access-list 116 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 145 permit ip 192.168.0.0 0.0.0.255 192.168.0.0 0.0.0.255
access-list 190 permit ip 192.168.1.0 0.0.0.255 10.1.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
route-map nonat permit 10
match ip address 112
!
alias exec sr show ip route
!
line con 0
line aux 0
line vty 0 4
access-class 90 in
!
!
end
So, I telnet into the router, log in as enable, type "ping 192.168.2.253" and get "Success rate is 0 percent (0/5)". Shouldn't I be able to ping this interface, just so I know it is functioning?
Thanks for any help you guys might be able to give.
I'm still a beginner with the Cisco routers. Here's my situation:
I have two offices which communicate over the internet using the VPN tunnel between two Cisco 1721 routers. One office is out in the middle of nowhere, and just recently we were able to get DSL service to replace the old ISDN line. I purchased a WIC-1ENET module to use with a DSL modem to get the service going on the remote site.
I've installed teh WIC-1ENET module in the router (with the ISDN module still in), and I know there will be some configuring to get the interface working with the DSL, but at present I can't even get an internal ping to work on the ethernet0 interface just to verify that the module is functional. If I telnet into the router, either onthe ISDN interface (BRI0) or the FastEthernet interface, log in as enable, then ping the IP address that I assigned to the ethernet0 interface, I get 0/5 response, even though the "show interface" says the module is OK and the status is "up".
Here is the "show ip int brief":
Interface IP-Address OK? Method Status Protocol
FastEthernet0 192.168.0.254 YES NVRAM up up
Virtual-Access1 unassigned YES unset up up
BRI0 x6.x1.x5.142 YES NVRAM up up
BRI0:1 unassigned YES unset up up
BRI0:2 unassigned YES unset up up
Ethernet0 192.168.2.253 YES manual up down
I'm using the non-routable address just for test purposes at the moment.
Here is the config:
Current configuration : 3587 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname MYROUTER
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 XXXXXXXX
!
username XXXXXX password 7 XXXXXXXXXX
clock timezone Pacific -8
clock summer-time PDT recurring
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
aaa new-model
!
!
aaa authentication login userauth local
aaa authorization network groupauth local
aaa session-id common
ip subnet-zero
!
!
ip domain name XXXXX.org
ip name-server XXX.XXX.174.17
!
ip cef
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
isdn switch-type basic-5ess
!
!
!
!
crypto isakmp policy 50
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key XXXXXXX address XX.XX.XXX.148 no-xauth
crypto isakmp keepalive 10 5
!
!
crypto ipsec transform-set mytransform esp-3des esp-md5-hmac
!
crypto map mytunnelrsa 10 ipsec-isakmp
set peer XX.XX.XXX.148
set transform-set mytransform
match address 116
!
!
!
!
interface BRI0
description ISDN Line # XXXXXXX
ip address XX.XX.XX.142 255.255.255.252
ip access-group 101 in
ip nat outside
encapsulation ppp
no ip route-cache cef
no ip mroute-cache
load-interval 60
dialer string XXXXXXXXX
dialer string XXXXX
dialer load-threshold 2 either
dialer-group 1
isdn switch-type basic-dms100
isdn spid1 XXXXXXXXX
isdn spid2 XXXXXXXXX
ppp authentication pap callin
ppp pap sent-username MYROUTER password 7 XXXXXX
ppp multilink
crypto map mytunnelrsa
!
interface Ethernet0
ip address 192.168.2.253 255.255.255.0
full-duplex
!
interface FastEthernet0
ip address 192.168.0.254 255.255.255.0
ip nat inside
no ip route-cache cef
no ip mroute-cache
speed auto
!
ip local pool ippool 10.1.1.1 10.1.1.254
ip nat pool my XX.XX.XX.142 XX.XX.XX.142 prefix-length 29
ip nat inside source route-map nonat interface BRI0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 BRI0
no ip http server
no ip http secure-server
!
!
logging trap notifications
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 2 permit 192.168.0.0 0.0.0.255
access-list 10 permit 192.168.0.0 0.0.0.255
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 90 permit any log
access-list 101 deny tcp any eq 445 any
access-list 112 deny ip 192.168.0.0 0.0.0.255 10.1.1.0 0.0.0.255
access-list 112 deny ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 112 permit ip 192.168.0.0 0.0.0.255 any
access-list 116 permit ip 192.168.0.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 145 permit ip 192.168.0.0 0.0.0.255 192.168.0.0 0.0.0.255
access-list 190 permit ip 192.168.1.0 0.0.0.255 10.1.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
route-map nonat permit 10
match ip address 112
!
alias exec sr show ip route
!
line con 0
line aux 0
line vty 0 4
access-class 90 in
!
!
end
So, I telnet into the router, log in as enable, type "ping 192.168.2.253" and get "Success rate is 0 percent (0/5)". Shouldn't I be able to ping this interface, just so I know it is functioning?
Thanks for any help you guys might be able to give.