Ok... first of all I have a Cisco 2514 Router running IOS version 12.2(12a). Ethernet 0 is connected to my cable modem and Ethernet 1 is connected to a 2900 Catalyst switch. The router is running NAT and there are 3 Windows XP machines and 1 Linux Red Hat machine on my network. I will post my running config below..
Now.. I want to create a VPN so I can connect to my network via a laptop from various places. I have looked all over cisco's site and I cant find anything specific to setting this up. I don't know if VPN is something that needs to be set up on my machines, router or switch. I have no prior experience with VPNs.
Could someone get me on the right track...
Running Config....
Current configuration : 1771 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Sabap_Cable-NAT
!
no logging console
enable secret 5 $1$tmqq$ZBM3YNS6YZeER6T5fCpLl1
!
ip subnet-zero
!
!
!
!
interface Ethernet0
description *** 2 MBps Link to Mediacom ***
ip address dhcp
ip nat outside
!
interface Ethernet1
description *** 10 MBps Link to 172.16.5.0 Network ***
ip address 172.16.5.254 255.255.255.0
ip nat inside
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip nat inside source list 1 interface Ethernet0 overload
ip nat inside source static tcp 172.16.5.2 3392 interface Ethernet0 3392
ip nat inside source static tcp 172.16.5.4 3394 interface Ethernet0 3394
ip nat inside source static tcp 172.16.5.3 22 interface Ethernet0 10000
ip nat inside source static udp 172.16.5.2 59111 interface Ethernet0 59111
ip nat inside source static udp 172.16.5.2 59110 interface Ethernet0 59110
ip nat inside source static tcp 172.16.5.1 60000 interface Ethernet0 60000
no ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip http server
!
access-list 1 permit 172.16.5.0 0.0.0.255
banner motd ^C
WARNING: Unauthorized access to this computer system is prohibited.
Violators are subject to criminal and civil penalties.
Pursuant to 18 U.S.C. section 2510, any and all monitoring
of user activity may take place on this system by the management.^C
!
line con 0
session-timeout 30
exec-timeout 120 0
password 7 010007065A1B
login
line aux 0
session-timeout 30
password 7 08324D4C0809
login
line vty 0 4
session-timeout 30
exec-timeout 120 0
password 7 021505590A16
login
!
end
Now.. I want to create a VPN so I can connect to my network via a laptop from various places. I have looked all over cisco's site and I cant find anything specific to setting this up. I don't know if VPN is something that needs to be set up on my machines, router or switch. I have no prior experience with VPNs.
Could someone get me on the right track...
Running Config....
Current configuration : 1771 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Sabap_Cable-NAT
!
no logging console
enable secret 5 $1$tmqq$ZBM3YNS6YZeER6T5fCpLl1
!
ip subnet-zero
!
!
!
!
interface Ethernet0
description *** 2 MBps Link to Mediacom ***
ip address dhcp
ip nat outside
!
interface Ethernet1
description *** 10 MBps Link to 172.16.5.0 Network ***
ip address 172.16.5.254 255.255.255.0
ip nat inside
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip nat inside source list 1 interface Ethernet0 overload
ip nat inside source static tcp 172.16.5.2 3392 interface Ethernet0 3392
ip nat inside source static tcp 172.16.5.4 3394 interface Ethernet0 3394
ip nat inside source static tcp 172.16.5.3 22 interface Ethernet0 10000
ip nat inside source static udp 172.16.5.2 59111 interface Ethernet0 59111
ip nat inside source static udp 172.16.5.2 59110 interface Ethernet0 59110
ip nat inside source static tcp 172.16.5.1 60000 interface Ethernet0 60000
no ip classless
ip route 0.0.0.0 0.0.0.0 Ethernet0
ip http server
!
access-list 1 permit 172.16.5.0 0.0.0.255
banner motd ^C
WARNING: Unauthorized access to this computer system is prohibited.
Violators are subject to criminal and civil penalties.
Pursuant to 18 U.S.C. section 2510, any and all monitoring
of user activity may take place on this system by the management.^C
!
line con 0
session-timeout 30
exec-timeout 120 0
password 7 010007065A1B
login
line aux 0
session-timeout 30
password 7 08324D4C0809
login
line vty 0 4
session-timeout 30
exec-timeout 120 0
password 7 021505590A16
login
!
end