First, a "caveat":
IOS Newbie adminning an INSULAR (read: NOT connected to the internet)multi-domain network in an educational/lab environment.
Networks are physically small (less than 500 total hosts, including VMs, but 5 domains -- for lab simulation purposes)
So, we're (under)utilising a Catalyst 4224 (the 24 10/100 ports)to do the routing between the domains/Vlans.
However, only one vlan (vlan 2, in my example)seems to be working, and at that, only between the ethernet ports its been assigned. Any ping attempts beyond the hosts connected to vlan 2 get nowhere rather fast.
Had to reconfig from scratch after flash image got hosed and had to tftp a new one to the router -- cribbed a lot of the config from an old configuration txt file.
Config follows: (left out voice port configs -- not used)
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname iwar_th115
!
no logging console
enable secret 5 $1$33yw$I3mZcHrFcX.z7wdzAjNWr.
enable password adminpw
!
memory-size iomem 25
vlan 7
name VLAN0007
vlan 23
name spare
vlan 2
name white
vlan 6
name SIGSAC
vlan 5
name grey
vlan 4
name gold
vlan 3
name black
vlan 1
name VLAN0001
!
ip subnet-zero
ip tftp source-interface FastEthernet0/0
ip name-server 150.1.0.2
ip name-server 192.168.10.1
ip name-server 172.16.100.2
!
voicecard mode toll-by-pass
!
!
interface FastEthernet0/0
ip address 10.11.12.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet5/1
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/2
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/3
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/4
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/5
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/6
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/7
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/8
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/9
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/10
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/11
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/12
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/13
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/14
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/15
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/16
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/17
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/18
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/19
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/20
no ip address
duplex auto
speed auto
switchport access vlan 6
!
interface FastEthernet5/21
no ip address
duplex auto
speed auto
switchport access vlan 7
!
interface FastEthernet5/22
no ip address
duplex auto
speed auto
switchport access vlan 7
!
interface FastEthernet5/23
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/24
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface Vlan 1
ip address 10.11.12.254 255.255.255.0
shutdown
!
interface Vlan 2
ip address 150.1.0.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 3
ip address 192.168.0.254 255.255.0.0
ip mroute-cache
full-duplex
!
interface Vlan 4
ip address 172.16.100.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 5
ip address 172.16.110.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 6
ip address 172.16.120.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 7
ip address 172.16.130.254 255.255.255.0
ip mroute-cache
full-duplex
!
!
router igrp 1
redistribute connected
network 150.1.0.0
network 172.16.0.0
network 192.168.0.0
network 192.168.10.0
!
ip default-gateway 192.168.12.254
ip classless
no ip http server
!
access-list 1 permit 192.168.10.1
access-list 1 permit any
tftp-server flash 1
tftp-server flash 2
snmp-server community iwar RW
snmp-server trap link ietf
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps envmon
snmp-server enable traps bgp
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
snmp-server enable traps ipmulticast
snmp-server enable traps msdp
snmp-server enable traps rsvp
snmp-server enable traps frame-relay
snmp-server enable traps rtr
snmp-server enable traps syslog
snmp-server enable traps dsp card-status
snmp-server enable traps ipmobile
snmp-server enable traps dnis
snmp-server enable traps xgcp
snmp-server host 10.11.12.3 iwar
snmp-server host 192.168.12.3 iwar
snmp-server tftp-server-list 1
snmp ifmib ifalias long
snmp mib persist circuit
So, where are the errors, here? Again, be gentle, I just learned to spell IOS a few weeks ago . . .
IOS Newbie adminning an INSULAR (read: NOT connected to the internet)multi-domain network in an educational/lab environment.
Networks are physically small (less than 500 total hosts, including VMs, but 5 domains -- for lab simulation purposes)
So, we're (under)utilising a Catalyst 4224 (the 24 10/100 ports)to do the routing between the domains/Vlans.
However, only one vlan (vlan 2, in my example)seems to be working, and at that, only between the ethernet ports its been assigned. Any ping attempts beyond the hosts connected to vlan 2 get nowhere rather fast.
Had to reconfig from scratch after flash image got hosed and had to tftp a new one to the router -- cribbed a lot of the config from an old configuration txt file.
Config follows: (left out voice port configs -- not used)
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname iwar_th115
!
no logging console
enable secret 5 $1$33yw$I3mZcHrFcX.z7wdzAjNWr.
enable password adminpw
!
memory-size iomem 25
vlan 7
name VLAN0007
vlan 23
name spare
vlan 2
name white
vlan 6
name SIGSAC
vlan 5
name grey
vlan 4
name gold
vlan 3
name black
vlan 1
name VLAN0001
!
ip subnet-zero
ip tftp source-interface FastEthernet0/0
ip name-server 150.1.0.2
ip name-server 192.168.10.1
ip name-server 172.16.100.2
!
voicecard mode toll-by-pass
!
!
interface FastEthernet0/0
ip address 10.11.12.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet5/1
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/2
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/3
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/4
no ip address
duplex auto
speed auto
switchport access vlan 2
!
interface FastEthernet5/5
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/6
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/7
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/8
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/9
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/10
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/11
no ip address
duplex auto
speed auto
switchport access vlan 3
!
interface FastEthernet5/12
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/13
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/14
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/15
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/16
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/17
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/18
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/19
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/20
no ip address
duplex auto
speed auto
switchport access vlan 6
!
interface FastEthernet5/21
no ip address
duplex auto
speed auto
switchport access vlan 7
!
interface FastEthernet5/22
no ip address
duplex auto
speed auto
switchport access vlan 7
!
interface FastEthernet5/23
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface FastEthernet5/24
no ip address
duplex auto
speed auto
switchport access vlan 4
!
interface Vlan 1
ip address 10.11.12.254 255.255.255.0
shutdown
!
interface Vlan 2
ip address 150.1.0.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 3
ip address 192.168.0.254 255.255.0.0
ip mroute-cache
full-duplex
!
interface Vlan 4
ip address 172.16.100.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 5
ip address 172.16.110.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 6
ip address 172.16.120.254 255.255.255.0
ip mroute-cache
full-duplex
!
interface Vlan 7
ip address 172.16.130.254 255.255.255.0
ip mroute-cache
full-duplex
!
!
router igrp 1
redistribute connected
network 150.1.0.0
network 172.16.0.0
network 192.168.0.0
network 192.168.10.0
!
ip default-gateway 192.168.12.254
ip classless
no ip http server
!
access-list 1 permit 192.168.10.1
access-list 1 permit any
tftp-server flash 1
tftp-server flash 2
snmp-server community iwar RW
snmp-server trap link ietf
snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart
snmp-server enable traps hsrp
snmp-server enable traps config
snmp-server enable traps entity
snmp-server enable traps envmon
snmp-server enable traps bgp
snmp-server enable traps pim neighbor-change rp-mapping-change invalid-pim-message
snmp-server enable traps ipmulticast
snmp-server enable traps msdp
snmp-server enable traps rsvp
snmp-server enable traps frame-relay
snmp-server enable traps rtr
snmp-server enable traps syslog
snmp-server enable traps dsp card-status
snmp-server enable traps ipmobile
snmp-server enable traps dnis
snmp-server enable traps xgcp
snmp-server host 10.11.12.3 iwar
snmp-server host 192.168.12.3 iwar
snmp-server tftp-server-list 1
snmp ifmib ifalias long
snmp mib persist circuit
So, where are the errors, here? Again, be gentle, I just learned to spell IOS a few weeks ago . . .