I have a 2600 router and a 3700 switch for the Lan. The 2600 uses adsl via fa 0/0 and then there is a point to point to the switch. DHCP is handed to clients on a windows box. My issues is that some websites are very slow and hardly load and i.e. windows update will not evne load and other sites on only certain sites load. Some websites have no issues and browse at regular dsl speed. My thoughts are there is a routing issue (ospf) or is some sort of MTU issue. the configs are as follows.
its kind of a crazy way to do things but this is mainly a lab
=========================================
Router
=========================================
Building configuration...
Current configuration : 1498 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
boot-start-marker
boot-end-marker
no logging console
enable secret 5 $1$FiEX$jdP9Z2np.YwpOoxAzZWIx1
no aaa new-model
resource policy
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
vpdn enable
interface Loopback0
ip address 192.168.0.249 255.255.255.255
interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
interface FastEthernet0/1
ip address 192.168.252.1 255.255.255.252
ip nat inside
no ip mroute-cache
ip ospf network point-to-point
duplex auto
speed auto
no cdp enable
interface FastEthernet0/1.1
no cdp enable
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username password 0
router ospf 10
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 1 permit 0.0.0.0 0.0.0.255
access-list 2 permit any
no cdp run
control-plane
call-manager-fallback
max-conferences 4 gain -6
line con 0
line aux 0
line vty 0 4
password
login
end
===================================
Switch
===================================
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
!
enable secret 5 $1$wERh$hTcpEfX2TGfTnNZyoEZAW.
enable password martini1
!
no aaa new-model
switch 1 provision ws-c3750g-48ps
vtp domain sfdc-tor
vtp mode transparent
ip subnet-zero
ip routing
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10
name test
!
vlan 36
name VoICE-11-tor
!
vlan 37
name DATA-11-tor
!
!
interface Loopback0
ip address 192.168.0.248 255.255.255.255
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
no switchport
ip address 192.168.252.2 255.255.255.252
ip ospf network point-to-point
!
interface GigabitEthernet1/0/3
switchport access vlan 10
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
switchport access vlan 10
!
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.1.200
!
router ospf 10
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.252.1
no ip http server
no ip http secure-server
!
ip ospf name-lookup
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line vty 0 4
password
no login
line vty 5 15
password
no login
!
its kind of a crazy way to do things but this is mainly a lab
=========================================
Router
=========================================
Building configuration...
Current configuration : 1498 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
boot-start-marker
boot-end-marker
no logging console
enable secret 5 $1$FiEX$jdP9Z2np.YwpOoxAzZWIx1
no aaa new-model
resource policy
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
vpdn enable
interface Loopback0
ip address 192.168.0.249 255.255.255.255
interface FastEthernet0/0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1
interface FastEthernet0/1
ip address 192.168.252.1 255.255.255.252
ip nat inside
no ip mroute-cache
ip ospf network point-to-point
duplex auto
speed auto
no cdp enable
interface FastEthernet0/1.1
no cdp enable
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap callin
ppp pap sent-username password 0
router ospf 10
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http secure-server
ip nat inside source list 1 interface Dialer1 overload
access-list 1 permit 192.168.0.0 0.0.255.255
access-list 1 permit 0.0.0.0 0.0.0.255
access-list 2 permit any
no cdp run
control-plane
call-manager-fallback
max-conferences 4 gain -6
line con 0
line aux 0
line vty 0 4
password
login
end
===================================
Switch
===================================
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
!
enable secret 5 $1$wERh$hTcpEfX2TGfTnNZyoEZAW.
enable password martini1
!
no aaa new-model
switch 1 provision ws-c3750g-48ps
vtp domain sfdc-tor
vtp mode transparent
ip subnet-zero
ip routing
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 10
name test
!
vlan 36
name VoICE-11-tor
!
vlan 37
name DATA-11-tor
!
!
interface Loopback0
ip address 192.168.0.248 255.255.255.255
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
no switchport
ip address 192.168.252.2 255.255.255.252
ip ospf network point-to-point
!
interface GigabitEthernet1/0/3
switchport access vlan 10
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
switchport access vlan 10
!
!
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip helper-address 192.168.1.200
!
router ospf 10
log-adjacency-changes
network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.252.1
no ip http server
no ip http secure-server
!
ip ospf name-lookup
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
line vty 0 4
password
no login
line vty 5 15
password
no login
!