I am hoping someone can give me a clue on where to look next. This is a 2610 connected directly (via crossover) to a cellular internet device. With the device set to offer the public cellular net assigned IP via DHCP, the router works fine. However, with the device set to offer a private IP, the address is assigned, and the arp table populated but the router can't route to/through it. Here is the config and some debug/show command outputs. Any help would be greatly appreciated!! Thanks in Advance!
----------------------------------------------------------
rbos1-0425#sh run
Building configuration...
Current configuration : 2303 bytes
!
! Last configuration change at 13:30:29 est Tue Feb 6 2007
!
version 12.3
service config
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname rbos1-0425
!
boot-start-marker
boot-end-marker
!
logging buffered 10000 debugging
no logging console
enable secret ******
!
clock timezone est -5
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
!
x25 routing
!
!
!
interface Loopback0
no ip address
shutdown
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface Serial1/0
description X25 connection for Base 6274
no ip address
encapsulation x25 dce
no ip mroute-cache
x25 htc 8
x25 win 7
x25 wout 7
x25 ips 512
x25 ops 512
clock rate 19200
no cdp enable
!
interface Serial1/1
no ip address
no ip mroute-cache
no cdp enable
!
interface Serial1/2
no ip address
no ip mroute-cache
no cdp enable
!
interface Serial1/3
no ip address
no ip mroute-cache
no cdp enable
!
interface Async1
ip address 10.40.244.217 255.255.240.0
encapsulation ppp
dialer in-band
dialer idle-timeout 60
dialer wait-for-carrier-time 20
dialer string 19727920229
dialer string 17326022341
dialer-group 1
async default routing
async mode dedicated
ppp authentication chap
ppp chap hostname rbos1-0425
ppp chap password ******
!
router eigrp 1
passive-interface FastEthernet0/0
network 10.0.0.0
no auto-summary
eigrp stub connected
!
ip classless
ip route 10.0.0.0 255.0.0.0 Async1
ip route 0.0.0.0 0.0.0.0 dhcp
ip route 4.2.2.2 255.255.255.255 dhcp
ip http server
!
access-list 101 deny eigrp any any
access-list 101 deny udp any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
x25 route 11280508 xot *******
!
line con 0
exec-timeout 15 0
password ****
login
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
password ********
login
line vty 0 4
exec-timeout 15 0
password ******
logging synchronous
login
transport input telnet
!
ntp clock-period 17208604
ntp server 142.179.100.217
!
end
rbos1-0425# sh int f0/0
FastEthernet0/0 is up, line protocol is up
Hardware is AmdFE, address is 000e.84df.fb60 (bia 000e.84df.fb60)
Internet address is 192.168.13.1/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 10Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
DEBUG AND ROUTES/ARP TABLE
rbos1-0424#
Feb 6 14:33:34: %SYS-5-CONFIG_I: Configured from console by vty1 (10.40.240.6)
Feb 6 14:33:35: DHCP: Adding static route to 0.0.0.0 0.0.0.0 via 192.168.13.31
Feb 6 14:33:35: Adding static route to 192.168.13.31 255.255.255.255 via 192.168.13.31
Feb 6 14:33:35: Adding DNS server address 68.28.114.11
Feb 6 14:33:35: Adding DNS server address 68.28.122.11
Feb 6 14:33:35: DHCP Client Pooling: ***Allocated IP address: 192.168.13.1
Feb 6 14:33:35: Allocated IP address = 192.168.13.1 255.255.255.0
Feb 6 14:33:35: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 192.168.13.1, mask 255.255.255.0, hostname rbos1-0424
bos1-0424#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.13.1 - 0013.1928.bcc0 ARPA FastEthernet0/0
Internet 192.168.13.31 1 0014.3e00.50d5 ARPA FastEthernet0/0
rbos1-0424#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.13.31 to network 0.0.0.0
192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.13.0/24 is directly connected, FastEthernet0/0
S 192.168.13.31/32 [254/0] via 192.168.13.31
4.0.0.0/32 is subnetted, 1 subnets
S 4.2.2.2 [1/0] via 192.168.13.31
10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
S 10.0.0.0/8 is directly connected, Async1
C 10.40.240.0/20 is directly connected, Async1
C 10.40.240.6/32 is directly connected, Async1
S* 0.0.0.0/0 [254/0] via 192.168.13.31
rbos1-0424#ping 4.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:
Feb 6 14:35:35: %SYS-5-CONFIG_I: Configured from console by vty1 (10.40.240.6)
Feb 6 14:35:36: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast
Feb 6 14:35:37: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable. <-----????
Feb 6 14:35:39: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable.
Feb 6 14:35:41: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable
Feb 6 14:35:41: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast.
Feb 6 14:35:43: IP: s=0.0.0.0 (local), d=142.179.100.217, len 76, unroutable
Feb 6 14:35:43: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable.
Feb 6 14:35:45: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable.
rbos1-0424#ping 192.168.13.31
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.31, timeout is 2 seconds:
Feb 6 14:35:55: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast
Feb 6 14:35:56: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable. <---- What the?
Feb 6 14:35:59: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable.
Feb 6 14:36:00: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast
Feb 6 14:36:01: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable.
Feb 6 14:36:03: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable.
Feb 6 14:36:05: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable
----------------------------------------------------------
rbos1-0425#sh run
Building configuration...
Current configuration : 2303 bytes
!
! Last configuration change at 13:30:29 est Tue Feb 6 2007
!
version 12.3
service config
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname rbos1-0425
!
boot-start-marker
boot-end-marker
!
logging buffered 10000 debugging
no logging console
enable secret ******
!
clock timezone est -5
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
no ip domain lookup
!
x25 routing
!
!
!
interface Loopback0
no ip address
shutdown
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface Serial1/0
description X25 connection for Base 6274
no ip address
encapsulation x25 dce
no ip mroute-cache
x25 htc 8
x25 win 7
x25 wout 7
x25 ips 512
x25 ops 512
clock rate 19200
no cdp enable
!
interface Serial1/1
no ip address
no ip mroute-cache
no cdp enable
!
interface Serial1/2
no ip address
no ip mroute-cache
no cdp enable
!
interface Serial1/3
no ip address
no ip mroute-cache
no cdp enable
!
interface Async1
ip address 10.40.244.217 255.255.240.0
encapsulation ppp
dialer in-band
dialer idle-timeout 60
dialer wait-for-carrier-time 20
dialer string 19727920229
dialer string 17326022341
dialer-group 1
async default routing
async mode dedicated
ppp authentication chap
ppp chap hostname rbos1-0425
ppp chap password ******
!
router eigrp 1
passive-interface FastEthernet0/0
network 10.0.0.0
no auto-summary
eigrp stub connected
!
ip classless
ip route 10.0.0.0 255.0.0.0 Async1
ip route 0.0.0.0 0.0.0.0 dhcp
ip route 4.2.2.2 255.255.255.255 dhcp
ip http server
!
access-list 101 deny eigrp any any
access-list 101 deny udp any any
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101
x25 route 11280508 xot *******
!
line con 0
exec-timeout 15 0
password ****
login
line 1
modem InOut
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
password ********
login
line vty 0 4
exec-timeout 15 0
password ******
logging synchronous
login
transport input telnet
!
ntp clock-period 17208604
ntp server 142.179.100.217
!
end
rbos1-0425# sh int f0/0
FastEthernet0/0 is up, line protocol is up
Hardware is AmdFE, address is 000e.84df.fb60 (bia 000e.84df.fb60)
Internet address is 192.168.13.1/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Half-duplex, 10Mb/s, 100BaseTX/FX
ARP type: ARPA, ARP Timeout 04:00:00
DEBUG AND ROUTES/ARP TABLE
rbos1-0424#
Feb 6 14:33:34: %SYS-5-CONFIG_I: Configured from console by vty1 (10.40.240.6)
Feb 6 14:33:35: DHCP: Adding static route to 0.0.0.0 0.0.0.0 via 192.168.13.31
Feb 6 14:33:35: Adding static route to 192.168.13.31 255.255.255.255 via 192.168.13.31
Feb 6 14:33:35: Adding DNS server address 68.28.114.11
Feb 6 14:33:35: Adding DNS server address 68.28.122.11
Feb 6 14:33:35: DHCP Client Pooling: ***Allocated IP address: 192.168.13.1
Feb 6 14:33:35: Allocated IP address = 192.168.13.1 255.255.255.0
Feb 6 14:33:35: %DHCP-6-ADDRESS_ASSIGN: Interface FastEthernet0/0 assigned DHCP address 192.168.13.1, mask 255.255.255.0, hostname rbos1-0424
bos1-0424#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.13.1 - 0013.1928.bcc0 ARPA FastEthernet0/0
Internet 192.168.13.31 1 0014.3e00.50d5 ARPA FastEthernet0/0
rbos1-0424#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 192.168.13.31 to network 0.0.0.0
192.168.13.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.13.0/24 is directly connected, FastEthernet0/0
S 192.168.13.31/32 [254/0] via 192.168.13.31
4.0.0.0/32 is subnetted, 1 subnets
S 4.2.2.2 [1/0] via 192.168.13.31
10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
S 10.0.0.0/8 is directly connected, Async1
C 10.40.240.0/20 is directly connected, Async1
C 10.40.240.6/32 is directly connected, Async1
S* 0.0.0.0/0 [254/0] via 192.168.13.31
rbos1-0424#ping 4.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 4.2.2.2, timeout is 2 seconds:
Feb 6 14:35:35: %SYS-5-CONFIG_I: Configured from console by vty1 (10.40.240.6)
Feb 6 14:35:36: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast
Feb 6 14:35:37: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable. <-----????
Feb 6 14:35:39: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable.
Feb 6 14:35:41: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable
Feb 6 14:35:41: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast.
Feb 6 14:35:43: IP: s=0.0.0.0 (local), d=142.179.100.217, len 76, unroutable
Feb 6 14:35:43: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable.
Feb 6 14:35:45: IP: s=192.168.13.1 (local), d=4.2.2.2, len 100, unroutable.
rbos1-0424#ping 192.168.13.31
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.13.31, timeout is 2 seconds:
Feb 6 14:35:55: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast
Feb 6 14:35:56: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable. <---- What the?
Feb 6 14:35:59: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable.
Feb 6 14:36:00: IP: s=10.40.244.216 (local), d=224.0.0.10 (Async1), len 66, sending broad/multicast
Feb 6 14:36:01: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable.
Feb 6 14:36:03: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable.
Feb 6 14:36:05: IP: s=192.168.13.1 (local), d=192.168.13.31, len 100, unroutable