Is it possible to route VLAN information between two Cisco C3750-48TS switches using the SFP ports or do these have to go directly to a Layer 3 switch?
Yes. I have a couple of VLANs that cross from a stack of 3750-48TS switches on my first floor to a stack of 3750-48TS switches on the second floor via fiber SFPs. I used CMS to configure it, but just change the VLAN configuration for the SFP ports to ISL Trunk and then indicate which VLANs have trunk access.
switchport trunk encapsulation dot1q (or isl)
switchport mode trunk (optional but i always set it)
do this on both side of the connection. make sure you have vtp setup correctly with vtp server and client or vtp transparent setup on both side. not a problem.
3550
3560
3750
2950
2924
4500
4948
all work off of concept of switchport commands. On layer 3 devices you can set switchports to L3 routed ports or you can use SVI interfaces.
example
interface vlan 3 (this is an SVI or switched virtual int)
ip address 192.168.1.1 255.255.255.0
int fa 0/1
switchport access vlan 3
this is how you have one virtual interface and add many L2 switch ports to its L3 domain
or you can have
interface fa 0/1
no switchport
ip address 192.168.1.1 255.255.255.0
this is how you make a normal L2 switchport a L3 routed port.Same thing as a physical interface on a router.
or
you can have a trunk port
interface fa 0/1
switchport trunk encapsulation dot1q
switchport mode trunk
or you can have an access port L2
int fa 0/1
switchport access vlan 2
many options on the newer IOS based catalyst switches. no need for seperate router to handle MLS (multilayer switching) its all in the same box.
The really cool thing is that the new ISR routers are actually doing the opposite. They have a router with a switch integrated into it. Meaning you can execute switchport commands on a router. Not happening before ISRs came out. Very interesting. No more routers on a stick.
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.