Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Wanet Telecoms Ltd on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Terminal Server

Status
Not open for further replies.

rburke

Programmer
Apr 28, 2002
426
US
Can anyone help me out with how to setup a 2511 or 2512 Terminal server to different cisco routers and switches? I know I will need an octal cable or two, but how do you setup the server so that you can reverse telnet through the other routers AUX or console ports? My lab consists of 2500 series, 4000 series, and one 2900 switch. If someone could give me a snip of how they set theirs up, or point me to a Cisco source I'd appreciate it.

burke
 
version 11.3
!
service udp-small-servers
service tcp-small-servers
!
hostname R2509
!
enable secret cisco
!
no ip domain-lookup
!
ip host r2513 2001 10.1.1.1
ip host r2503 2002 10.1.1.1
ip host r2520 2003 10.1.1.1
ip host r2504 2004 10.1.1.1
ip host r2501 2005 10.1.1.1
ip host Cat2901 2006 10.1.1.1
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
!
ip classless
!
line con 0
!
line 1 8
transport input all
no exec
line aux 0
line vty 0 4
login
!
end

This is very basic. My current config is a bit more complicated as I use TACACS for authentication.

MikeS
Find me at
"Take advantage of the enemy's unreadiness, make your way by unexpected routes, and attack unguarded spots."
Sun Tzu
 
"interface Loopback0
ip address 10.1.1.1 255.255.255.255"

Can you expalin what the Loopback statement above does?

Thanks for the help Mike.

burke
 
Yep.. it gives you a stable *interface* to borrow an IP address from. You notice that with each port, you telnet to the loopback IP address and port ID. Reverse telnet uses the IP address as a *fake* interface for telnet to work. The 20xx is the TTY line that is associated with the IP. So when you say

terminalserver>r2520

You really say, telnet to r2520 which is a name for the device on TTY port 2003 and use the IP address of loopback0 for the telnet session. You could just have easily opened port 2003 without the name but the name is easier to remember ;-)

MikeS
Find me at
"Take advantage of the enemy's unreadiness, make your way by unexpected routes, and attack unguarded spots."
Sun Tzu
 

interface Loopback0 enables loopback mode on a slot/port-adapter thats is always up. The "0"is the interface-number


ip address 10.1.1.1 255.255.255.255 is the assigned IP network address 10.1.1.1 and network mask 255.255.255.255 to the interface Loopback0
Route once; switch many
 
Ok, I think I am understanding it. But what is the difference between TTY and VTY? I know that vty is the telnet lines, but I don't understand the difference.

And for the Loopback interface, it looks like all it does is setup a fake IP that really is never used(since you could have multiple connections open all with that one Loopback IP). Is that correct?

burke
 
The loopback IS a real interface but it's logical rather then physical. You can telnet to it, bring it down, route packets to it(they go away) which is less overhead then using an accesslist and some protocols use loopbacks. OSPF will use it as the router ID and OPSF will be much more stable this way since it doesnt *flap* like a normal serial can do.

But you are correct with having multiple connections opened using the *fake* IP address of the loopback. But you only get one connection per TTY so if you were to telnet into the TS.. connnect to port 2 and then telnet again into the TS, port 2 would not be available as it's busy with VTY1


MikeS Find me at
"Take advantage of the enemy's unreadiness, make your way by unexpected routes, and attack unguarded spots."
Sun Tzu
 
interface Loopback0 is software based only.

TTY - Protects against un-authorized Telenet Port logons.

VTY Ports are rather a special case, since they are not real ports.In other words, you won't find a Port on the back of your Router labelled VTY. They are what could be called "Virtual Ports" that wait patientlyfor a Remote Connection, usually using Telnet, to log in. Route once; switch many
 
OK, so how many TTY ports would a terminal server with 16 terminal lines (2511/2512 in particular) have? Would it be 16? Because in your example of the config it had tty 2001-2006, so what is the range for tty ports?


Sorry for all the questions, just trying to figure it out.

burke
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top