come on guys help me out here please. I post this message on 14 and no one respond! I m posting again and expecting few replies please !
I am trying to bring up tunnel between cisco 1811 router and pix! can any one please take a look at router config and let me know what I am missing! I create tunnels on pix all the time and get no problem but router is giving my tough time.! I am pasting configs for both pix and router
I think there is a problem with router config!
Router
==================================
Current configuration : 4939 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warning
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.56.1
!
ip dhcp pool dtm
import all
network 192.168.56.0 255.255.255.0
default-router 192.168.56.1
!
!
no ip domain lookup
ip domain name private.corp
ip ssh time-out 60
ip ssh version 2
!
!
crypto pki trustpoint TP-self-signed-2705682511
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2705682511
revocation-check none
rsakeypair TP-self-signed-2705682511
!
!
crypto pki certificate chain TP-self-signed-2705682511
!
!
!
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
lifetime 28800
!
crypto isakmp policy 20
encr 3des
hash md5
authentication pre-share
crypto isakmp key xxxxxxxxxx address xx.xx.xx.xx
!
crypto ipsec transform-set myset esp-des esp-md5-hmac
!
crypto map mymap 10 ipsec-isakmp
set peer xx.xx.xx.xx
set transform-set myset
match address 101
!
!
!
!
interface FastEthernet0
no ip address
duplex auto
speed auto
!
interface FastEthernet1
ip address xx.xx.xx.xx xx.xx.xx.xx
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map mymap
!
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$
ip address 192.168.56.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Async1
no ip address
encapsulation slip
!
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 102 interface FastEthernet1 overload
!
access-list 101 permit ip 192.168.56.0 0.0.0.255 192.168.88.0 0.0.0.255
access-list 102 deny ip 192.168.56.0 0.0.0.255 192.168.88.0 0.0.0.255
access-list 102 permit ip 192.168.56.0 0.0.0.255 any
no cdp run
===================================================
!
PIX 501 CONFIG
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname abc
domain-name private.corp
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list acl-out permit icmp any any echo-reply
access-list acl-out permit icmp any any unreachable
access-list acl-out permit icmp any any time-exceeded
access-list NONAT permit ip 192.168.88.0 255.255.255.0 192.168.56.0 255.255.255.0
access-list tim permit ip 192.168.88.0 255.255.255.0 192.168.56.0 255.255.255.0
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside 24.xx.xx.xx 255.255.xx.xx
ip address inside 192.168.88.254 255.255.255.0
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 24.xx.xx.xx
sysopt connection permit-ipsec
crypto ipsec transform-set AES-256 esp-aes-256 esp-sha-hmac
crypto map abc 10 ipsec-isakmp
crypto map abc 10 match address tim
crypto map abc 10 set peer xx.xx.xx.xx
crypto map abc 10 set transform-set AES-256
crypto map abc interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xx.xx netmask 255.255.xx.xx
isakmp identity address
isakmp keepalive 10 3
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption aes-256
isakmp policy 1 hash sha
isakmp policy 1 group 5
isakmp policy 1 lifetime 28800
isakmp policy 5 authentication pre-share
isakmp policy 5 encryption aes-256
isakmp policy 5 hash sha
isakmp policy 5 group 2
isakmp policy 5 lifetime 86400
isakmp policy 6 authentication pre-share
isakmp policy 6 encryption aes-256
isakmp policy 6 hash sha
isakmp policy 6 group 2
isakmp policy 6 lifetime 28800
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption des
isakmp policy 30 hash md5
isakmp policy 30 group 1
isakmp policy 30 lifetime 86400
I am trying to bring up tunnel between cisco 1811 router and pix! can any one please take a look at router config and let me know what I am missing! I create tunnels on pix all the time and get no problem but router is giving my tough time.! I am pasting configs for both pix and router
I think there is a problem with router config!
Router
==================================
Current configuration : 4939 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warning
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.56.1
!
ip dhcp pool dtm
import all
network 192.168.56.0 255.255.255.0
default-router 192.168.56.1
!
!
no ip domain lookup
ip domain name private.corp
ip ssh time-out 60
ip ssh version 2
!
!
crypto pki trustpoint TP-self-signed-2705682511
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2705682511
revocation-check none
rsakeypair TP-self-signed-2705682511
!
!
crypto pki certificate chain TP-self-signed-2705682511
!
!
!
crypto isakmp policy 10
encr aes 256
authentication pre-share
group 5
lifetime 28800
!
crypto isakmp policy 20
encr 3des
hash md5
authentication pre-share
crypto isakmp key xxxxxxxxxx address xx.xx.xx.xx
!
crypto ipsec transform-set myset esp-des esp-md5-hmac
!
crypto map mymap 10 ipsec-isakmp
set peer xx.xx.xx.xx
set transform-set myset
match address 101
!
!
!
!
interface FastEthernet0
no ip address
duplex auto
speed auto
!
interface FastEthernet1
ip address xx.xx.xx.xx xx.xx.xx.xx
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map mymap
!
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$
ip address 192.168.56.1 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Async1
no ip address
encapsulation slip
!
ip classless
ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx
!
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
ip nat inside source list 102 interface FastEthernet1 overload
!
access-list 101 permit ip 192.168.56.0 0.0.0.255 192.168.88.0 0.0.0.255
access-list 102 deny ip 192.168.56.0 0.0.0.255 192.168.88.0 0.0.0.255
access-list 102 permit ip 192.168.56.0 0.0.0.255 any
no cdp run
===================================================
!
PIX 501 CONFIG
:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
hostname abc
domain-name private.corp
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list acl-out permit icmp any any echo-reply
access-list acl-out permit icmp any any unreachable
access-list acl-out permit icmp any any time-exceeded
access-list NONAT permit ip 192.168.88.0 255.255.255.0 192.168.56.0 255.255.255.0
access-list tim permit ip 192.168.88.0 255.255.255.0 192.168.56.0 255.255.255.0
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside 24.xx.xx.xx 255.255.xx.xx
ip address inside 192.168.88.254 255.255.255.0
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl-out in interface outside
route outside 0.0.0.0 0.0.0.0 24.xx.xx.xx
sysopt connection permit-ipsec
crypto ipsec transform-set AES-256 esp-aes-256 esp-sha-hmac
crypto map abc 10 ipsec-isakmp
crypto map abc 10 match address tim
crypto map abc 10 set peer xx.xx.xx.xx
crypto map abc 10 set transform-set AES-256
crypto map abc interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xx.xx netmask 255.255.xx.xx
isakmp identity address
isakmp keepalive 10 3
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption aes-256
isakmp policy 1 hash sha
isakmp policy 1 group 5
isakmp policy 1 lifetime 28800
isakmp policy 5 authentication pre-share
isakmp policy 5 encryption aes-256
isakmp policy 5 hash sha
isakmp policy 5 group 2
isakmp policy 5 lifetime 86400
isakmp policy 6 authentication pre-share
isakmp policy 6 encryption aes-256
isakmp policy 6 hash sha
isakmp policy 6 group 2
isakmp policy 6 lifetime 28800
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 86400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
isakmp policy 30 authentication pre-share
isakmp policy 30 encryption des
isakmp policy 30 hash md5
isakmp policy 30 group 1
isakmp policy 30 lifetime 86400