i have configured route maps for my uBR router so that traffic coming from different subnets on the cable1/0 interface can take different interfaces out to the internet. somehow it is just not working! i was sure my route maps were ok, but not sure now...can anyone help please ?! here is the configs i have put...minus the real ips 
when i do a trace from the client IPs, i end up within the router, and nowhere else. from there i time out. HELP PLEASE !
nterface Cable1/0
ip address 196.0.0.1 255.255.255.192 secondary
ip address 196.1.0.1 255.255.255.252 secondary
ip address 10.2.0.1 255.255.255.0
ip route-cache policy
ip route-cache flow
ip policy route-map DEFAULT-ROUTING
no keepalive
**
ip access-list extended Clients1
permit ip 196.0.0.1 0.0.0.63 any
ip access-list extended Clients2
permit ip 196.1.0.1 0.0.0.63 any
**
route-map DEFAULT-ROUTING permit 10
match ip address Clients1
set ip default next-hop 196.9.0.1
!
route-map DEFAULT-ROUTING permit 15
match ip address Clients2
set ip next-hop 196.10.0.1
when i do a trace from the client IPs, i end up within the router, and nowhere else. from there i time out. HELP PLEASE !
nterface Cable1/0
ip address 196.0.0.1 255.255.255.192 secondary
ip address 196.1.0.1 255.255.255.252 secondary
ip address 10.2.0.1 255.255.255.0
ip route-cache policy
ip route-cache flow
ip policy route-map DEFAULT-ROUTING
no keepalive
**
ip access-list extended Clients1
permit ip 196.0.0.1 0.0.0.63 any
ip access-list extended Clients2
permit ip 196.1.0.1 0.0.0.63 any
**
route-map DEFAULT-ROUTING permit 10
match ip address Clients1
set ip default next-hop 196.9.0.1
!
route-map DEFAULT-ROUTING permit 15
match ip address Clients2
set ip next-hop 196.10.0.1