dulem
Technical User
- Jul 10, 2002
- 39
Hello.
My network is connected to 3 ISP’s with one 2610. I use static routes. Problem is that I can from outside world ping just one serial interfece which is default route. I have some hosts with 3 secondary adresses and I can ping all tree addresses.
By changing default route serial interface which can be ping-ed is also changed.
Debug IP policy don’t display anything.
So how can I force router that packet received on one serial send back from same interface.
Thanks in advance.
Image name:c2600-jk8s-mz.122-10.bin
!
interface Ethernet0/0
description connected to localnet
ip address FROM_ISP3_POOL secondary
ip address FROM_ISP2_POOL secondary
ip address FROM_ISP1_POOL
ip address 10.1.1.1
ip nat inside
!
interface Serial0/0
description connected to ISP1
ip address ISP1_WAN
ip nat outside
encapsulation ppp
ip policy route-map ser00
fair-queue
!
interface Serial0/1
description connected ISP2
ip address ISP2_WAN
ip nat outside
encapsulation ppp
ip policy route-map ser01
!
interface Serial0/2
description connected ISP3
ip address ISP3_WAN
ip nat outside
encapsulation ppp
ip policy route-map ser02
!
ip route 0.0.0.0 0.0.0.0 Serial0/0
!
access-list 124 permit ip any host ISP1_WAN
access-list 125 permit ip any host ISP2_WAN
access-list 126 permit ip any host ISP3_WAN
!
route-map ser00 permit 10
match ip address 124
set interface Serial0/0
!
route-map ser01 permit 10
match ip address 125
set interface Serial0/1
!
route-map ser02 permit 10
match ip address 126
set interface Serial0/2
!
My network is connected to 3 ISP’s with one 2610. I use static routes. Problem is that I can from outside world ping just one serial interfece which is default route. I have some hosts with 3 secondary adresses and I can ping all tree addresses.
By changing default route serial interface which can be ping-ed is also changed.
Debug IP policy don’t display anything.
So how can I force router that packet received on one serial send back from same interface.
Thanks in advance.
Image name:c2600-jk8s-mz.122-10.bin
!
interface Ethernet0/0
description connected to localnet
ip address FROM_ISP3_POOL secondary
ip address FROM_ISP2_POOL secondary
ip address FROM_ISP1_POOL
ip address 10.1.1.1
ip nat inside
!
interface Serial0/0
description connected to ISP1
ip address ISP1_WAN
ip nat outside
encapsulation ppp
ip policy route-map ser00
fair-queue
!
interface Serial0/1
description connected ISP2
ip address ISP2_WAN
ip nat outside
encapsulation ppp
ip policy route-map ser01
!
interface Serial0/2
description connected ISP3
ip address ISP3_WAN
ip nat outside
encapsulation ppp
ip policy route-map ser02
!
ip route 0.0.0.0 0.0.0.0 Serial0/0
!
access-list 124 permit ip any host ISP1_WAN
access-list 125 permit ip any host ISP2_WAN
access-list 126 permit ip any host ISP3_WAN
!
route-map ser00 permit 10
match ip address 124
set interface Serial0/0
!
route-map ser01 permit 10
match ip address 125
set interface Serial0/1
!
route-map ser02 permit 10
match ip address 126
set interface Serial0/2
!