Got a configuration problem on a cisco 837 adsl router. I can set it up to forward smtp traffic to an internal mailserver, using the following commands;
(where a.b.c.d is the outside wan ip on the Dialer, 10.1.92.2 is the mailserver's local address)
access-list 111 permit tcp any host a.b.c.d eq smtp
interface Dialer1
ip access-group 111 in
ip nat inside source static tcp 10.1.92.2 25 a.b.c.d 25 extendable
This works fine for traffic that originates from the WAN. However, I also have a site to site vpn, and remote user vpns, and although all other traffic down the vpns work fine (pings, shares etc), smtp traffic doesn't work. I suspect it is being statically translated by the static rule to the outside address of the router.
So the question is, how do i configure the router to statically translate the traffic if it originated from the internet, but not translate it if it came from either of my vpns?
For information, the site to site vpn traffic, the remote end's local range is 10.0.0.0/16 and the remote access users vpn in and get assigned an address on a 172.16.1.0/24 range.
Any help very much appreciated
Thanks!
(where a.b.c.d is the outside wan ip on the Dialer, 10.1.92.2 is the mailserver's local address)
access-list 111 permit tcp any host a.b.c.d eq smtp
interface Dialer1
ip access-group 111 in
ip nat inside source static tcp 10.1.92.2 25 a.b.c.d 25 extendable
This works fine for traffic that originates from the WAN. However, I also have a site to site vpn, and remote user vpns, and although all other traffic down the vpns work fine (pings, shares etc), smtp traffic doesn't work. I suspect it is being statically translated by the static rule to the outside address of the router.
So the question is, how do i configure the router to statically translate the traffic if it originated from the internet, but not translate it if it came from either of my vpns?
For information, the site to site vpn traffic, the remote end's local range is 10.0.0.0/16 and the remote access users vpn in and get assigned an address on a 172.16.1.0/24 range.
Any help very much appreciated
Thanks!