Hello world,
I have unfortunately spent too long trying to make functional a network configuration in my home. I cannot find the problem with this configuration that I have built from checking some very good and useful resources.
Here is my config:
Wirespeed DSL Router external IP: 1.2.3.4
Internal 192.168.1.254 / 24
Cisco Router external IP: 192.168.1.1 / 24
Internal 10.10.10.1
Wireless Router external IP: 10.10.10.2
Internal 10.0.0.254
Internal workstation IP: 10.0.0.4
I have configured port forwarding for HTTP and FTP traffic on DSL Router to 192.168.1.1. It is also configured on the Wireless Router to 10.0.0.4. The problem is the Cisco router. I am confident the problem lies within the Cisco router.
Here is my fully functional config (with the exception of the Port Forwarding!)
Current configuration : 677 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface Ethernet1
ip address 192.168.1.1 255.255.255.0
ip nat outside
!
ip nat inside source list 1 interface Ethernet1 overload
ip nat inside source static tcp 10.10.10.2 80 192.168.1.1 80 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
no ip http server
!
!
access-list 1 permit 10.10.10.0 0.0.0.255
!
line con 0
stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end
If anyone out there had the patience and time to read this, I will really appreciate your advice.
Thank you!
aka Jahlmer
I have unfortunately spent too long trying to make functional a network configuration in my home. I cannot find the problem with this configuration that I have built from checking some very good and useful resources.
Here is my config:
Wirespeed DSL Router external IP: 1.2.3.4
Internal 192.168.1.254 / 24
Cisco Router external IP: 192.168.1.1 / 24
Internal 10.10.10.1
Wireless Router external IP: 10.10.10.2
Internal 10.0.0.254
Internal workstation IP: 10.0.0.4
I have configured port forwarding for HTTP and FTP traffic on DSL Router to 192.168.1.1. It is also configured on the Wireless Router to 10.0.0.4. The problem is the Cisco router. I am confident the problem lies within the Cisco router.
Here is my fully functional config (with the exception of the Port Forwarding!)
Current configuration : 677 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
ip nat inside
hold-queue 100 out
!
interface Ethernet1
ip address 192.168.1.1 255.255.255.0
ip nat outside
!
ip nat inside source list 1 interface Ethernet1 overload
ip nat inside source static tcp 10.10.10.2 80 192.168.1.1 80 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.254
no ip http server
!
!
access-list 1 permit 10.10.10.0 0.0.0.255
!
line con 0
stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end
If anyone out there had the patience and time to read this, I will really appreciate your advice.
Thank you!
aka Jahlmer