Hello all,
I would like to use my PIX firewall to block specific IP addresses from having internet access. I understand how to create an Oject-Group, but I am uncertain how to setup the ACL. I have no experience with Cisco IOS.
Im running the following;
Danuser-PIX# show running
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXXX/XXXXXXXXXX encrypted
passwd XXXXXXXXXXXXXXX encrypted
hostname Danuser-PIX
domain-name <domain>.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group network NoInternet
description List of IP addresses block from the Internet
network-object host 192.168.0.100
network-object host 192.168.0.101
network-object host 192.168.0.102
network-object host 192.168.0.103
network-object host 192.168.0.104
network-object host 192.168.0.105
network-object host 192.168.0.106
network-object host 192.168.0.107
network-object host 192.168.0.108
network-object host 192.168.0.109
network-object host 192.168.0.110
network-object host 192.168.0.111
access-list vpn permit ip 192.168.0.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list vpn permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list incoming permit icmp any any
access-list incoming permit tcp any host xx.xx.xxx.xxx eq smtp
access-list incoming permit tcp any host xx.xx.xxx.xxx eq https
access-list incoming permit tcp any host xx.xx.xxx.xxx eq www
access-list incoming permit tcp any host xx.xx.xxx.xxx eq pop3
access-list incoming permit tcp any host xx.xx.xxx.xxx eq 995
access-list incoming permit tcp any host xx.xx.xxx.xxx eq 993
access-list incoming permit tcp any host xx.xx.xxx.xxx eq imap4
access-list danuser permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.
0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.0.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool danuser 10.1.1.1-10.1.1.25
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list vpn
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) xx.xx.xxx.xxx 192.168.0.5 dns netmask 255.255.255.255 0
0
access-group incoming in interface outside
timeout xlate 2:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set pix esp-3des esp-md5-hmac
crypto dynamic-map cisco 90 set transform-set pix
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address danuser
crypto map newmap 10 set peer xx.xx.xxx.xxx
crypto map newmap 10 set transform-set pix
crypto map newmap 90 ipsec-isakmp dynamic cisco
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xxx.xxx netmask 255.255.255.255 no-xauth no-co
nfig-mode
isakmp key ******** address xx.xx.xxx.xxx netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup XXXXl address-pool XXXXXXX
vpngroup XXXXl split-tunnel vpn
vpngroup XXXXl idle-time 28800
vpngroup XXXXl password ********
vpngroup XXXd address-pool danuser
vpngroup XXXd dns-server 192.168.0.3
vpngroup XXXd idle-time 1800
vpngroup XXXd password ********
vpngroup XXXy address-pool danuser
vpngroup XXXy dns-server 192.168.0.3
vpngroup XXXy idle-time 1800
vpngroup XXXy password ********
vpngroup XXXe address-pool danuser
vpngroup XXXe dns-server 192.168.0.3
vpngroup XXXe idle-time 1800
vpngroup XXXe password ********
vpngroup XXXa address-pool danuser
vpngroup XXXa dns-server 192.168.0.3
vpngroup XXXa idle-time 1800
vpngroup XXXa password ********
vpngroup XXXn address-pool danuser
vpngroup XXXn dns-server 192.168.0.3
vpngroup XXXn idle-time 1800
vpngroup XXXn password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh xx.xx.xxx.xxx 255.255.255.128 outside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
vpdn group danuser request dialout pppoe
vpdn group danuser localname XX
vpdn group danuser ppp authentication pap
vpdn username XX *********
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:4b814b7fd6d7e9557048398391a46c6d
: end
As you can see, I have the object-group inserted. I'm guessing that I need something like the following for the ACL.
Danuser-PIX(config)# access-list outbound remark |Block specific IP addresses from internet|
Danuser-PIX(config)# access-list outbound deny ip object-group NoInternet any
Danuser-Pix(config)# access-list outbound permit ip any any
I'm realy not sure if I need the last statement or not. Can someone tell me if I have the right idea?
Thanks,
I would like to use my PIX firewall to block specific IP addresses from having internet access. I understand how to create an Oject-Group, but I am uncertain how to setup the ACL. I have no experience with Cisco IOS.
Im running the following;
Danuser-PIX# show running
: Saved
:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password XXXXX/XXXXXXXXXX encrypted
passwd XXXXXXXXXXXXXXX encrypted
hostname Danuser-PIX
domain-name <domain>.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
object-group network NoInternet
description List of IP addresses block from the Internet
network-object host 192.168.0.100
network-object host 192.168.0.101
network-object host 192.168.0.102
network-object host 192.168.0.103
network-object host 192.168.0.104
network-object host 192.168.0.105
network-object host 192.168.0.106
network-object host 192.168.0.107
network-object host 192.168.0.108
network-object host 192.168.0.109
network-object host 192.168.0.110
network-object host 192.168.0.111
access-list vpn permit ip 192.168.0.0 255.255.255.0 10.1.1.0 255.255.255.0
access-list vpn permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list incoming permit icmp any any
access-list incoming permit tcp any host xx.xx.xxx.xxx eq smtp
access-list incoming permit tcp any host xx.xx.xxx.xxx eq https
access-list incoming permit tcp any host xx.xx.xxx.xxx eq www
access-list incoming permit tcp any host xx.xx.xxx.xxx eq pop3
access-list incoming permit tcp any host xx.xx.xxx.xxx eq 995
access-list incoming permit tcp any host xx.xx.xxx.xxx eq 993
access-list incoming permit tcp any host xx.xx.xxx.xxx eq imap4
access-list danuser permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.
0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside pppoe setroute
ip address inside 192.168.0.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool danuser 10.1.1.1-10.1.1.25
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list vpn
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) xx.xx.xxx.xxx 192.168.0.5 dns netmask 255.255.255.255 0
0
access-group incoming in interface outside
timeout xlate 2:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set pix esp-3des esp-md5-hmac
crypto dynamic-map cisco 90 set transform-set pix
crypto map newmap 10 ipsec-isakmp
crypto map newmap 10 match address danuser
crypto map newmap 10 set peer xx.xx.xxx.xxx
crypto map newmap 10 set transform-set pix
crypto map newmap 90 ipsec-isakmp dynamic cisco
crypto map newmap interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xxx.xxx netmask 255.255.255.255 no-xauth no-co
nfig-mode
isakmp key ******** address xx.xx.xxx.xxx netmask 255.255.255.255 no-xauth no-c
onfig-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup XXXXl address-pool XXXXXXX
vpngroup XXXXl split-tunnel vpn
vpngroup XXXXl idle-time 28800
vpngroup XXXXl password ********
vpngroup XXXd address-pool danuser
vpngroup XXXd dns-server 192.168.0.3
vpngroup XXXd idle-time 1800
vpngroup XXXd password ********
vpngroup XXXy address-pool danuser
vpngroup XXXy dns-server 192.168.0.3
vpngroup XXXy idle-time 1800
vpngroup XXXy password ********
vpngroup XXXe address-pool danuser
vpngroup XXXe dns-server 192.168.0.3
vpngroup XXXe idle-time 1800
vpngroup XXXe password ********
vpngroup XXXa address-pool danuser
vpngroup XXXa dns-server 192.168.0.3
vpngroup XXXa idle-time 1800
vpngroup XXXa password ********
vpngroup XXXn address-pool danuser
vpngroup XXXn dns-server 192.168.0.3
vpngroup XXXn idle-time 1800
vpngroup XXXn password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh xx.xx.xxx.xxx 255.255.255.128 outside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
vpdn group danuser request dialout pppoe
vpdn group danuser localname XX
vpdn group danuser ppp authentication pap
vpdn username XX *********
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
Cryptochecksum:4b814b7fd6d7e9557048398391a46c6d
: end
As you can see, I have the object-group inserted. I'm guessing that I need something like the following for the ACL.
Danuser-PIX(config)# access-list outbound remark |Block specific IP addresses from internet|
Danuser-PIX(config)# access-list outbound deny ip object-group NoInternet any
Danuser-Pix(config)# access-list outbound permit ip any any
I'm realy not sure if I need the last statement or not. Can someone tell me if I have the right idea?
Thanks,