I've got policy based routing configured as follows, and it's matching just fine. However, with test pings the source address is always the Fa0/0 interface and that's where the response comes back. Outbound packets that match ARE correctly leaving the fa0/1 interface. I can force the source address to be the Fa0/1's address and things are OK.
I want packets that match to leave and come back in on the Fa0/1 interface.
----------------------------------
interface FastEthernet0/0
description LAN Connection
ip address w.x.y.z 255.255.255.192
ip route-cache policy
ip policy route-map HTTP
interface FastEthernet0/1
ip address 192.168.252.2 255.255.255.0
access-list 1 permit a.b.c.d
route-map HTTP permit 10
match ip address 1
set ip next-hop 192.168.252.1
I want packets that match to leave and come back in on the Fa0/1 interface.
----------------------------------
interface FastEthernet0/0
description LAN Connection
ip address w.x.y.z 255.255.255.192
ip route-cache policy
ip policy route-map HTTP
interface FastEthernet0/1
ip address 192.168.252.2 255.255.255.0
access-list 1 permit a.b.c.d
route-map HTTP permit 10
match ip address 1
set ip next-hop 192.168.252.1