Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations bkrike on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Need to be able to VPN in from home

Status
Not open for further replies.

dougp25

MIS
May 8, 2006
1
US
We just recently moved our network main office from one building to another, and changed ISPs in the process. We are also implementing some Cisco IP Phones. I used to be able to use the Cisco VPN client to be able to login to the network from home (not windows login, I just want to be able to do TCP/IP stuff from home). It is no longer working! (The consultant found it faster to blow away the config and start over, but that lost all my config stuff!)

I have tried to rebuild it, here's my current config. If you can tell me what I am doing wrong, that would be awesome.

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password aeszTov9WyMJMAk1 encrypted
passwd BUV1V0Qx426/.4tE encrypted
hostname DPW-Fire-515
domain-name newmarketnh.gov
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list inbound permit icmp any any
access-list inbound permit tcp any host 66.67.68.69 eq 3389
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list nonat permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0

pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside dhcp setroute
ip address inside 192.168.1.253 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.2.1-192.168.2.254
pdm location 192.168.1.0 255.255.255.0 inside
pdm location 192.168.1.8 255.255.255.255 inside
pdm logging warnings 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 192.168.6.1 3389 netmask 255.255.255.
255 0 0
access-group inbound in interface outside
route inside 192.168.5.0 255.255.255.0 192.168.1.254 1
route inside 192.168.6.0 255.255.255.0 192.168.1.254 1
route inside 192.168.9.0 255.255.255.0 192.168.1.254 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map newmarket 10 ipsec-isakmp dynamic dynmap
crypto map newmarket client authentication LOCAL
crypto map newmarket interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup newmarket address-pool ippool
vpngroup newmarket dns-server 192.168.1.4
vpngroup newmarket split-tunnel 101
vpngroup newmarket idle-time 1800
vpngroup newmarket password ********
telnet 192.168.0.0 255.255.0.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
username dpoulin password Msm3wE02r52vpVox encrypted privilege 2
terminal width 80
Cryptochecksum:d660f31801f9039ffe754be25313a89c
 
dougp25

Can you post the original config? I have a few ideas, but I want a (previously working) baseline.




Brent
Systems Engineer / Consultant
CCNP
 
Hi Doug.
A few minor suggestions:

Do not employ these lines:
Code:
access-list inbound permit icmp any any
access-list inbound permit tcp any host 66.67.68.69 eq 3389
The first line announces you to the world.
The second line opens up your server for anyone using Remote Desktop. It's generally a big No-No from a security viewpoint. Since you will be using VPN, you're already "past" the outside interface. The "inbound" ACL wont apply to your connection anyway. Remove them and use:
Code:
sysopt connection permit-ipsec
As for connection with VPN from home, the lines you need are:
Code:
crypto map [your cryptomap] client authentication [LOCAL | TACACS | RADIUS etc.]
crypto ipsec transform-set [b]3DES-MD5[/b] esp-3des esp-md5-hmac 
crypto dynamic-map [your dynamic-map (eg. [b]vpnclients[/b])] 10 set transform-set [b]3DES-MD5[/b]
crypto map [your cryptomap (eg. VPN)] 10 ipsec-isakmp dynamic [same as above [b]vpnclients[/b], or something else of your choosing]
crypto map [your cryptomap] interface outside
isakmp enable outside

isakmp policy 1 authentication pre-share
isakmp policy 1 encryption 3des
isakmp policy 1 hash md5
isakmp policy 1 group 2
isakmp policy 1 lifetime 86400

vpngroup [groupname] address-pool [pool-name]
vpngroup [groupname] dns-server [dns srver1] [dns server2]
vpngroup [groupname] default-domain [your domain name]
vpngroup [groupname] idle-time 1800
vpngroup [groupname] password ********
Lastly, add this line:
Code:
aaa-server LOCAL protocol local
And then add the users you want to have access through VPN as you normally would add users in the PIX.

PS.
Don't forget to change the VPN address in you VPN client to match the new outside address on your PIX. This will be your VPN gateway-address. Come to think of it, you should ask your ISP to make it static.

Hope this helps

A firm beleiver of the "Keep it Simple" philosophy
Cheers
/T
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top