jlsanderson
IS-IT--Management
I have a remote location with DSL and Cisco 501 PIX.
I want to establish a peer VPN connection to Main Office with DSL and Cisco 501 PIX. Can you look at the config files and tell me why they do not connect? How to debug?
I am taking over some of the networking from a small company. I am mostly a WinTel guy. trying to get comfortable with the IOS.
Remote location config.
PIX Version 6.3 (4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password x
passwd x
hostname x
domain-name x
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit tcp any any eq 6502
access-list 100 permit udp any any eq 6502
access-list 100 permit icmp any any echo-reply
access-list 100 permit tcp any any eq 1603
access-list 100 permit tcp any any eq telnet
access-list 100 permit udp any any eq 23
access-list 150 permit ip 192.168.126.0 255.255.255.0 192.168.125.0 255.255.255.0
access-list nonat permit ip 192.168.126.0 255.255.255.0 192.168.125.0 255.255.255.0
access-list nonat permit ip 192.168.126.0 255.255.255.0 192.168.127.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xx.xx.xx.xx 255.255.255.0
ip address inside 192.168.xx.xx 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.127.11-192.168.127.20
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.xx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1200
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES esp-3des esp-md5-hmac
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map VPN 10 ipsec-isakmp
crypto map VPN 10 match address 150
crypto map VPN 10 set peer xx.xx.xx.xx
crypto map VPN 10 set transform-set ESP-3DES
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xx.xx netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 84600
vpngroup vpnclient address-pool ippool
vpngroup vpnclient dns-server
vpngroup vpnclient wins-server
vpngroup vpnclient default-domain ciscopix.com
vpngroup vpnclient idle-time 1800
vpngroup vpnclient password ********
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
management-access inside
console timeout 0
dhcpd dns
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
: end
Main Office Config.
PIX Version 6.3 (3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd
hostname
domain-name
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any echo-reply
access-list 100 permit tcp any any eq 6502
access-list 100 permit udp any any eq 6502
access-list 100 permit tcp any any eq 1603
access-list 100 permit udp any any eq 1603
access-list 100 permit tcp any any eq telnet
access-list 100 permit udp any any eq 23
access-list 100 permit tcp any any eq 4148
access-list 100 permit udp any any eq 4148
access-list nonat permit ip 192.168.125.0 255.255.255.0 192.168.126.0 255.255.255.0
access-list nonat permit ip 192.168.125.0 255.255.255.0 192.168.127.0 255.255.255.0
access-list nonat permit ip 192.168.127.0 255.255.255.0 192.168.126.0 255.255.255.0
access-list 150 permit ip 192.168.125.0 255.255.255.0 192.168.126.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xx.xx.xx.xx 255.255.255.0
ip address inside 192.168.125.xx 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.127.1-192.168.127.10
pdm location 0.0.0.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 6502 192.168.xx.2 6502 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 6502 192.168.xx.2 6502 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 4148 192.168.xx.2 4148 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 4148 192.168.xx.2 4148 netmask 255.255.255.255 0 0
rip inside default version 2
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.125.0 255.255.255.0 inside
http 192.168.127.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1200
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES esp-3des esp-md5-hmac
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map VPN 10 ipsec-isakmp
crypto map VPN 10 match address 150
crypto map VPN 10 set peer xx.xx.xx.xx
crypto map VPN 10 set transform-set ESP-3DES
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xx.xx netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpnclient address-pool ippool
vpngroup vpnclient dns-server 192.168.xx.xx
vpngroup vpnclient wins-server 192.168.xx.xx
vpngroup vpnclient default-domain ciscopix.com
vpngroup vpnclient idle-time 1800
vpngroup vpnclient password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
management-access inside
console timeout 0
dhcpd address 192.168.xx.195-192.168.xx.199 inside
dhcpd dns
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
: end
I also have a VPN client setup to the main office that works fine, but when I use the same setup for the remote office PIX, it does not work.
vpngroup vpnclient address-pool ippool
vpngroup vpnclient dns-server 192.168.xx.xx
vpngroup vpnclient wins-server 192.168.xx.xx
vpngroup vpnclient default-domain ciscopix.com
vpngroup vpnclient idle-time 1800
vpngroup vpnclient password ********
Also I have a T1 going to both areas. Coming in to 1720 Router. I assume I would not need this if the Peer to peer works?
I want to establish a peer VPN connection to Main Office with DSL and Cisco 501 PIX. Can you look at the config files and tell me why they do not connect? How to debug?
I am taking over some of the networking from a small company. I am mostly a WinTel guy. trying to get comfortable with the IOS.
Remote location config.
PIX Version 6.3 (4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password x
passwd x
hostname x
domain-name x
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit tcp any any eq 6502
access-list 100 permit udp any any eq 6502
access-list 100 permit icmp any any echo-reply
access-list 100 permit tcp any any eq 1603
access-list 100 permit tcp any any eq telnet
access-list 100 permit udp any any eq 23
access-list 150 permit ip 192.168.126.0 255.255.255.0 192.168.125.0 255.255.255.0
access-list nonat permit ip 192.168.126.0 255.255.255.0 192.168.125.0 255.255.255.0
access-list nonat permit ip 192.168.126.0 255.255.255.0 192.168.127.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xx.xx.xx.xx 255.255.255.0
ip address inside 192.168.xx.xx 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.127.11-192.168.127.20
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group 100 in interface outside
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.xx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1200
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES esp-3des esp-md5-hmac
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map VPN 10 ipsec-isakmp
crypto map VPN 10 match address 150
crypto map VPN 10 set peer xx.xx.xx.xx
crypto map VPN 10 set transform-set ESP-3DES
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xx.xx netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 84600
vpngroup vpnclient address-pool ippool
vpngroup vpnclient dns-server
vpngroup vpnclient wins-server
vpngroup vpnclient default-domain ciscopix.com
vpngroup vpnclient idle-time 1800
vpngroup vpnclient password ********
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
management-access inside
console timeout 0
dhcpd dns
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80
: end
Main Office Config.
PIX Version 6.3 (3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password
passwd
hostname
domain-name
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit icmp any any echo-reply
access-list 100 permit tcp any any eq 6502
access-list 100 permit udp any any eq 6502
access-list 100 permit tcp any any eq 1603
access-list 100 permit udp any any eq 1603
access-list 100 permit tcp any any eq telnet
access-list 100 permit udp any any eq 23
access-list 100 permit tcp any any eq 4148
access-list 100 permit udp any any eq 4148
access-list nonat permit ip 192.168.125.0 255.255.255.0 192.168.126.0 255.255.255.0
access-list nonat permit ip 192.168.125.0 255.255.255.0 192.168.127.0 255.255.255.0
access-list nonat permit ip 192.168.127.0 255.255.255.0 192.168.126.0 255.255.255.0
access-list 150 permit ip 192.168.125.0 255.255.255.0 192.168.126.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside xx.xx.xx.xx 255.255.255.0
ip address inside 192.168.125.xx 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool ippool 192.168.127.1-192.168.127.10
pdm location 0.0.0.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 6502 192.168.xx.2 6502 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 6502 192.168.xx.2 6502 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 4148 192.168.xx.2 4148 netmask 255.255.255.255 0 0
static (inside,outside) udp interface 4148 192.168.xx.2 4148 netmask 255.255.255.255 0 0
rip inside default version 2
route outside 0.0.0.0 0.0.0.0 xx.xx.xx.x 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 192.168.125.0 255.255.255.0 inside
http 192.168.127.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection tcpmss 1200
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES esp-3des esp-md5-hmac
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map VPN 10 ipsec-isakmp
crypto map VPN 10 match address 150
crypto map VPN 10 set peer xx.xx.xx.xx
crypto map VPN 10 set transform-set ESP-3DES
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap interface outside
isakmp enable outside
isakmp key ******** address xx.xx.xx.xx netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpnclient address-pool ippool
vpngroup vpnclient dns-server 192.168.xx.xx
vpngroup vpnclient wins-server 192.168.xx.xx
vpngroup vpnclient default-domain ciscopix.com
vpngroup vpnclient idle-time 1800
vpngroup vpnclient password ********
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 60
management-access inside
console timeout 0
dhcpd address 192.168.xx.195-192.168.xx.199 inside
dhcpd dns
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
dhcpd enable inside
terminal width 80
: end
I also have a VPN client setup to the main office that works fine, but when I use the same setup for the remote office PIX, it does not work.
vpngroup vpnclient address-pool ippool
vpngroup vpnclient dns-server 192.168.xx.xx
vpngroup vpnclient wins-server 192.168.xx.xx
vpngroup vpnclient default-domain ciscopix.com
vpngroup vpnclient idle-time 1800
vpngroup vpnclient password ********
Also I have a T1 going to both areas. Coming in to 1720 Router. I assume I would not need this if the Peer to peer works?