billyj1900
MIS
I am trying to setup NAT overload because I have two ISPs (cable and DSL) for redundancy. The config is below. Internet traffic from e1/0 is pinging 4.2.2.2 but at a slow pace. !.!.!.! sometimes not at all. Any suggestions?
version 12.3
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1_101
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$PzQd$SlDLCWmUUYwv0Ag.FZAMU.
!
no network-clock-participate slot 1
no network-clock-participate wic 0
aaa new-model
!
aaa authentication login default local enable
aaa session-id common
ip subnet-zero
ip cef
!
ip dhcp excluded-address 192.168.2.1 192.168.2.5
!
ip dhcp pool data
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 4.2.2.2
!
no ip bootp server
ip domain name 7217
ip audit po max-events 100
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
description ISP cable
ip address X.X.X.1 X.X.X.X
ip nat outside
ip load-sharing per-packet
duplex auto
speed auto
!
interface BRI0/0
no ip address
encapsulation hdlc
shutdown
!
interface Serial0/0
ip unnumbered Loopback0
!
interface FastEthernet0/1
description ISP dsl
ip address X.X.X.2 X.X.X.X
ip nat outside
ip load-sharing per-packet
duplex auto
speed auto
!
interface Ethernet1/0
ip address 192.168.2.1 255.255.255.0
ip nat inside
full-duplex
!
ip nat inside source route-map ISP1 interface FastEthernet0/0 overload
ip nat inside source route-map ISP2 interface FastEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 X.X.X.1
ip route 0.0.0.0 0.0.0.0 X.X.X.2
!
no ip http server
no ip http secure-server
!
access-list 101 permit ip any any
no cdp run
!
route-map ISP2 permit 10
match ip address 101
match interface FastEthernet0/1
!
route-map ISP1 permit 10
match ip address 101
match interface FastEthernet0/0
!
dial-peer cor custom
!
banner login ^C
*************************************************************************
Logins are monitored and restriced
*************************************************************************
^C
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
transport preferred ssh
transport input ssh
!
end
version 12.3
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1_101
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$PzQd$SlDLCWmUUYwv0Ag.FZAMU.
!
no network-clock-participate slot 1
no network-clock-participate wic 0
aaa new-model
!
aaa authentication login default local enable
aaa session-id common
ip subnet-zero
ip cef
!
ip dhcp excluded-address 192.168.2.1 192.168.2.5
!
ip dhcp pool data
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 4.2.2.2
!
no ip bootp server
ip domain name 7217
ip audit po max-events 100
!
interface Loopback0
no ip address
!
interface FastEthernet0/0
description ISP cable
ip address X.X.X.1 X.X.X.X
ip nat outside
ip load-sharing per-packet
duplex auto
speed auto
!
interface BRI0/0
no ip address
encapsulation hdlc
shutdown
!
interface Serial0/0
ip unnumbered Loopback0
!
interface FastEthernet0/1
description ISP dsl
ip address X.X.X.2 X.X.X.X
ip nat outside
ip load-sharing per-packet
duplex auto
speed auto
!
interface Ethernet1/0
ip address 192.168.2.1 255.255.255.0
ip nat inside
full-duplex
!
ip nat inside source route-map ISP1 interface FastEthernet0/0 overload
ip nat inside source route-map ISP2 interface FastEthernet0/1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 X.X.X.1
ip route 0.0.0.0 0.0.0.0 X.X.X.2
!
no ip http server
no ip http secure-server
!
access-list 101 permit ip any any
no cdp run
!
route-map ISP2 permit 10
match ip address 101
match interface FastEthernet0/1
!
route-map ISP1 permit 10
match ip address 101
match interface FastEthernet0/0
!
dial-peer cor custom
!
banner login ^C
*************************************************************************
Logins are monitored and restriced
*************************************************************************
^C
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
transport preferred ssh
transport input ssh
!
end