I have a cisco 2610 with two ethernet modules (one is on a module.) And my topology is like this:
[CABLE MODEM]-------[e1/0 Cisco 2610 e0/0]------[LAN]
^ ^
| |
ethernet ethernet
69.47.17.34/20 192.168.1.1/24
I can ping both interfaces and telnet into the router from another network, but i cant access the internet from within the network. It seems that the DHCP is working fine. My theory is the nat isnt configured right..?
this is my current config:
Current configuration : 1245 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname o3rat
!
enable secret 5 $1$OCnm$yubBhGOMHT7KKZlQxNyZL.
!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.10
!
ip dhcp pool 1
network 192.168.1.0 255.255.255.0
dns-server 64.233.217.2 64.233.207.
default-router 192.168.1.1
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface Ethernet0/0
description Router to Switch Connection
ip address 192.168.1.1 255.255.255.0
ip nat inside
half-duplex
!
interface Ethernet1/0
description LAN to WAN connection
ip address 69.47.17.34 255.255.248.0
ip nat outside
half-duplex
!
ip nat inside source list 99 interface Ethernet1/0 overload
ip nat inside source list 102 interface Ethernet1/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 69.47.16.1
half-duplex
!
ip nat inside source list 99 interface Ethernet1/0 overload
ip nat inside source list 102 interface Ethernet1/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 69.47.16.1
no ip http server
!
access-list 99 permit any
access-list 102 permit ip 0.0.0.0 192.168.1.254 any
!
line con 0
password 7 12010014071F0916
login
line aux 0
line vty 0 4
password 7 0831495A021617
login
!
end
Any suggestions???
[CABLE MODEM]-------[e1/0 Cisco 2610 e0/0]------[LAN]
^ ^
| |
ethernet ethernet
69.47.17.34/20 192.168.1.1/24
I can ping both interfaces and telnet into the router from another network, but i cant access the internet from within the network. It seems that the DHCP is working fine. My theory is the nat isnt configured right..?
this is my current config:
Current configuration : 1245 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname o3rat
!
enable secret 5 $1$OCnm$yubBhGOMHT7KKZlQxNyZL.
!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.1.2
ip dhcp excluded-address 192.168.1.3
ip dhcp excluded-address 192.168.1.10
!
ip dhcp pool 1
network 192.168.1.0 255.255.255.0
dns-server 64.233.217.2 64.233.207.
default-router 192.168.1.1
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface Ethernet0/0
description Router to Switch Connection
ip address 192.168.1.1 255.255.255.0
ip nat inside
half-duplex
!
interface Ethernet1/0
description LAN to WAN connection
ip address 69.47.17.34 255.255.248.0
ip nat outside
half-duplex
!
ip nat inside source list 99 interface Ethernet1/0 overload
ip nat inside source list 102 interface Ethernet1/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 69.47.16.1
half-duplex
!
ip nat inside source list 99 interface Ethernet1/0 overload
ip nat inside source list 102 interface Ethernet1/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 69.47.16.1
no ip http server
!
access-list 99 permit any
access-list 102 permit ip 0.0.0.0 192.168.1.254 any
!
line con 0
password 7 12010014071F0916
login
line aux 0
line vty 0 4
password 7 0831495A021617
login
!
end
Any suggestions???