Im trying to setup NAT with a 2514 router and Sprint Broadband and am having some difficulties. My broadband modem is connected ethernet1 and my local network is connected to ethernet0. I just can not seem to get an internet connection going on my PC. My configuration is as follows:
ip name-server 24.221.129.4
!
ip subnet-zero
ip domain-lookup
ip routing
!
interface Ethernet 0
no shutdown
description connected to EthernetLAN
ip address 10.10.1.1 255.255.255.0
ip nat inside
keepalive 10
!
interface Ethernet 1
no shutdown
description connected to Internet
ip address 24.221.136.17 255.255.255.0
ip nat outside
keepalive 10
! Access Control List 1
!
no access-list 1
access-list 1 permit 10.10.1.0 0.0.0.255
!
! Dynamic NAT
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
ip nat inside source list 1 interface Ethernet 1 overload
!
router rip
version 2
network 10.0.0.0
passive-interface Ethernet 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Ethernet 1
I can ping both ehthernet0 and ethernet1 from the client PC.
The show ip nat statistics reveals the following:
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
Ethernet1
Inside interfaces:
Ethernet0
Hits: 118 Misses: 129
Expired translations: 129
Dynamic mappings:
-- Inside Source
access-list 101 interface Ethernet1 refcount 0
The show ip nat translations reveals:
Pro Inside global Inside local Outside local Outside global
udp 24.221.136.17:1027 10.10.1.6:1027 24.221.129.4:53 24.221.129.4:53
udp 24.221.136.17:1027 10.10.1.6:1027 24.221.129.5:53 24.221.129.5:53
udp 24.221.136.17:1090 10.10.1.6:1090 24.221.129.4:53 24.221.129.4:53
udp 24.221.136.17:1090 10.10.1.6:1090 24.221.129.5:53 24.221.129.5:53
I have read many examples and even bought some books on cisco routing but am unable to get this working. Does anyone have any ideas of what may be wrong?
ip name-server 24.221.129.4
!
ip subnet-zero
ip domain-lookup
ip routing
!
interface Ethernet 0
no shutdown
description connected to EthernetLAN
ip address 10.10.1.1 255.255.255.0
ip nat inside
keepalive 10
!
interface Ethernet 1
no shutdown
description connected to Internet
ip address 24.221.136.17 255.255.255.0
ip nat outside
keepalive 10
! Access Control List 1
!
no access-list 1
access-list 1 permit 10.10.1.0 0.0.0.255
!
! Dynamic NAT
!
ip nat translation timeout 86400
ip nat translation tcp-timeout 86400
ip nat translation udp-timeout 300
ip nat translation dns-timeout 60
ip nat translation finrst-timeout 60
ip nat inside source list 1 interface Ethernet 1 overload
!
router rip
version 2
network 10.0.0.0
passive-interface Ethernet 1
no auto-summary
!
!
ip classless
!
! IP Static Routes
ip route 0.0.0.0 0.0.0.0 Ethernet 1
I can ping both ehthernet0 and ethernet1 from the client PC.
The show ip nat statistics reveals the following:
Total active translations: 0 (0 static, 0 dynamic; 0 extended)
Outside interfaces:
Ethernet1
Inside interfaces:
Ethernet0
Hits: 118 Misses: 129
Expired translations: 129
Dynamic mappings:
-- Inside Source
access-list 101 interface Ethernet1 refcount 0
The show ip nat translations reveals:
Pro Inside global Inside local Outside local Outside global
udp 24.221.136.17:1027 10.10.1.6:1027 24.221.129.4:53 24.221.129.4:53
udp 24.221.136.17:1027 10.10.1.6:1027 24.221.129.5:53 24.221.129.5:53
udp 24.221.136.17:1090 10.10.1.6:1090 24.221.129.4:53 24.221.129.4:53
udp 24.221.136.17:1090 10.10.1.6:1090 24.221.129.5:53 24.221.129.5:53
I have read many examples and even bought some books on cisco routing but am unable to get this working. Does anyone have any ideas of what may be wrong?