Hello all
Wondered if someone could help.
I'm trying to Nat all inside traffic out via atm card ip address, which seems to work fine.
The problem I've got is allowing external traffic inbound on port 8080. I've added what I think to be the command but it dosn't seem to work.
I think my problem is access list related, but I know very little about access lists.I've attached a copy of my config, If anyone could spare the time to have a look over it and let me know where I'm going wrong I would be very greatful.
P.s I think it may be related but I can't see the http server either.
Thanks again
Rob
Using 2633 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname ISP router
!
enable password *************
!
no ip subnet-zero
ip cef
!
!
ip name-server ***********
ip name-server ***********
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
isdn switch-type basic-net3
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
backup delay 10 10
backup interface Dialer2
no ip address
ip mtu 1492
ip nat outside
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
no fair-queue
!
interface FastEthernet0/0
ip address 192.168.6.2 255.255.0.0
ip nat inside
speed 10
full-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address 1.1.1.1 255.255.255.252
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname chap username
ppp chap password chap password
ppp pap sent-username PAP username
!
router rip
version 2
network 172.48.0.0
no auto-summary
!
ip nat pool isp 1.1.1.1 1.1.1.1 prefix-length 24
ip nat inside source list 1 pool isp overload
ip nat inside source static tcp 172.48.6.1 8080 1.1.1.1 8080 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 172.48.0.0 255.255.0.0 FastEthernet0/0
ip http server
ip pim bidir-enable
!
!
no logging trap
access-list 1 permit any
dialer-list 1 protocol ip permit
!
snmp-server community public RO
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
banner login ^C
*************************************************
* *
* Do not attempt to log on unless you *
* are an authorized user! *
* *
*************************************************
^C
!
line con 0
line aux 0
line vty 0 4
password **********
login
!
!
end
Wondered if someone could help.
I'm trying to Nat all inside traffic out via atm card ip address, which seems to work fine.
The problem I've got is allowing external traffic inbound on port 8080. I've added what I think to be the command but it dosn't seem to work.
I think my problem is access list related, but I know very little about access lists.I've attached a copy of my config, If anyone could spare the time to have a look over it and let me know where I'm going wrong I would be very greatful.
P.s I think it may be related but I can't see the http server either.
Thanks again
Rob
Using 2633 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname ISP router
!
enable password *************
!
no ip subnet-zero
ip cef
!
!
ip name-server ***********
ip name-server ***********
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
isdn switch-type basic-net3
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
backup delay 10 10
backup interface Dialer2
no ip address
ip mtu 1492
ip nat outside
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
dsl operating-mode auto
no fair-queue
!
interface FastEthernet0/0
ip address 192.168.6.2 255.255.0.0
ip nat inside
speed 10
full-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address 1.1.1.1 255.255.255.252
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname chap username
ppp chap password chap password
ppp pap sent-username PAP username
!
router rip
version 2
network 172.48.0.0
no auto-summary
!
ip nat pool isp 1.1.1.1 1.1.1.1 prefix-length 24
ip nat inside source list 1 pool isp overload
ip nat inside source static tcp 172.48.6.1 8080 1.1.1.1 8080 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 172.48.0.0 255.255.0.0 FastEthernet0/0
ip http server
ip pim bidir-enable
!
!
no logging trap
access-list 1 permit any
dialer-list 1 protocol ip permit
!
snmp-server community public RO
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
banner login ^C
*************************************************
* *
* Do not attempt to log on unless you *
* are an authorized user! *
* *
*************************************************
^C
!
line con 0
line aux 0
line vty 0 4
password **********
login
!
!
end