I am having a few problems with inter vlan routing between 3350,3560 and a few 2950's.
the 3350 is a 12 port gigabit switch which 5 of the ports are congifured as trunk ports and link to each individual switch.
I am using VTP the 3560 is the server and is also the routing switch. I have 2 vlans 1 for data and 2 for voice.
the problem i am having is that i can not ping from 1 vlan to the other even though i have L3 configuration and trunk ports on all switches set for dot1q as thats all 2950's support.
Vlan 1 is my active vlan on all switches and have ip addresses configured 172.16.10.XXX per switch.
Here is the config of the 3560 switch to see anyone can figure out what my problem will be.
Building configuration...
Current configuration : 4700 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw_006
!
enable secret 5 $1$w6bJ$M3gF8DBHzVqAKxLoqJp8r1
!
ip subnet-zero
ip routing
!
ip host sw_001 172.16.10.101
ip host sw_002 172.16.10.102
ip host sw_003 172.16.10.103
ip host sw_004 172.16.10.104
ip host sw_005 172.16.10.105
ip host sw_006 172.16.10.106
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
description Cisco PIX Firewall
switchport mode access
!
interface FastEthernet0/2
description Telephone system server
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/10
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/14
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/15
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/17
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/18
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-3,1000-1005
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 172.16.10.106 255.255.0.0
!
interface Vlan3
ip address 172.17.0.1 255.255.0.0
!
ip default-gateway 172.16.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.1
ip http server
!
!
control-plane
!
!
end
sw_006#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
C 172.17.0.0/16 is directly connected, Vlan3
C 172.16.0.0/16 is directly connected, Vlan1
S* 0.0.0.0/0 [1/0] via 172.16.0.1
Thank you in advance
Ian
the 3350 is a 12 port gigabit switch which 5 of the ports are congifured as trunk ports and link to each individual switch.
I am using VTP the 3560 is the server and is also the routing switch. I have 2 vlans 1 for data and 2 for voice.
the problem i am having is that i can not ping from 1 vlan to the other even though i have L3 configuration and trunk ports on all switches set for dot1q as thats all 2950's support.
Vlan 1 is my active vlan on all switches and have ip addresses configured 172.16.10.XXX per switch.
Here is the config of the 3560 switch to see anyone can figure out what my problem will be.
Building configuration...
Current configuration : 4700 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname sw_006
!
enable secret 5 $1$w6bJ$M3gF8DBHzVqAKxLoqJp8r1
!
ip subnet-zero
ip routing
!
ip host sw_001 172.16.10.101
ip host sw_002 172.16.10.102
ip host sw_003 172.16.10.103
ip host sw_004 172.16.10.104
ip host sw_005 172.16.10.105
ip host sw_006 172.16.10.106
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
interface FastEthernet0/1
description Cisco PIX Firewall
switchport mode access
!
interface FastEthernet0/2
description Telephone system server
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/4
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/5
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/6
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/8
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/9
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/10
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/11
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/12
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/13
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/14
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/15
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/16
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/17
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/18
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/19
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/20
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/21
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/22
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/23
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/24
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,2,1002-1005
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-3,1000-1005
switchport mode trunk
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 172.16.10.106 255.255.0.0
!
interface Vlan3
ip address 172.17.0.1 255.255.0.0
!
ip default-gateway 172.16.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.0.1
ip http server
!
!
control-plane
!
!
end
sw_006#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.16.0.1 to network 0.0.0.0
C 172.17.0.0/16 is directly connected, Vlan3
C 172.16.0.0/16 is directly connected, Vlan1
S* 0.0.0.0/0 [1/0] via 172.16.0.1
Thank you in advance
Ian