Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations TouchToneTommy on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Get DNS address when using DHCP

Status
Not open for further replies.

Tobius

Programmer
Nov 22, 2002
2
US
I have a cisco 806 router attached to a DSL modem at home. I have set DHCP on the outside interface, and if I hardcode the DNS addresses in the pool, all works fine. My question is how do I get DHCP to provide the DNS addresses? I know that it sees them from the following:

Code:
Router#show dhcp server
   DHCP server: ANY (255.255.255.255)
    Leases:   3
    Offers:   1      Requests: 3     Acks: 3     Naks: 0
    Declines: 0      Releases: 0     Bad:  0
    DNS0:   12.44.113.7,   DNS1:  12.44.112.8
    Subnet: 255.255.0.0   DNS Domain: 101freeway.com

Without the hardcoding, my PC sees DNS server address of 0.0.0.0. My configuration, for the most part, is as follows:

Code:
!
ip subnet-zero
no ip domain-lookup
ip dhcp excluded-address 192.168.39.1
ip dhcp relay information trust-all
!
ip dhcp pool CLIENT
   import all
   network 192.168.39.0 255.255.255.0
   default-router 192.168.39.1
   domain-name CLIENT
   dns-server 12.44.113.8 12.44.112.7 12.127.16.67
!
ip audit notify log
ip audit po max-events 100
!
!
!
interface Ethernet0
 description Inside
 ip address 192.168.39.1 255.255.255.0
 ip nat inside
 no cdp enable
 hold-queue 100 out
!
interface Ethernet1
 description Outside
 ip address dhcp
 ip nat outside
 no cdp enable
!
ip nat inside source list 102 interface Ethernet1 overload
ip classless
no ip http server
ip pim bidir-enable
!
!
access-list 102 permit ip 192.168.39.0 0.0.0.255 any
no cdp run
 
try changing the domain-name to:

domain-name 101freeway.com.

Just a thought after looking at your dhcp pool, and also remove your dns-server statements. see if that works

brian
 
Thanks, Brian. I had tried that before without success. However, I did what you said, and did ipconfig /release and /renew on my PC but that did not get the DNS server. So then I did a reload on the router (which I had not done before), then a release/renew on the PC and now the DNS servers show up. Thanks again.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top