kenmiecomputer
Vendor
I am trying to implement QOS for VOIP but can't seem to get any of the packets to go into the priority queue. This is an Avaya phone system that is tagging the packets with DSCP of 46 and 34 and COS of 5. I have 2950 switches and 1760 routers. Below are the configurations that I have in place. There is onle one VLAN (long story). What am I missing?
If I do a "show policy-map int s0/0" I see the below output but as you can see there are no matches:
Serial0/0
Service-policy output: voipQoS
Class-map: VoIP (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef
0 packets, 0 bytes
5 minute rate 0 bps
Match: ip dscp af41
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 768 (kbps) Burst 19200 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0
Class-map: class-default (match-any)
6818395 packets, 1036550438 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/58/0
exponential weight: 9
dscp Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
af11 0/0 0/0 0/0 32 40 1/10
af12 0/0 0/0 0/0 28 40 1/10
af13 0/0 0/0 0/0 24 40 1/10
af21 0/0 0/0 0/0 32 40 1/10
af22 0/0 0/0 0/0 28 40 1/10
af23 0/0 0/0 0/0 24 40 1/10
af31 0/0 0/0 0/0 32 40 1/10
af32 0/0 0/0 0/0 28 40 1/10
af33 0/0 0/0 0/0 24 40 1/10
af41 0/0 0/0 0/0 32 40 1/10
af42 0/0 0/0 0/0 28 40 1/10
af43 0/0 0/0 0/0 24 40 1/10
cs1 0/0 0/0 0/0 22 40 1/10
cs2 0/0 0/0 0/0 24 40 1/10
cs3 0/0 0/0 0/0 26 40 1/10
cs4 0/0 0/0 0/0 28 40 1/10
cs5 0/0 0/0 0/0 30 40 1/10
cs6 1593/122843 0/0 0/0 32 40 1/10
cs7 0/0 0/0 0/0 34 40 1/10
ef 0/0 0/0 0/0 36 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
default 6816750/1036381477 21/17228 37/31356 20 40 1/10
___________________
Router Config:
!
class-map match-any VoIP
match ip dscp ef
match ip dscp af41
!
policy-map voipQoS
class VoIP
priority 768
class class-default
fair-queue
random-detect dscp-based
!
interface FastEthernet0/0
no ip address
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address x.x.x.x x.x.x.x
!
interface Serial0/0
bandwidth 1544
no ip address
service-policy output voipQoS
encapsulation frame-relay
no ip mroute-cache
service-module t1 timeslots 1-24
frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
ip address x.x.x.x x.x.x.x
frame-relay interface-dlci 100 IETF
!
Switch Config:
interface FastEthernet0/1
switchport mode trunk
switchport priority extend trust
no ip address
duplex full
speed 100
spanning-tree portfast
!
If I do a "show policy-map int s0/0" I see the below output but as you can see there are no matches:
Serial0/0
Service-policy output: voipQoS
Class-map: VoIP (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp ef
0 packets, 0 bytes
5 minute rate 0 bps
Match: ip dscp af41
0 packets, 0 bytes
5 minute rate 0 bps
Queueing
Strict Priority
Output Queue: Conversation 264
Bandwidth 768 (kbps) Burst 19200 (Bytes)
(pkts matched/bytes matched) 0/0
(total drops/bytes drops) 0/0
Class-map: class-default (match-any)
6818395 packets, 1036550438 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
Queueing
Flow Based Fair Queueing
Maximum Number of Hashed Queues 256
(total queued/total drops/no-buffer drops) 0/58/0
exponential weight: 9
dscp Transmitted Random drop Tail drop Minimum Maximum Mark
pkts/bytes pkts/bytes pkts/bytes thresh thresh prob
af11 0/0 0/0 0/0 32 40 1/10
af12 0/0 0/0 0/0 28 40 1/10
af13 0/0 0/0 0/0 24 40 1/10
af21 0/0 0/0 0/0 32 40 1/10
af22 0/0 0/0 0/0 28 40 1/10
af23 0/0 0/0 0/0 24 40 1/10
af31 0/0 0/0 0/0 32 40 1/10
af32 0/0 0/0 0/0 28 40 1/10
af33 0/0 0/0 0/0 24 40 1/10
af41 0/0 0/0 0/0 32 40 1/10
af42 0/0 0/0 0/0 28 40 1/10
af43 0/0 0/0 0/0 24 40 1/10
cs1 0/0 0/0 0/0 22 40 1/10
cs2 0/0 0/0 0/0 24 40 1/10
cs3 0/0 0/0 0/0 26 40 1/10
cs4 0/0 0/0 0/0 28 40 1/10
cs5 0/0 0/0 0/0 30 40 1/10
cs6 1593/122843 0/0 0/0 32 40 1/10
cs7 0/0 0/0 0/0 34 40 1/10
ef 0/0 0/0 0/0 36 40 1/10
rsvp 0/0 0/0 0/0 36 40 1/10
default 6816750/1036381477 21/17228 37/31356 20 40 1/10
___________________
Router Config:
!
class-map match-any VoIP
match ip dscp ef
match ip dscp af41
!
policy-map voipQoS
class VoIP
priority 768
class class-default
fair-queue
random-detect dscp-based
!
interface FastEthernet0/0
no ip address
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address x.x.x.x x.x.x.x
!
interface Serial0/0
bandwidth 1544
no ip address
service-policy output voipQoS
encapsulation frame-relay
no ip mroute-cache
service-module t1 timeslots 1-24
frame-relay lmi-type ansi
!
interface Serial0/0.1 point-to-point
ip address x.x.x.x x.x.x.x
frame-relay interface-dlci 100 IETF
!
Switch Config:
interface FastEthernet0/1
switchport mode trunk
switchport priority extend trust
no ip address
duplex full
speed 100
spanning-tree portfast
!