I am having an issue with setting up DHCP and ACL on an ethernet port. I am using a Cisco 2621 router.
(I am doing this not from a copy paste, so if the commands a little off it is because of that)
ip dhcp pool test
network 192.168.1.0
default-router 192.168.1.1
int lo0
ip add 1.1.1.1 255.0.0.0
int fa0/1
ip add 192.168.1.1 255.255.255.0
no shut
ip access-group test in
ip access-list extended test
permit tcp any any eq 67
permit ip host 192.168.1.3 host 1.1.1.1
Basically I am trying to take a network and allow only certain ips within that network to go out a certain external IP, simulated by the loopback interface. However, when I place both the ACL and the DHCP on the port, the DHCP gets cancelled out. Do I have it set for the wrong port?
(I am doing this not from a copy paste, so if the commands a little off it is because of that)
ip dhcp pool test
network 192.168.1.0
default-router 192.168.1.1
int lo0
ip add 1.1.1.1 255.0.0.0
int fa0/1
ip add 192.168.1.1 255.255.255.0
no shut
ip access-group test in
ip access-list extended test
permit tcp any any eq 67
permit ip host 192.168.1.3 host 1.1.1.1
Basically I am trying to take a network and allow only certain ips within that network to go out a certain external IP, simulated by the loopback interface. However, when I place both the ACL and the DHCP on the port, the DHCP gets cancelled out. Do I have it set for the wrong port?