Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations wOOdy-Soft on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Configuring Sub-interfaces in router 877? 2

Status
Not open for further replies.

yemaya

Technical User
Sep 13, 2006
140
CA
Hi Guys;

I have 4 subnets configurated and i want to replace an old router for one 877, i have adsl right now, i have static ip and dhcp running to provide ip's to all subnets inside, here is what i want to do in the 877:

Code:
interface FastEthernet0/0
 no shutdown
 no ip address
!
interface FastEthernet0/0.1
 no shutdown
 encapsulation dot1Q 1 native
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.10
 no shutdown
 encapsulation dot1Q 10
 ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.20
 no shutdown
 encapsulation dot1Q 20
 ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.30
 no shutdown
 encapsulation dot1Q 30
 ip address 192.168.4.1 255.255.255.0
!
interface FastEthernet0/0.40
 no shutdown
 encapsulation dot1Q 40
 ip address 192.168.5.1 255.255.255.0

Can i do this in the 877 ?.

Thanks in advance.
 
What kind of switch are you planning on connecting this to? I think it'll only work if you have something like a 2960 that supports vlans and trunking. Otherwise, it won't work.
 
Hi.

I have one 2950, will this switch work?.

Thanks.
 
Hi.

That is what i have right now in my router but what i need to know is how to do it, if i have to do it under vlan interface or other interface?.

Thanks.
 
I don't think you can do sub-interfaces on an 877, you must do this via VLAN's and trunks, however there are limitations....

The Advanced Security IOS only supports a single VLAN interface, the Advanced IP Services IOS supports a maximum of 4 VLAN interfaces. Configuration for this would be something like:

Code:
vlan 10
 name VLAN-10
vlan 20
 name VLAN-20
vlan 30
 name VLAN-30
vlan 40
 name VLAN-40
!
interface FastEthernet1
 switchport access vlan 10
!
interface FastEthernet2
 switchport access vlan 20
!
interface FastEthernet3
 switchport access vlan 30
!
interface FastEthernet4
 switchport access vlan 40
!
interface Vlan10
 ip address 10.1.1.1 255.255.255.0
!
interface Vlan20
 ip address 10.1.2.1 255.255.255.0
!
interface Vlan30
 ip address 10.1.3.1 255.255.255.0
!
interface Vlan40
 ip address 10.1.4.1 255.255.255.0
!

HTH

Andy
 
Interesting info ADB.. I assumed that the 4 switch-ports on the 877s were unmanaged "dumb ports"
 
Hi.

Thanks for your help but i know how to create subinterfaces, my question is: if a create the subinterfaces under the fastethernet0/0 what i have to do under interface vlan1?, just leave it shutdown or what?.

Thanks.
 
I've got an old Cisco 804 in my lab and I just verified that it does do subinterfaces.... However, the IOS is 11.2, so the configuration is a bit different than the above....
As far as vlan1 goes, you need that vlan because it is the native vlan...
 
Hi.

Thanks for your help but i know how to create subinterfaces, my question is: if a create the subinterfaces under the fastethernet0/0 what i have to do under interface vlan1?, just leave it shutdown or what?.

Thanks.

I have an 877 running 12.4(11)T2 Advanced IP Services and you can't create subinterfaces, you must do what I posted in my previous post:

Code:
cisco-877(config)#interface fastEthernet 1.10
                            ^
% Invalid input detected at '^' marker.

cisco-877(config)#

The FastEthernet interfaces on the 877 are just Layer-2. You may configure them as 802.1q trunks but from a Layer-3 perspective the 877 can only support 4 SVI's, and ONLY if you have Advanced IP Services IOS.

HTH

Andy
 
yemaya, I just noticed one other thing with your initial config...

interface FastEthernet0/0.1
no shutdown
encapsulation dot1Q 1 native

The vlan 1 interface shouldn't have an IP because it's the default vlan...

 
yemaya, I just noticed one other thing with your initial config...

interface FastEthernet0/0.1
no shutdown
encapsulation dot1Q 1 native

The vlan 1 interface shouldn't have an IP because it's the default vlan...

Yes, but you still can't create sub-interfaces on an 877..... ;o)
 
Hi guys,

I got it guys, i used my 1760 with one wic-1adsl and i got all my vlans running.

Thanks guys for your help.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top