Yes, its possible .... but Im not sure why you want to do it. Honestly you would be better off with a broadband router unless there is something you are trying to accomplish.
I tried with no real success, router to modem (Speedstream, old). I have a 2620XM, and bought a WIC-1ADSL, and it works great. I did this for my home lab, and so I can mess around with VPN configs and such.
I tried that, letting the modem do the PPP and letting the router do ppp in bridge mode. The modem doing PPP I think maybe worked, but the modem has no port forwarding in it, so there's no way to do VPN, ftp (or any other set up that requires certain layer 4 through layer 7 to pass through to the router).
The reason I want to do it is to start getting more familiar with Cisco stuff. I have messed with routers and switches and even core switches but with T1 and gigaman. I am just not really sure on how the setup with DSL will work. So that means I need a WIC-1ADSL burtsbees??? It doesn't work from modem to router directly???
Well, if you get a 2600, then make sure it has an IOS that can handle a WIC-1ADSL just in case. There are modems that jive good with a Cisco---mine just was not one of them.
Hello
If you have a ADSL modem it will work without having to buy a WIC-1ADSL .My setup at home is the same.I have a ADSL modem with a Cisco 1718 natting my internal LAN.If you need help setting it up no problem.
Regards
Heres a config that might help set it up...I use another ISP so now I dont care who sees it.
------------------------
sh run
Building configuration...
Current configuration : 5757 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname internet
!
logging queue-limit 100
enable secret 5 $1$e4/W$g5CRhNS1fJ4cXOmh1yv681
!
ip subnet-zero
!
!
ip domain lookup source-interface Dialer1
ip domain name pcnetworking.ca
ip name-server 65.39.192.130
!
ip dhcp pool INTERNET_ACESS
network 192.168.1.0 255.255.255.0
domain-name domain.com
dns-server 192.168.1.1 65.39.192.130
default-router 192.168.1.1
lease 7
!
ip dhcp pool INTERNET_ACCESS
!
ip audit notify log
ip audit po max-events 100
vpdn enable
!
vpdn-group Internet
accept-dialin
protocol pppoe
virtual-template 1
!
vpdn-group pppoe
!
!
!
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Ethernet0/0
ip address 192.168.1.1 255.255.255.0
ip nat inside
half-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
no ip route-cache
no ip mroute-cache
half-duplex
pppoe enable
pppoe-client dial-pool-number 1
!
interface Dialer1
ip address negotiated
ip access-group internet in
ip mtu 1495
ip nat outside
encapsulation ppp
no ip route-cache
no ip mroute-cache
dialer pool 1
dialer idle-timeout 2147483
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username username@ispserver.com password myadslpassword
ip nat inside source list 1 interface Dialer1 overload
ip nat inside source static tcp 192.168.1.101 1731 interface Dialer1 1731
ip nat inside source static tcp 192.168.1.101 1720 interface Dialer1 1720
ip nat inside source static tcp 192.168.1.101 1503 interface Dialer1 1503
ip nat inside source static tcp 192.168.1.101 522 interface Dialer1 522
ip nat inside source static tcp 192.168.1.101 389 interface Dialer1 389
ip nat inside source static udp 192.168.1.101 8888 interface Dialer1 8888
ip nat inside source static tcp 192.168.1.44 47494 interface Dialer1 47494
ip nat inside source static tcp 192.168.1.44 6881 interface Dialer1 6881
ip nat inside source static tcp 192.168.1.101 3389 interface Dialer1 22
ip nat inside source static tcp 192.168.1.254 443 interface Dialer1 443
ip nat inside source static tcp 192.168.1.254 25 interface Dialer1 25
ip nat inside source static udp 192.168.1.254 6881 interface Dialer1 6881
ip nat inside source static tcp 192.168.1.101 8888 interface Dialer1 8888
ip nat inside source static tcp 192.168.1.100 1723 interface Dialer1 1723
ip nat inside source static tcp 192.168.1.101 21 interface Dialer1 21
ip nat inside source static tcp 192.168.1.101 1977 interface Dialer1 1977
ip nat inside source static tcp 192.168.1.101 1877 interface Dialer1 1877
ip nat inside source static tcp 192.168.1.202 80 interface Dialer1 80
ip nat inside source static tcp 192.168.1.202 3389 interface Dialer1 3390
ip nat inside source static tcp 192.168.1.201 3389 interface Dialer1 3389
no ip http server
no ip http secure-server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip dns server
!
!
ip access-list extended internet
permit tcp any any eq www
permit tcp any any eq smtp
permit tcp any any eq ftp
permit tcp any any eq 443
permit tcp any any eq 1723
permit tcp any any eq 22
permit udp any any eq 6881
permit tcp any any eq 6881
permit tcp any any eq 47494
permit tcp any host 192.168.1.101 eq 8888
permit tcp any any eq 3389
permit tcp any host 192.168.1.101 eq 389
permit tcp any host 192.168.1.101 eq 522
permit tcp any host 192.168.1.101 eq 1503
permit tcp any host 192.168.1.101 eq 1720
permit tcp any any eq 1977
permit tcp any any eq 1877
permit tcp any any eq 3390
permit ip any any
!
ip access-list extended outbound
deny tcp any host 72.14.205.83
deny tcp any host 72.14.205.19
permit ip any any
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit
!
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
!
line con 0
password pass
line aux 0
line vty 0 4
password pass
login
!
!
end
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.