HI,
i'm trying to configure nat for internet access over adsl. i did configure the atm0 and dialer and i am getting an ip address from the ISP. My problem is that no one on the network can access the internet, so i'm guessing i have a nat problem. here's my config. any suggestions is appreciated. thanks.
current configuration: 1038 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
vpdn enable
!
vpdn-group pppoe
request dialin
protocol pppoe
!
!
!
interface atm0
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface fastethernet0
ip address 192.168.1.1 255.255.255.0
ip tcp adjust-mss 1452
speed auto
!
interface dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname x
ppp chap password 0
ppp pap sent-username x password 0
!
ip nat inside souce list 1 interface dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
ip pim bidir-enable
!
!
access-list permit any
!
!
line con 0
line aux 0
line vty 0 4
no scheduler allocate
end
i'm trying to configure nat for internet access over adsl. i did configure the atm0 and dialer and i am getting an ip address from the ISP. My problem is that no one on the network can access the internet, so i'm guessing i have a nat problem. here's my config. any suggestions is appreciated. thanks.
current configuration: 1038 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
vpdn enable
!
vpdn-group pppoe
request dialin
protocol pppoe
!
!
!
interface atm0
no ip address
no atm ilmi-keepalive
pvc 0/35
pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
interface fastethernet0
ip address 192.168.1.1 255.255.255.0
ip tcp adjust-mss 1452
speed auto
!
interface dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
ppp chap hostname x
ppp chap password 0
ppp pap sent-username x password 0
!
ip nat inside souce list 1 interface dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 dialer1
no ip http server
ip pim bidir-enable
!
!
access-list permit any
!
!
line con 0
line aux 0
line vty 0 4
no scheduler allocate
end