Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations TouchToneTommy on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

ADSL config on a cisco 1721

Status
Not open for further replies.

DG659

IS-IT--Management
Aug 20, 2003
157
GB
Sorry to be a Pain.
I know theres a config out there for a cisco 1721 but i just can find it .I have looked honest!

I would be really really greatfull if someone could post me an idiots guide to setting up my cisco 1721 for connection to UK Adsl (PPOPA vxmux vpi=0 vci=38) internet and to hand out dhcp on my lan dont care what the Lan IP is you decide.

thanks in advance.
 
Do you have a WIC-1ADSL or a modem connecting to the 1721? I'll be glad to help...

Burt
 
its a WIC-1ADSL there is also a WIC 1B S/T tho that will not be configured foe the moment anyway.

thanks any help would be greatly recieved
 
First thing you need to do is get the Ethernet interface up and define it as NAT inside:
Code:
interface FastEthernet0
 ip address 192.168.1.254 255.255.255.0
 ip nat inside
 no shut
!
Then bring the ADSL interface up and define it as NAT outside - I have listed both PAP & CHAP configurations, depending on your ISP one of these will be relevent:
Code:
interface ATM0
 no atm ilmi-keepalive
 dsl operating-mode auto
 no shut
 pvc 0/38 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
!
interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap pap callin
 ppp chap hostname username@isp.com
 ppp chap password PASS
 ppp pap sent-username username@isp.com password PASS
 ppp ipcp dns request accept
!
You then need to configure what you are going to NAT and a default route:
Code:
access-list 10 permit 192.168.1.0 0.255.255.255
ip nat inside source list 10 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1

That should be enough to get the ADSL connection up. You will need to either configure your PC with a static IP address (in the network 192.168.1.0/24) or add a DHCP scope on the router:
Code:
ip dhcp pool DHCP-Pool
   import all
   network 192.168.120.0 255.255.255.240
   domain-name YOUR.DOMAIN.COM
   default-router 192.168.1.254
   lease 1
!

You should probably also create an ACL or if you have Firewall features enable them to restrict the inbound access, NAT will protect you somewhat but hackers can work around it.

I am sure some other people will be on here to add to this...

Andy
 
The easiest way is to use SDM, by configuring an IP address in the same subnet as a computer that can connect to it (which usually has SDM loaded on it), and a username password...
router(config#username bla priv 15 secret blabla
router(config)#ip http server
router(config)#ip http authentication local

Burt
 
SDM ?
Im all in favour of a GUI
where do i get this and is it free ?
thanks
 
sorry people i am not ignoring your kind help but the wife has me so busy i havent had a chance.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top