Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Chriss Miller on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Adding a stub to an existing environment (home lab)

Status
Not open for further replies.

labgrl76

IS-IT--Management
Dec 2, 2005
40
US
Hey all,

What I am trying to accomplish is merely a simulated wan connection via dce/dte cables between a 2514 and a 2620. The configuration of Site_A actually works and is connected to a linksys wireless "router" :) Anyhow, I've managed to get both routers to actually ping one anothers ethernet interfaces but can't seem to get past e0. I've done research but was wondering if anyone had some suggestions on what I am either missing or doing incorrectly. Perhaps I'm using the wrong routing protocol? As always thanks in advance :D

linksys>-----e0-site_A-e1------<hub
|
s0 (172.16.2.1)
|
|
s0/0 (172.16.2.2)
|
site_C-fa0/0---<hub>-----<laptop w/static ip>


SITE_A
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Site_A
!
boot-start-marker
boot-end-marker
!
enable secret 5 $xxxxxxxxxxxxxxxxxxxxxx.
!
no aaa new-model
ip subnet-zero
no ip source-route
ip cef
no ip domain lookup
no ip dhcp conflict logging
ip dhcp excluded-address 10.0.100.1 10.0.100.99
!
ip dhcp pool internal
network 10.0.100.0 255.255.255.0
default-router 10.0.100.1
dns-server 64.87.64.146 68.87.75.194
netbios-name-server 10.0.100.2 10.0.100.3
lease 5
!
no ip bootp server
!
!
!
interface Ethernet0
description Connection to Linksys
ip address dhcp
ip access-group 100 in
ip access-group 101 out
no ip unreachables
no ip proxy-arp
ip nat outside
no cdp enable
!
interface Ethernet1
description INTERNAL LAN
ip address 10.0.100.1 255.255.255.0
no ip proxy-arp
ip nat inside
no ip route-cache
no cdp enable
!
interface Serial0
description Wan link to Site_C
bandwidth 64
ip address 172.16.2.1 255.255.255.0
clockrate 64000
no fair-queue
no cdp enable
!
interface Serial1
no ip address
shutdown
no fair-queue
!
router rip
network 10.0.0.0
network 172.16.0.0
network 192.168.1.0
!
ip nat inside source list 1 interface Ethernet0 overload
no ip http server
ip classless
ip route 10.0.103.0 255.255.255.0 172.16.2.2
!
!
access-list 1 permit 10.0.100.0 0.0.0.255
access-list 1 permit 10.0.102.0 0.0.0.255
access-list 1 permit 10.0.103.0 0.0.0.255
access-list 1 deny any
access-list 101 deny ip 64.127.106.128 0.0.0.7 any
access-list 101 permit ip any any
!
banner motd ^C
!!! WARNING UNAUTHORIZED ACCESS PROHIBITED !!! ^C
!
line con 0
exec-timeout 0 0
password 7 xxxxxxxxxxxxxxx
logging synchronous
login
line aux 0
line vty 0 4
access-class 1 in
exec-timeout 0 0
password 7 xxxxxxxxxxxxxx
login
!
!
end

SITE_C
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Site_C
!
boot-start-marker
boot-end-marker
!
enable secret 5 $xxxxxxxxxxxxxxxxxxxxxxx.
!
no aaa new-model
no ip subnet-zero
no ip cef
!
!
no ip domain lookup
!
!
!
!
controller T1 1/0
shutdown
framing sf
linecode ami
!
!
interface FastEthernet0/0
ip address 10.0.103.1 255.255.255.0
duplex auto
speed auto
no cdp enable
!
interface Serial0/0
ip address 172.16.2.2 255.255.255.0
no ip route-cache
no cdp enable
!
interface BRI0/0
no ip address
shutdown
!
router rip
network 10.0.0.0
network 172.16.0.0
network 192.168.1.0
!
no ip http server
no ip classless
ip route 10.0.100.0 255.255.255.0 172.16.2.1
!
!
access-list 1 permit 10.0.100.0 0.0.0.255
access-list 1 permit 10.0.103.0 0.0.0.255
access-list 1 deny any
banner motd ^C
!!! WARNING UNAUTHORIZED ACCESS PROHIBITED !!! ^C
!
line con 0
exec-timeout 0 0
password 7 xxxxxxxxxxxxx
logging synchronous
login
line aux 0
line vty 0 4
access-class 1 in
password 7 xxxxxxxxxxxxxx
login
!
!
end

 
you need to use rip version 2 so that you can use classless networks. as it is now your using rip v1 which is bound to classfull address's

you can add to your routing config the following lines

version 2
no auto-sum

and your routing table should update.

give that a go..
 
Well, I've managed to apply those statements on both routers and saw the route tables updated. Still can't ping 192.168.1.1 from Site_C or reach the internet from a laptop staticly connected to site_C. I'm wondering if this is all due to the fact I've got dhcp going on Site_A's router. Below are the route tables for A and C.

Site_A
Gateway of last resort is 192.168.1.1 to network 0.0.0.0

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.2.0 is directly connected, Serial0
10.0.0.0/24 is subnetted, 2 subnets
S 10.0.103.0 [1/0] via 172.16.2.2
C 10.0.100.0 is directly connected, Ethernet1
C 192.168.1.0/24 is directly connected, Ethernet0
S* 0.0.0.0/0 [254/0] via 192.168.1.1

Site_C
Gateway of last resort is not set

172.16.0.0/24 is subnetted, 1 subnets
C 172.16.2.0 is directly connected, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.103.0 is directly connected, FastEthernet0/0
S 10.0.100.0 [1/0] via 172.16.2.1
R 192.168.1.0/24 [120/1] via 172.16.2.1, 00:00:17, Serial0/0

Many thanks again for help on this.
 
Try changing the default route on "C" to the following:

ip route 0.0.0.0 0.0.0.0 ip route 172.16.2.1

 
sorry bout the typo...should be:

ip route 0.0.0.0 0.0.0.0 172.16.2.1
 
Might also change the followinf on "C"

no ip subnet-zero
Change to
ip subnet-zero
 
Thanks, yeah I applied them and still not getting out. Not sure what is holding C from getting through. Maybe it's the configuration of A?
 
Most likely, your linksys will need a route for 10.0.103.0 255.255.255.0 pointing to site A's E0. Start from the linksys and see how far you can ping things. May need a similar route for 172.16.2.0 255.255.255.0 to see the WAN interfaces.
 
Router A

interface Ethernet0

ip access-group 100 in

There is no list to support it.
Also add
ip route 0.0.0.0 0.0.0.0 ethernet0


 
Gotcha, yeah I made a typo on the access list and was actually supposed to be 100...yeah it's a wonder why I was still receiving icmp requests from an outside port scanner. I'll go ahead and apply the ip route as well and see if it helps. Thanks again.
 
Just a quick note, I am able to ping 10.0.103.50 which is a static connection (workstation) so communication going in from linksys seems to be okay.
 
Okay! Finally managed to figure it out. Since Site_A is using NAT translation from just E1 to E0, I thought why not add "ip nat inside" to interface s0 on the 2514? Makes sense since site_a wouldn't know where to route those incoming packets from the 172.16.2.0(S0)network unless it was part of the NAT configuration. Now both Site_A and Site_C are rockin. thanks to all for the advice BTW :)

labgrl
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top