Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations TouchToneTommy on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

827 with Verizon DSL

Status
Not open for further replies.

farslayer9

IS-IT--Management
Jul 29, 2004
8
US
I've been fairly unsuccessful getting my 827 router connected to Verizon DSL. Here is my configuration (this forum had a few configs that seemed to be working), and any help is greatly appreciated. My DSL modem is a Westel and it is set to bridge, so my 827 must utilize NAT. I have confirmed my username/password as well and am currently using a crappy Linksys router.

Thanks!!!


Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 549McClung
!
enable secret 5 #####
enable password #####
!
!
!
!
!
ip subnet-zero
no ip routing
!
!
!
bridge irb
!
!
!
interface Ethernet0
description LAN
ip address 10.11.12.250 255.255.255.0
ip nat inside
no ip route-cache
no keepalive
no cdp enable
hold-queue 32 in
hold-queue 100 out
!
interface ATM0
no ip address
no ip route-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description WAN
no ip route-cache
pvc 0/35
pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp chap hostname #####
ppp chap password 7 #####
!
ip nat inside source list 101 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
access-list 101 permit ip 10.11.12.0 0.0.0.255 any
dialer-list 1 protocol ip permit
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
transport input none
stopbits 1
line vty 0 4
password #####
login
!
scheduler max-task-time 5000
end
 
If you have a modem, you don't need a dialer config. In fact, you don't need the modem. Just the 827. I will post a complete config in a while...

Burt
 
Hi, I'm a moron, I meant to say that the modem is going to be chucked, I want the 827 to serve as the modem AND the router. Sorry about the confusion.
 
interface ATM0/0.1 point-to-point
oam-pvc manage

interface Ethernet0
ip mtu 1492

interface Dialer1
ip tcp adjust-mss 1452
ppp authentication pap chap callin
ppp chap hostname xxxxxxxxxxxx
ppp chap password xxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxx password xxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request

ntp clock-period 17180367
ntp server 64.113.32.5 source Dialer1

You need to tell the router how to authenticate the circuit with pap/chap callin. The ntp config is on the house...

Also, MTU for adsl is 1492, not the default 1500. The ip tcp adjust-mss 1452 is tcp max segment size, and that = 1492 MTU.

Burt

 
Ok, here's my new config, which I've not yet tried (I'll try it in a second and post the results of a show int if it fails). I was unable to set the NTP server (unrecognized command) and adjust-mss on the Dialer1 interface was also not an option under ip tcp or anywhere else, so I just set the MTU on the dialer1 interface to 1492. Also, I set an encapsulation type of aal5snap on the ATM0.1 interface, which I saw may be necessary. If this doesn't work, is there a way to log where the connection fails?

Thanks!


Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 549McClung
!
enable secret 5 #####
enable password #####
!
!
!
!
!
ip subnet-zero
no ip routing
!
!
!
!
!
interface Ethernet0
description LAN
ip address 10.11.12.250 255.255.255.0
ip mtu 1492
ip nat inside
no ip route-cache
no ip mroute-cache
no keepalive
no cdp enable
hold-queue 32 in
hold-queue 100 out
!
interface ATM0
no ip address
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description WAN
no ip route-cache
no ip mroute-cache
pvc 0/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname #####
ppp chap password 7 #####
ppp pap sent-username ##### password 7 #####
ppp ipcp dns request
ppp ipcp wins request
!
ip nat inside source list 101 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
access-list 101 permit ip 10.11.12.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
line con 0
transport input none
stopbits 1
line vty 0 4
password #####
login
!
scheduler max-task-time 5000
end
 
Here is the most recent configuration and the results of a show int (the changes above didn't work). Any help is greatly appreciated!!



Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 549McClung
!
enable secret 5 #####
enable password #####
!
!
!
!
!
ip subnet-zero
no ip routing
!
!
!
!
!
!
interface Ethernet0
description LAN
ip address 10.11.12.250 255.255.255.0
ip mtu 1492
ip nat inside
no ip route-cache
no ip mroute-cache
no keepalive
no cdp enable
hold-queue 32 in
hold-queue 100 out
!
interface ATM0
mtu 1492
no ip address
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description WAN
mtu 1492
no ip route-cache
no ip mroute-cache
pvc 0/35
encapsulation aal5snap
pppoe-client dial-pool-number 1
!
!
interface Dialer1
mtu 1492
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname #####
ppp chap password 7 #####
ppp pap sent-username ##### password 7 #####
ppp ipcp dns request
ppp ipcp wins request
!
ip nat inside source list 101 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
access-list 101 permit ip 10.11.12.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!
line con 0
transport input none
stopbits 1
line vty 0 4
password #####
login
!
scheduler max-task-time 5000
end



Results of a show int


ATM0 is up, line protocol is up
Hardware is PQUICC_SAR (with Alcatel ADSL Module)
MTU 1492 bytes, sub MTU 1492, BW 640 Kbit, DLY 80 usec,
reliability 5/255, txload 1/255, rxload 1/255
Encapsulation ATM, loopback not set
Keepalive not supported
Encapsulation(s): AAL5, PVC mode
11 maximum active VCs, 3 current VCCs
VC idle disconnect time: 300 seconds
Last input 00:09:38, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: Per VC Queueing
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
1 packets input, 74 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 2 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 2 interface resets
0 output buffer failures, 0 output buffers swapped out
ATM0.1 is up, line protocol is up
Hardware is PQUICC_SAR (with Alcatel ADSL Module)
Description: WAN
MTU 1492 bytes, BW 640 Kbit, DLY 80 usec,
reliability 5/255, txload 1/255, rxload 1/255
Encapsulation ATM
16 packets input, 1146 bytes
0 packets output,0 bytes
0 OAM cells input, 0 OAM cells output
AAL5 CRC errors : 0
AAL5 Oversized SDUs : 0
Dialer1 is up (spoofing), line protocol is up (spoofing)
Hardware is Unknown
Internet address will be negotiated using IPCP
MTU 1492 bytes, BW 56 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, loopback not set
DTR is pulsed for 1 seconds on reset
Last input never, output never, output hang never
Last clearing of "show interface" counters 00:59:37
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/16 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
0 packets output, 0 bytes
Ethernet0 is up, line protocol is up
Hardware is PQUICC Ethernet, address is 00b0.c28e.3c36 (bia 00b0.c28e.3c36)
Description: LAN
Internet address is 10.11.12.250/24
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:00, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/100, 0 drops; input queue 0/32, 0 drops
5 minute input rate 2000 bits/sec, 2 packets/sec
5 minute output rate 1000 bits/sec, 2 packets/sec
2308 packets input, 172826 bytes, 0 no buffer
Received 307 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
1462 packets output, 136564 bytes, 0 underruns(0/0/0)
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 
Take the aal5snap encaps off, and try again. This time, do this...

router#conf t
router(config)#int atm0
router(config-if)#shut
router(config-if)#exit
router(config)#int di1
router(config-if)#shut
router(config-if)#exit
router(config)#do deb ppp neg
router(config)#do deb ppp authe
router(config)#int atm0
router(config-if)#no shut
router(config-if)#exit
router(config)#int di1
router(config-if)#no shut
router(config-if)#end
router#

You should see if the interface goes up, then down, look in the results of "debug ppp neg" and "debug ppp authe"---if you see something like "no entry for blablabla", then the username/password is/are wrong...post the results if you're not sure.

Burt
 
Ok, i've enabled debugging, but I have no idea how to actually display the results. Sorry i'm such a noob at Cisco.
 
Actually, you may be able to post a "sh log"...

What are you using to console? Hyperterminal? If so, Go to the top in HyperTerminal where it says transfer, and select "capture text". I think it then lets you choose a file, then you "start". But before you do, shut down the interfaces and input the debug commands. Then do the capture text and start, then turn the interfaces back up. Then copy and paste into here from that .txt file. I would recommend using Tera Term or PuTTy...

Burt
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top