I have a Cisco 2620 with 64MB memory (Max memory for the router model) running 12.3(19)ipbase. This router has been rock solid for a very long time. 3 months ago, we added a second T1 and using IP CEF to join them together (MLPPP is not supported by the ISP).
Regularly now, (Once a week) the router gets a semi lockup condition in that you can talk to the router, checks its configs, but BOTH serial ports are marked down. Shut and No Shut doesn't bring them back, you have to reboot the router.
I am wondering maybe with all the routes and CEF that the router is running out of memory. (Maybe i need something like no ip-route cache). I sniffed the network packets and there isn't anything unusual out there (no slammer, DOS, etc).
I have already swapped T1 cards on port interfaces out, have had the lines checked, etc..
Here is the config, it is very very basic. Hopefully someone will see something I am missing.
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname arh_hq_internet
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip name-server 146.145.64.2
!
username xxx privilege 15 password 7 xxxxxxxxxxxxx
username xxxxxx privilege 15 password 7 xxxxxxxxxxx
!
!
class-map match-any VOIP
match ip dscp ef
match ip dscp af41
!
!
policy-map PRIORITY
class VOIP
priority 768
class class-default
fair-queue
random-detect dscp-based
!
!
!
interface FastEthernet0/0
description Ethernet to Sonicwall 2040
bandwidth 100000
ip address xxx.xxx.xxx.161 255.255.255.248
speed 100
full-duplex
!
interface Serial0/0
description T1 to ATX Circuit ID:HCGS307601NJ Jack J3
bandwidth 1536
ip address xxx.xxx.xxx.170 255.255.255.252
service-policy output PRIORITY
!
interface Serial0/1
description T1 to ATX Circuit ID:HGCS314067NJ Jack J1
bandwidth 1536
ip address xx.x.xxx.38 255.255.255.252
service-policy output PRIORITY
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/1
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
login local
line aux 0
line vty 0 4
exec-timeout 30 0
login local
!
!
end
Thanks
Phil Gordemer
ARH Associates
Regularly now, (Once a week) the router gets a semi lockup condition in that you can talk to the router, checks its configs, but BOTH serial ports are marked down. Shut and No Shut doesn't bring them back, you have to reboot the router.
I am wondering maybe with all the routes and CEF that the router is running out of memory. (Maybe i need something like no ip-route cache). I sniffed the network packets and there isn't anything unusual out there (no slammer, DOS, etc).
I have already swapped T1 cards on port interfaces out, have had the lines checked, etc..
Here is the config, it is very very basic. Hopefully someone will see something I am missing.
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname arh_hq_internet
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
ip cef
!
!
!
ip name-server 146.145.64.2
!
username xxx privilege 15 password 7 xxxxxxxxxxxxx
username xxxxxx privilege 15 password 7 xxxxxxxxxxx
!
!
class-map match-any VOIP
match ip dscp ef
match ip dscp af41
!
!
policy-map PRIORITY
class VOIP
priority 768
class class-default
fair-queue
random-detect dscp-based
!
!
!
interface FastEthernet0/0
description Ethernet to Sonicwall 2040
bandwidth 100000
ip address xxx.xxx.xxx.161 255.255.255.248
speed 100
full-duplex
!
interface Serial0/0
description T1 to ATX Circuit ID:HCGS307601NJ Jack J3
bandwidth 1536
ip address xxx.xxx.xxx.170 255.255.255.252
service-policy output PRIORITY
!
interface Serial0/1
description T1 to ATX Circuit ID:HGCS314067NJ Jack J1
bandwidth 1536
ip address xx.x.xxx.38 255.255.255.252
service-policy output PRIORITY
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/1
ip route 0.0.0.0 0.0.0.0 Serial0/0
no ip http server
!
dialer-list 1 protocol ip permit
!
line con 0
login local
line aux 0
line vty 0 4
exec-timeout 30 0
login local
!
!
end
Thanks
Phil Gordemer
ARH Associates