Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations TouchToneTommy on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

1760v with Verizon DSL PPPOE

Status
Not open for further replies.

youcandoit

Technical User
Feb 14, 2005
159
US
Hello,

I recently purchased a 1760 v and wic 1 enet and would like to replace my linksys wrt54g as the PPPOE client to my service provider. I understand i need to set up a dialer and NAT but am slightly confused. I was hoping you guys here could help.

Thanks
 
at first glance it looks good. ill let you know. thanx
 
here is my config it still doesnt work. is there anything im missing? i reviewed it several times.

sho run
Building configuration...

Current configuration : 1327 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
voice-card 3
!
no aaa new-model
ip subnet-zero

!
!
!
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
no ftp-server write-enable
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
description adsl lan interface
ip address 10.0.0.1 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat inside
no ip mroute-cache
half-duplex
pppoe enable
no cdp enable
!
interface FastEthernet0/0
ip address dhcp
speed auto
!
interface Dialer1
description adsl WAN dialer
ip address negotiated
no ip unreachables
ip nat outside
encapsulation ppp
no ip mroute-cache
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname vze3gfgy
ppp chap password 0 pat123
ppp pap sent-username vze3gfgy password 0 pat123
!
ip nat inside source list 10 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
!
access-list 10 permit 0.0.0.0 255.255.255.0
no cdp run
!
voice-port 3/0
!
voice-port 3/1
!

!
!
line con 0
line aux 0
line vty 0 4
!
end

Router#sho ver
Cisco Internetwork Operating System Software
IOS (tm) C1700 Software (C1700-IPVOICE-M), Version 12.3(7.10), MAINTENANCE INTERIM SOFTWARE
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 23-Mar-04 04:12 by dchih
Image text-base: 0x80008120, data-base: 0x813C3D58

ROM: System Bootstrap, Version 12.2(4r)XL, RELEASE SOFTWARE (fc1)

Router uptime is 27 minutes
System returned to ROM by reload
System image file is "flash:c1700-ipvoice-mz.123-7.10.bin"

cisco 1760 (MPC860P) processor (revision 0x200) with 59017K/6519K bytes of memory.
Processor board ID FOC06380SEF (491801823), with hardware revision BB67
MPC860P processor: part number 5, mask 2
Bridging software.
X.25 software, Version 3.0.0.
1 Ethernet/IEEE 802.3 interface(s)
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
32K bytes of non-volatile configuration memory.
--More--  32768K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Router#sho log
Syslog logging: enabled (0 messages dropped, 1 messages rate-limited, 0 flushes, 0 overruns, xml disabled)
Console logging: disabled
Monitor logging: level debugging, 0 messages logged, xml disabled
Buffer logging: disabled, xml disabled
Logging Exception size (4096 bytes)
Count and timestamp logging messages: disabled
Trap logging: level informational, 20 message lines logged
Router#
 
Need to delete the following:

access-list 10 permit 0.0.0.0 255.255.255.0

And re-enter it as:


access-list 10 permit 10.0.0.0 255.255.255.0
 
did this config work for you? i am trying to set up a 1750 with a wic-1enet using pppoe and am having no luck.
 
so is your modem plugged into the Fast E then?

your config is missing a little bit of info...

interface Ethernet0/0
description LAN
ip address 10.0.0.1 255.255.255.0
no ip redirects
no ip proxy-arp
ip nat inside

interface FastEthernet0/0
description ADSL Wan Interface
no ip address
no ip redirects
no ip proxy-arp
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface Dialer1
description ADSL WAN Dialer
bandwidth 3000
ip address negotiated
no ip redirects
no ip proxy-arp
ip mtu 1492
ip nat outside
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer idle-timeout 0
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username USERNAME password PASSWORD
ppp ipcp dns request

 
sorry,
the bandwidth statement above is not required...
i just added it for mine for reference.
 
no mine didnt work and has been changed. i will post config again once i make changes.
 
I noticed the 255.255.255.0 mask on that access-list 10.

Doesn't an access-list use a wildcard mask, such as 0.0.0.255?

Just a thought...

Experience is a tough teacher.
The test comes first, the lesson comes later...
 
More specifically, that should be:

access-list 10 permit 10.0.0.0 0.255.255.255

That means the first octet must match, but all of the other octets can be any value (between 0 and 255).

Experience is a tough teacher.
The test comes first, the lesson comes later...
 
here is the important part that finally got mine going:

Code:
vpdn-group 1
 request-dialin
  protocol pppoe


interface Ethernet0
 description DSL WAN Interface
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 no ip mroute-cache
 half-duplex
 pppoe enable
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface FastEthernet0
 description DSL LAN Interface
 ip address 192.168.7.1 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip tcp adjust-mss 1408
 no ip mroute-cache
 speed auto
 no cdp enable
!
interface Dialer1
 description DSL WAN Dialer
 ip address xx.xxx.xx.xx 255.255.255.248
 no ip unreachables
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username ********* password 0 ************
 crypto map towash
!
ip nat inside source list nonat interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server
no ip http secure-server
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top