×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Samsung SP1213N Wrong Native Size

Samsung SP1213N Wrong Native Size

Samsung SP1213N Wrong Native Size

(OP)
I got a new Samsung sp1213n.  The drive size was 6.5GB in windows xp for some reason, so I downloaded samsung's hard drive utility (hutil.exe) to resize it to its real size of around 120GB.  In hutil.exe the "Drive size" was 6500MB (approx) and the "native size" showed up as 114498MB.  I forget exactly what option I used, but somehow hutil.exe changed the drive's native size to 6500MB, too (instead of changing the drive size to 114498MB which I had THOUGHT it was going to do).

Now, I cannot size it any larger because the drive's "native size" is set to 6500MB even though it is actually much larger.  Amd hutil.exe cannot change the native size back!  CMOS auto detects it as 6.5GB.

The other samsung utility (disk manager) doesn't seem to do much good either.  Does anyone have any ideas?  Is there an easy way to fix this?  Could the hard drive be physically damaged?  Or is it just some firmware setting set wrong or something?  I don't think it's just a BIOS limitation because I should have been able to fix that with the samsung utilities (and I don't believe 6.5GB is a BIOS limitation boundary).  Any suggestions from someone with experience dealing with these drives would be greatly appreciated.  Thanks.

RE: Samsung SP1213N Wrong Native Size

I'd try a Win 98 boot disk to use "Fdisk" to re-partition (and format), and see if it shows the correct size.

RE: Samsung SP1213N Wrong Native Size

I have the same problem and have tried all the options in hutil and the disk manager without success. The SP1213N is attached as a slave alongside another 120GB master drive, so I am fairly confident that it is the drive and not the bios. I have also tried it in other PCs, all running XP. In my case the drive reports a native size of 32GBs and I do have the limiter jumper removed. The drive functions perfectly in all other respects.

If you find a solution please report back, I will do the same. I appreciate that this is not much help, but sometimes it aids one's sanity to know that you are not the only one with the problem.



 

RE: Samsung SP1213N Wrong Native Size

(OP)
I managed to fix it.  I got a freeware hard drive utility called hdat2 (www.hdat2.com if I remeber correctly).  I used this and it was able to detect the actual size and change both the drives current size and native size.  Next boot the BIOS detected it perfectly fine.

There's something on the drive's firmware that identifies what size it is to the BIOS.  It can be set smaller ro artifically limit the size of the drive so the BIOS will always detect it as smaller.  This should be able to fix it.  Run it and go into menu and the resize option.  It should show your drive's current set size and the actual size.  Get it just to restore it.  In my case the current size and the native size were both set smaller so I had to browse a few other options (I forget what exactly) before it would detect the original size of 120GB.

According to Samsung 99.9% of the time it's the BIOS, but this is the other 0.1%.

Try that and it that doesn't work then either it really is a BIOS error or I have no idea.

RE: Samsung SP1213N Wrong Native Size

Thanks for the information on the hdat2 utility. It also enabled me to restore my drive back to its correct size of 120GB.

It did not prove straightforward. I could not get hdat2 to action any commands on the drive until I first disabled all of the options under the commands/features menu including the Look Ahead and Write Cache. After that I used the DCO menu to do a Restore, rebooted and then used the Set Maximum Address to make the full native size available. Finally I re-enable the options in the commands/features menu, I had previously had to disable.

Thanks again for relating how you solved it.

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close