×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Print Spooler service terminated unexpectedly

Print Spooler service terminated unexpectedly

Print Spooler service terminated unexpectedly

(OP)
Hi,

since last week I see recurring Print Spooler crashes on our Win2K SP4 (English) File & Print server. The Event Viewer reports:

Source: Service Control Manager
Event ID: 7031

The Print Spooler service terminated unexpectedly.  It has done this 1 time(s).  The following corrective action will be taken in 60000 milliseconds: Restart the service.

I have cleaned out the spooler directory and rebooted the server but that didn't help.

Any ideas anyone?

Thanx,
Fred

RE: Print Spooler service terminated unexpectedly

I would try moving the spooler to another drive. Or at least a new location on the current drive.  

I had the same problem, I think it was caused by a bad sector on the drive but I'm not sure.  Anyway it was fixed by moving the spooler. (Printers folder --> file --> server properties --> advanced).

RE: Print Spooler service terminated unexpectedly

(OP)
Hi MoobyCow,

thanx for the advice, however, changing the spooler folder didn't help.  I have now reapplied SP4 and scheduled the server for reboot tonight, I'll know more tomorrow.

Thanx,
Fre

RE: Print Spooler service terminated unexpectedly

(OP)
Reinstalling SP4 didn't help, however I got 2 additional errors in the event log now:
The server service was unable to map error code 1727
and
The server service was unable to map error code 1726

On the Microsoft support site (Q199915), I found out that HP Webadmin might be the culprit. I deinstalled it and rebooted the machine. Since then, the spooler still crashes from time to time but one of the two extra errors are gone:
The server service was unable to map error code 1726
Now, I've removed an obsolete HP Jetadmin regkey and scheduled the server for reboot (will know more by tomorrow).

Greetz,
Fre

RE: Print Spooler service terminated unexpectedly

Sometimes you get a dodgy print job in the spooler folder. Remove what's in there (stop print server service first).. careful not to remove the driver files and then restart the spooler service.
This has happened to me now and again... I think the files are ecl files so please check before you remove anything... wouldn't want you to remove the wrong files.

RE: Print Spooler service terminated unexpectedly

(OP)
Hi, me again...

still the same problem even after removing the HP Jetadmin regkeys & rebooting.  I've now removed a printer which might be causing all this trouble. One of our users was complaining about his computer freezing when sending a job to the printer (HP Laserjet 2200 on an HP Jetdirect 170x printserver).  Strangely: this only happens when a Progress DB client is running in the background, and at exactly the same moment the spooler on the server hangs... I'm most curious, I'll let you know...

Fre

RE: Print Spooler service terminated unexpectedly

Having a similar problem with a Terminal Server, but there are no "network printers."  All of the printers are Local Printers printing to TCP/IP ports.  Maybe it's all the same...  Anyway, try the link below (MS Knowledge Base Article kb820550):
http://support.microsoft.com/kb/820550

Hope this helps!!!

RE: Print Spooler service terminated unexpectedly

Hello i have the same problem.
Any ideas anyone??  


Thanx
kris

RE: Print Spooler service terminated unexpectedly

(OP)
Hi Kris,

I never got the issue solved, no matter what I tried the error kept on coming back.  I finally moved all printers to a dedicated Windows 2003 server.

Grtz,
Fre

RE: Print Spooler service terminated unexpectedly

90% of the print spooler crashes I have seen are caused by 3rd party port monitors...

To remove 3rd party port monitors, you need to do some registry editing.  First go to HKLM\system\CurrentControlSet\ and backup the PRINT key.

Go to this registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors

These are the port monitors that are included in Windows. Do not touch these:
BJ Language Monitor
Local Port
PJL Language Monitor
Standard TCP/IP port
USB Monitor
Microsoft Document Image Writer Monitor (sometimes this one isn't there)

You might see instances of 3rd party monitors like the HP Master Monitor or 5si monitor.  Go into any key that is not in my previous list and look for the driver value.  Write this value down.  Once you have written that value down (it will be a .dll file) delete the entire 3rd party port monitor key (remember, do not delete the keys I mentioned above)

Now go to this key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Environments\Windows NT x86

You will see 1 to 3 subkeys.  They will be Version0, Version 2, and Version3.

Version 0: 9x printer drivers
Version 2: NT4 print drivers that operate in Kernel mode memory
Version 3: Win2k/NT4/XP/Win2k3 print drivers that operate ONLY in User mode.

In these keys, you will see different printer drivers.  Open those keys and look for the "Monitor" value.  There MAY be a .dll file listed in the monitor value.

IF that .dll file matches one from the list that you wrote down, erase it from the Monitor value.  Do not delete the monitor value.

Do this for all drivers in all version subkeys....

Restart the print spooler....

If a port monitor was causing your problem, then it should be resolved.

Port monitors for printers give you functions like telling you how many pages are left in a printer drawer.  They are not required for printing (except the ones mentioned in the begining)

If this doesn't resolve your issue, you'll need to get a user dump of the spooler and run it through a debugger.  That will tell you what file caused it to crash...

Dr Watson should also be set to capture a user dump.  Make sure that it is by clicking START>RUN and running the command "drwtsn32 -i" (without the quotes)

The following link will tell you about another utility called Userdump.exe. which you can use if Dr Watson doesn't capture the spooler crash...
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q264124

Good luck!


Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members!

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close