×
INTELLIGENT WORK FORUMS
FOR COMPUTER PROFESSIONALS

Log In

Come Join Us!

Are you a
Computer / IT professional?
Join Tek-Tips Forums!
  • Talk With Other Members
  • Be Notified Of Responses
    To Your Posts
  • Keyword Search
  • One-Click Access To Your
    Favorite Forums
  • Automated Signatures
    On Your Posts
  • Best Of All, It's Free!
  • Students Click Here

*Tek-Tips's functionality depends on members receiving e-mail. By joining you are opting in to receive e-mail.

Posting Guidelines

Promoting, selling, recruiting, coursework and thesis posting is forbidden.

Students Click Here

Jobs

Simple script with error 800A01AD

Simple script with error 800A01AD

Simple script with error 800A01AD

(OP)
I'm running a simple vbscript on WinXP SP2:

const HKEY_LOCAL_MACHINE = &H80000002
strComputer = "."
Set StdOut = WScript.StdOut
.......


On the 3rd line an error occurred
Script: c:\temp\read.vbs
Line: 3
Char: 1
Error: ActiveX component can't create object
Code:  800A01AD
Source: Microsoft VBScript Runtimeerror


Many examples on the internet use "WScript.StdOut" in there script. What's going wrong.


Please help!!!

RE: Simple script with error 800A01AD

Quote (HelpFile):

The StdIn, StdOut, and StdErr streams can be accessed while using CScript.exe only. Attempting to access these streams while using WScript.exe produces an error.

Hope This Helps, PH.
Want to get great answers to your Tek-Tips questions? Have a look at FAQ219-2884 or FAQ222-2244

RE: Simple script with error 800A01AD

(OP)
When I use cscript i got the following error:

c:\temp\read.vbs(3, 1) Runtimeerror Microsoft VBScript: ActiveX-component can't create object

Same problem...

RE: Simple script with error 800A01AD

Seems like a permission and/or security problem.
Have you administrative privileges when you run this script ?

Hope This Helps, PH.
Want to get great answers to your Tek-Tips questions? Have a look at FAQ219-2884 or FAQ222-2244

RE: Simple script with error 800A01AD

(OP)
Yes, I'm a full administrator

RE: Simple script with error 800A01AD

Hello kaul1jos,

With start | run, enter the command:
    wscript -regserver
see if it corrects the problem.

regards - tsuji

RE: Simple script with error 800A01AD

(OP)
still not working after wscript -regserver

RE: Simple script with error 800A01AD

kaul1jos,

Try config the firewall,

    set service type = REMOTEADMIN mode = ENABLE scope = SUBNET profile = DOMAIN

Refer to a previous thread for further ideas:
    http://tek-tips.com/viewthread.cfm?qid=927152

- tsuji

Red Flag This Post

Please let us know here why this post is inappropriate. Reasons such as off-topic, duplicates, flames, illegal, vulgar, or students posting their homework.

Red Flag Submitted

Thank you for helping keep Tek-Tips Forums free from inappropriate posts.
The Tek-Tips staff will check this out and take appropriate action.

Reply To This Thread

Posting in the Tek-Tips forums is a member-only feature.

Click Here to join Tek-Tips and talk with other members! Already a Member? Login

Close Box

Join Tek-Tips® Today!

Join your peers on the Internet's largest technical computer professional community.
It's easy to join and it's free.

Here's Why Members Love Tek-Tips Forums:

Register now while it's still free!

Already a member? Close this window and log in.

Join Us             Close